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Quick Tour
Welcome to WebNMS IoT Platform Eclipse Plugin
The documentation for Eclipse Plugin is arranged in a manner that makes information easily
accessible and understandable in the following way.


Quick Tour section provides an introduction to the Eclipse Plugin.



Setting up Development Environment provides the basics of working with the Eclipse
such as creating and working with Projects, multi user environment, modifying the
generated Source to the requirements, etc.



Customizing Services section provides all the details required by developers to
customize their WebNMS IoT application using the Eclipse Plugin.



Deploying Eclipse Application section provides information on how to deploy the
application created using Eclipse over WebNMS IoT



Known Issues and Limitations section provides known problems and associated
workarounds for the Eclipse Plugin.



FAQ section provides frequently asked questions about the Eclipse Plugin.

As always, we welcome your feedback on the product and will be happy to resolve any technical
queries that you may have with the product. Just send us a mail to WebNMS Support at iot-

support@webnms.com

Copyright @2018
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About Eclipse



Introduction



What does the Eclipse Studio Plug-in consist of ?

Introduction
Eclipse, Integrated Development Environment is a widely used open source development
environment. WebNMS now provides WebNMSEclipsePlugin which will seamlessly plug into the
Eclipse IDE and provide you with a powerful suite of Wizards and Tools that help you to develop
your IoT application very fast.
What does the Eclipse Studio Plug-in consist of ?
The Plugin comes with an intuitive set of wizards and tools for customizing the various services
offered by WebNMS. These tools support the entire development cycle of an management
application from modeling the gateway component as a managed resource to customizing
services to finally packaging and installing the application over WebNMS IoT Framework.
Some of the salient functions offered by the Plug-in are:


Modeling the resources such as IoT regions, sites, gateways, sensors etc, that can be
managed by WebNMS IoT.



Defining fault management for the device and processing them based on the required
criteria to generate events or alarms.



Creating screens for performing configurations on the device.



Defining performance management for the device in terms of data collection, status
polling.



Packaging the application as a downloadable NAR (NMS Archive) that can be installed on
any WebNMS.

The Eclipse Plugin is built on the extensible and platform-independent Java Technology and has a
highly intuitive graphical user interface. This is sure to enhance the productivity of the IoT
application building teams. The plugin has been designed keeping in mind the developer and
domain expert who normally form part of the development teams of IoT vendors or large
enterprises.
Take a peep into WebNMS IoT's latest offering for creating management applications easily and
quickly. We are confident you will find it of immense use. To make your task easier, the
documentation bundled will help you walk you through the various features offered in the
plugin along with real-time illustrations of the key features and services. As always, we welcome
your feedback and will be very glad to support you throughout your evaluation of the product
and the development of your applications.

Copyright @2018
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Getting Started with Eclipse



Pre requisites for Eclipse IDE
o



Software requirements

Procedure to start Eclipse IDE

Pre requisites for Eclipse IDE
The following are the pre requisites for WebNMS IoT application development using Eclipse.

Software requirements


Eclipse version Kepler or higher



JDK version 1.7 or higher



WebNMS IoT 6.0



WebNMS Eclipse Plugin

Procedure to start Eclipse IDE

For Eclipse - Kepler Version



Install the recommended Eclipse (version Kepler ) in your machine.
Get the latest WebNMS - Eclipse plugin (WebNMSEclipsePlugin.jar file) from <WebNMS
IoT Home>/StudioTools/Studio/jars directory and unzip this jar file in the <Eclipse
Installed directory>

For Eclipse - Any Higher Version



Install the recommended Eclipse (version Kepler or higher) in your machine.
Launch Eclipse.
To start Eclipse IDE. Use the script with the - vm option as given below:
Command for Linux machine:

./eclipse -vm <JDK 1.7 Home>/bin/java

Copyright @2018
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Command for Windows machine:

eclipse -vm <JDK 1.7 Home>\bin\java

If you are installing a newer version of our plug-in over, please use the "-clean"
option in the command line while starting Eclipse IDE:
Example: ./eclipse -vm <JDK 1.7 Home>/bin/java -clean
o
o
o
o

o

o
o
o

Copyright @2018

Click Help > Install New Software menu option.
Click Add, and specify the name WebNMSEclipsePlugin.
Click the Local button, and browse and select the Plugin location.
Click Add button to submit. In the text area, a combo box with the text There
are no categorized items is displayed. By default, eclipse groups the plugin
items by category.
Uncheck the combobox Group Items by Category. In the text area, the name
and version of the plugin WebNMS Development Plugin and Version 1.3.1 is
displayed.
Select the WebNMS Development Plugin, and click the Next > Next buttons
in the subsequent screens.
Selct Accept the License, and click Finish. The Security Warning dialog box
will be displayed.
Choose Install Anyway, and Choose Restart Now.
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Technical Support
Technical Support provides answers to your technical questions about the WebNMS Eclipse
plugin. We provide the best support and specialize in resolving the most complex problems
encountered during the process of working with the plug-in. The hallmark of our support is rapid
and knowledgeable response to customer queries from our product developers-cum-support
specialists.
For support and bug-report, please send e-mails to iot-support@webnms.com
Please provide the following information while sending support mails:
1. Eclipse Project Details
2. Logs and Debug messages. (Eclipse logs contained in a ".logs" file can be found in
<Eclipse Workspace>/.metadata directory)
Tell us also what you think of the plugin. We value your feedback and will use it to provide better
services and products for our customers.

Copyright @2018
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Setting up Development Environment
Setting up Development Environment
The first step in building an application is setting up the development environment. The Eclipse
supports concurrent project development whereby many people in a team can work together on
development environment. Please follow the steps below to setup the development
environment for working with the Eclipse.



Creating a New project



Viewing Project Details



Working with Files



Working with External Tools



Integrating Help

Copyright @2018
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Creating a Project in Eclipse



Overview



Creating the IoT Development Project



Working with Source Folders
o

Existing default source folders in the project

o

Procedure to create new source folder in the project

o

Procedure to copy source files in the WEBACTIONCLASSES folder

Overview
The first step in working with the Eclipse is creating a Project. A Project created in Eclipse
copies the necessary source files and configuration files from the reference WebNMS IoT
to the workspace where the project will be stored. The Eclipse workspace is created to
separate the development environment from the runtime WebNMS and make it easier for
grouping the necessary information while packaging the project. To create WebNMS IoT
application development project in Eclipse follow the procedure given below:
Creating the IoT Development Project


In the Eclipse IDE screen, select File > New > Create IoT Project menu. Alternatively, you
can click the Create IoT Project
toolbar button. IoT Development Project Wizard
screen pops up.



In the Project Properties screen, enter a name for the project in Project Name text field
and use the Browse button to select the WebNMS IoT Home directory. WebClient
support can also be enabled in the same wizard.



Click the Finish button.



You will find the created project under the Package Explorer tree.

Copyright @2018
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Working with Source Folders
Existing default source folders in the project
By default the following source folders will be available in the IoT Development
Project:


SERVER



WEBACTIONCLASSES
(This folder is created if the Enable WebClient Development option is
selected in the above screen)

You can also create new source folders using the procedure given below:
Procedure to create new source folder in the project


Select your project in the Package Explorer.



Right-click and select File > New > Source Folder menu. "New Source Folder"
wizard screen pops up.



In the screen, project name is pre-filled in Project Name text field and enter a
name for the folder in Folder Name text field or use the Browse button to select
from the existing directories.



Click Finish button. You will find the new source folder created under your
project in the Package Explorer tree.
The output folder for the newly created source folders will be automatically set to
the default output folder configured for the project. The default output folder is
classes folder present in the project. You can use the existing default source folders
of the project or new source folders created by you to create source files.

Procedure to copy source files in the WEBACTIONCLASSES folder


Copy the content of the webclient related java source file.



Select the WEBACTIONCLASSES in the Project Explorer tree.



Right click and select the Paste option. The source file will be copied along with
the package structure name.

Copyright @2018
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Viewing Project Details



Overview



Project Properties



Modifying WebNMS Home Details



Deployment Jar Configuration

Overview
Properties for the project created in Eclipse are set based on the information provided in the
New Project Wizard. The properties are applied for the complete project. To modify/edit the
WebNMS IoT Home Details, invoke the Project Properties dialog.
By default, the Project Properties dialog displays all the information set in the Project Wizard at
the time of the creation of the Project.


Project Properties



Modifying WebNMS Home Details



Deployment Jar Configuration

Project Properties is used to view the Project Details.

Project Properties
Select the project in the Package Explorer, you can notice Project Properties menu and icon
get enabled.




Select WebNMS > Project Properties menu. Alternatively, you can click the Project
Properties
toolbar button.
o

IoT Project Properties screen pops up.

o

In the IoT Project Properties screen, Project Details such as Project Name ,
WebNMS Installation Directory, WebNMS Context , WebNMS Version,
ServicePack Version are displayed.

Click OK.

Modifying WebNMS Home Details



Click Browse to modify the WebNMS Installation Directory. Classpath/Buildpath for the
project will be automatically updated with the newly specified WebNMS IoT Home.

Copyright @2018
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Click the Edit button to configure the deployment jar and type for the source folder.



Click the OK button to save the changes in the ProjectDetails.xml file.

Deployment Jar Configuration
The Deployment Jar Configuration option is also available in the Project Properties dialog. To
change the deployment jar and type of the source folder, select the Source folder row and click
the Edit button. From the dialog, select the jar and type from the drop down list boxes. The
deployment jar and type can be modified for SOURCE.
Follow the steps given below to create a new jar:
1. In the Select jar and type for source folder dialog, click the Create New Jar
button. The Create New Jar dialog will be displayed.
2. Enter the name of the jar to be created.
3. Click OK. The jar name gets added to the combo box.
4. Click OK in the Select jar and type for source folder dialog. The details will be
updated in the row of source folder.

Copyright @2018
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Note: While packaging the project, the class files present in the output class of the
source folder will be packaged with the newly created jar name.

Note: In the Deployment Jar Configuration, if the Common.jar is selected as the
deployment jar for the source folder, the class files present in the output classes of
the source folder will get packaged into the Server.jar. Therefore, when there is
requirement to have the class file in the server classpath, then the Common.jar
option can be selected.

Copyright @2018
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Working with Files



Overview



Steps to import WebNMS configuration files to Eclipse

Overview
In Eclipse, files (xml, java, conf, txt, etc.) can be created and edited. All source files generated in
the Project and configuration files copied to the workspace can be viewed, edited and user code
can be added as required.

Steps to import WebNMS configuration Files to Eclipse
In Eclipse, it is possible to Import a file from the local file system into the workspace. To Import
the WebNMS Configuration files to Eclipse, it is necessary to perform the following steps.


Right Click the Package Explorer Window and select Import option. "Import" Dialog
screen is displayed.



In the "Import" Dialog screen, Select Import WebNMS Conf File from Conf File Import.



Click Next button to view the " WebNMS Conf File Import " wizard.



In the Import WebNMS Conf File screen, import a file from the given WebNMS IoT
installation directory into the IoT Development project.



In the Select File text field , Click Browse to select the file that is to be imported.



Select the Parent Folder to where the files are to be imported. (By default the file will be
placed inside the "<projName>/resources" directory in the same directory structure as
present in WebNMS.)



Click Finish button.
The file gets imported to the Parent Folder in the Package Explorer Window.

Copyright @2018
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Working with External Tools



Deploy the Developed Application on WebNMS



Performing Security Administration Operations

You can develop applications and deploy the applications from the Eclipse IDE itself. The
procedure involved in deploying the application on WebNMS using Deployment Wizard menu.
Deploy the Developed Application on WebNMS
After developing the IoT application and packaging it as a NAR file, you need to deploy it in
WebNMS. Use the Deployment Wizard to install the NAR file over WebNMS. The Deployment
Wizard automatically takes care of conf files and resource related changes.
You can invoke the Deployment Wizard by using the WebNMS > Tools > Deployment Wizard
menu.
For details on deploying developed Application read the section Developer Guide > Designer
Tools > Deployment Tool.

Performing Security Administration Operations
The Security Administration User Interface can be invoked from Eclipse, and used to configure
the security information in the WebNMS.
You can invoke the Security Administrations UI by using the WebNMS > Tools > Security Admin
Tool menu.
For more details on Security Administration, please refer to the Security Services section in the
Developer Guide.

Copyright @2018
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Integrating WebNMS Studio help
The Eclipse InfoCenter offers an actively maintained output for WebNMS EclipsePlugin Help. It
enable users to access the WebNMS Eclipse Plugin help contents. For this the WebNMS Eclipse
Plugin help contents have to be integrated into Eclipse InfoCenter. This helps the customers
(developers) to view the information at offline or at a remote client site. It guides the user to
work with Eclipse Plugin and other related external tools.
Follow the below steps to integrate WebNMS Eclipse Plugin help into Eclipse InfoCenter.


Apply the WebNMSEclipsePlugin in your eclipse installation by unzipping the
WebNMSEclipsePlugin.jar in the <Eclipse Install Home>. Please refer Procedure to start
Eclipse IDE for more details.



Inside the <Eclipse Install Home>/plugins directory the help plugin archive
(com.adventnet.nms.IoTDevelopment.help_1.3.1.jar) will be available. Extract this jar file
into a folder with name as 'com.adventnet.nms.IoTDevelopment.help_1.3.1'. Now the
help plugin is converted from Archive format to exploded format.



Download the Eclipse Plugin Help documentation Zip from
http://www.webnms.com/iot/documentation.html. Rename the zip as "doc.zip" and
place it in the <Eclipse installed
directory>/plugins/com.adventnet.nms.IoTDevelopment.help_1.3.1.

Now Restart Eclipse with the "-clean" option.
To invoke Eclipse InfoCenter in Eclipse Plugin, Click Help->Help Contents.

Copyright @2018
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Customizing Services
Customizing Services
In order to build a complete IoT solution, you need to customize the various services offered by
WebNMS IoT. In this section, you will see how Eclipse Plugin helps you customize each of these
services and what are the various tools Eclipse Plugin offers to customize each of these services.
To start customizing the various services, the first step is modeling the resources to be managed.
Accordingly, this section starts with modeling resources and goes on to customizing the
management services of WebNMS. The topics are arranged in a fashion that is typical of the
order in which Services are customized in an IoT building cycle.



Resource Modeling



Fault Management



Performance Management



Server Configuration



Configuring Policies



Setting Logging Parameters



Configuring Backup Service



Setting Failover Parameters



Debugging Applications Built in Eclipse



Rebranding

Copyright @2018
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Modeling Resource
Modeling Resource

Modeling your resources is made very easy and comprehensive with the Model Managed Object
Wizard. With the Wizard, you can model your device as a managed resource for WebNMS IoT in
four easy steps. The Managed Object Wizard generates the hibernate mapping file for the
managed resource. The Generate Java Source menu can be used to auto-generate the java code
for the Managed Object.
From the Model Managed Object Wizard, you can


Extend Base Objects from a set of parent resources.



Configure field sizes for attributes depending on the database.

To work with the Managed Object Wizard for creating managed resources, please read Creating
Managed Resource.
To model other resources such as extended Alert, Event, and User-Object (that do not extend
any of the ManagedObject base classes) also the same Model Managed Object Wizard cab be
used. Please refer the following sections for more details:



Extending Events



Extending Alert



User-Object Modeling

Copyright @2018
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Creating Managed Resource



Overview



Model a Managed Object



Generate a Java Source Code



Actions for Modifying and Deleting the MO

Overview
The first step in creating an IoT application is Modeling the Managed Resources, this is done
using the Model Managed Object Wizard. This wizard will guide you through the steps of defining
the ManagedObject properties. The final output of this wizard is the hibernate mapping file. This
file can in turn be used to generate the bean class using the Generate Java Source menu. The key
feature of the wizard is the MIB support provided to simplify the task of defining unique
properties for the Managed Resource.

Model a Managed Object
Select the project or source folder in the Package Explorer , you can notice Model Object menu
and icon get enabled.


Select WebNMS > Modeling > Model Object menu. Alternatively, you can click the Model
Object
toolbar button. Package Structure Editor screen pops up.
o

In the Package Structure Editor screen, enter the package name of the managed
object in the Package Name text field and enter modeled or extended object name
in the Modeled/Extended Object Name text field.

o

Click Next button. Component MO Table Details screen pops up.

o

In the Component MO Table Details screen, select Topo for the Select Module
option, select com.adventnet.nms.topodb.ManagedObject (or other default
ManagedObject class) from the drop down list for the Parent MO/Extended Object
Name option. Refer to the topic WebNMS Default Managed Objects in NMS
Developer Guide for more details.

o

Fill the Discriminator Value. This is a string that uniquely represents this object. By
default, this is the same as the Managed Object name.

o

The Generate Java Source option will be selected by default. On completing the
wizard, the java source will be automatically generated for the modeled MO with this
option selected. If the option is de-selected, the java source will not be generated.
The generated source file will be placed under the SERVER source folder. To store
the file in a different source folder in the project, select the folder from the drop
down box.

Copyright @2018
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o

Hibernate advanced properties that corresponds to each of the extended managed
resource is shown below. The default value is false. You can enable these properties
only if you need to configure some advanced fetching strategy at the hibernate
persistence level.
o

Is dynamic update required: This corresponds to "dynamic-update
(optional, defaults to false): Specifies that UPDATE SQL should be
generated at runtime and contain only those columns whose values
have changed."

o

Is select before update required : This corresponds to "selectbefore-update (optional, defaults to false): Specifies that Hibernate
should never perform an SQL UPDATE unless it is certain that an
object is actually modified. In certain cases (actually, only when a
transient object has been associated with a new session using
update()), this means that Hibernate will perform an extra SQL
SELECT to determine if an UPDATE is actually required."

o

Enable lazy fetching: This corresponds to "lazy (optional): Setting
lazy="true" is a shortcut equivalent to specifying the name of the
class itself as the proxy interface.The optional proxy attribute
enables lazy initialization of persistent instances of the class.
Hibernate will initially return proxies which implement the named
interface. The actual persistent object will be loaded when a method
of the proxy is invoked."

o

Is dynamic Insert required:"dynamic-insert (optional, defaults to
false): Specifies that INSERT SQL should be generated at runtime and
contain only the columns whose values are not null."

o

Mark superclass as abstract:If your superclass is abstract, map it
with abstract="true". Of course, if it is not abstract, an additional
table is needed to hold instances of the superclass. Refer the section
9.1.5. Table per concrete class for more details.

o

Click the Configure other Mapping Properties button to configure additional
mapping properties for the MO. When the button is clicked, Join-SubClass Attribute
Viewer screen pops up. For more details regarding the hibernate properties refer
the hibernate documentation

o

In the Join-SubClass Attribute Viewer screen, enter the Attribute Value against
the Attribute Name for the required attributes. The attributes are given below:

Copyright @2018

o

entity-name

o

node

o

subselect

o

persister

o

check

o

catalog

o

batch-size

o

schema

o

proxy
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o

In the Join-SubClass Attribute Viewer screen, click the Save button to save the
additional attributes for the MO and Cancel button to cancel the additional attribute
configuration.

o

Click Next button to view the MO Property Details screen

o

In the MO Property Details screen, click Add button to add properties for the MO.
The columns name, type, column, length will become editable. Enter the
appropriate values. Select the row of the property and click Delete button to delete
the property.

o

While modelling the MO, hibernate specific properties can be added as column to
the table. On clicking the Additional Property button, the hibernate specific
properties will be listed. To add a property to the table, select the check box for the
property and click the Save button. To remove the added property from the table,
de-selected the property and click the Save button.

Copyright @2018
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Note: The additional hibernate specific properties is not mandatory, and the wizard
can be completed by providing values for the default columns
(PropertyName,Column,Type,Length).


Click Finish button to complete MO Modeling.

You will find the modeled MO under <Your Project>/Referenced
Libraries/resources/classes/hbnlib/<Package of MO>/ <Modeled MO> in the Project Explorer
window.
The next step is to generate the Java source code for the Modeled MO using Java Source
Generator.
Generate a Java Source Code
Generate Java Source is to create the source code for the Modeled MO from the Xml file.
Select the project or source folder in the Package Explorer, you can notice Generate Java
Source menu and icon get enabled.
o Select WebNMS > Modeling > Generate Java Source menu. Alternatively, you can
click the Generate Java Source toolbar button. Java Source Generator screen
pops up.
o

In Java Source Generator screen , select the Xml file (multiple Xml files can also be
selected) for Generating Java Source and click >> button.

o

Select the source folder to generate the Java source.

o

Click OK.

It will generate the Java source code for the hibernate mapping files that are selected.
Modifying an Managed Object
There are two ways in which an Managed Object can be modified.


Directly from the Project Tree



Using the Modify Object Wizard
Directly from the Project Tree


Edit the <Modeled MO>.hbm.xml generated under <Your Project>/Referenced
Libraries/resources/classes/hbnlib/<Package of MO> in the Project Explorer
window.



Modify/Add the required properties and save the changes.



Now generate the Java Source using WebNMS > Modeling > Generate Java
Source menu for the modified XML.
o

Copyright @2018

Select the modified <Modeled MO>.hbm.xml file and click OK. It will
ask a prompt message to replace the file.
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o

Click OK. It will generate the Java source code for the hibernate
mapping file that is modified.

Using the Modify Object Wizard


Select WebNMS > Modeling > Modify Object from the main menu.
Alternatively, you can click the Modify Object toolbar button. Modify XML file
screen pops up.



Select the XML file and click the >> button.



Click the Modify button. The MO Modeling wizard will be invoked with the
populated values.



o

The Package Name and Modelled/Extended Object Name text field
will be non-editable.

o

In the MO table details page ,the Module Selection will be noneditable. All the other fields will be editable and the values can be
modified.

o

Click the Next button to go to MO Property Details page. The
properties can also be edited.

Click the Modify button to complete the Modify Object Wizard.

Deleting an Managed Object


Directly from the Project Tree



Using the Delete Managed Object Wizard
Directly from the Project Tree
To Delete the Managed Object, delete the generated .java file and <Modeled
MO>.hbm.xml file in the Package Explorer window in the eclipse. Remove the
corresponding entry from the <Your Project>/Referenced

Copyright @2018
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Libraries/resources/classes/hbnlib/<Package of MO>\hibernate.cfg.xml file.
For Example, The steps to delete managed object say sampleObj is shown below,


Right Click sampleObj.java file present in Package Explorer window under <Your
Project>/SERVER/<Package of MO>/sampleObj.java and select delete.



Right Click sampleObj.hbm.xml file present in Package Explorer window under
<Your Project>/Referenced Libraries/resources/classes/hbnlib/<Package of
MO>/sampleObj.hbm.xml and select delete.



Remove the entry sampleObj.hbm.xml from the
<YourProject>/ReferencedLibraries/resources/classes/hbnlib/<Package of
MO>\hibernate.cfg.xml file.
Before deleting the Managed Object sampleObj, the entry in hibernate.cfg.xml
file will be as shown below

<mapping resource="com/adventnet/nms/tutorials/ems/testObj.hbm.xml"/>
<mapping resource="com/adventnet/nms/tutorials/ems/sampleObj.hbm.xml"/>

After deleting the Managed Object Card, Card.hbm.xml entry will not be present in
hibernate.cfg.xml.

<mapping resource="com/adventnet/nms/tutorials/ems/testObj.hbm.xml"/>

Using the Delete Managed Object Wizard


Select WebNMS > Modeling > Delete Object menu. Alternatively, you can click
the Delete Object toolbar button. The Delete Managed Object dialog pops
up.



Select the XML file that needs to be deleted.



Click the Delete button.

Note: When all the Managed Objects under a particular package <Package of MO>
are deleted, the package <Package of MO> will also be deleted from the Project
Explorer window .

Copyright @2018
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User-Object Modeling

The Procedure to Model a User Object is similar to the steps followed in Modelling a Managed
Object except that in the Component MO Table Details screen, select user-storage for the
Select Module option instead of topo. Once the user-storage is selected, Parent MO/Extended
Object Name gets disabled. For further details, refer to the section , Model a Managed Object.
In the case of user-storage option, it is necessary to specify the primary key. If single property is
selected as Primary key, then select the Generator types from the list.


Native



Assigned



Sequence



User-defined

By default, Native type is selected. only in the case of User-defined type, it is necessary to Specify
the User class.
If more than one property (composite key) is selected as Primary key, then it is necessary to
enter the Composite Identifier Class Name. Click Finish Button.

To generate the Java source code for the Modeled user object from the Xml file, refer to the
section Java Source Generator for more details.

Copyright @2018
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Note: When the data type is String for a column, the Generator types available in the
list are Assigned and User-defined only. For other data types all four Generator types
will be displayed for selection.

Copyright @2018
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Fault Management
Fault Management

Fault management focuses on problem detection, diagnosis and rectification. WebNMS IoT
offers comprehensive fault management services such as event and alert management, alarm
correlation etc. From Eclipse, it is possible to customize Fault service to specific requirements.
Using the Model Managed Object Wizard, you can define your own event object extending IoT
component event. Similarly you can define your own alert object extending alert. The relevant
hibernate mapping file and the bean sources are generated automatically. Please read the topics
Extending Events and Extending Alerts to know more.
For further details regarding extending Events and Alerts, please refer the section Fault
Management in WebNMS Documentation.
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Extending Events

Events are the basic units of fault management. The event object has certain properties defined
to identify the events. Users can have additional user properties for their convenience. More
number of user properties degrade performance as database queries increases with the number
of user properties. Users should understand the fact that user properties feature is provided for
adding a few properties in the event object without extending the event object. If the user wishes
to have more number of user properties, then it is better to extend the event object and add the
desired properties.
Need to Extend Events
Based on the device types and the need for additional properties, the decision whether to
extend the events or not is to be taken. If the IoT networked environment includes specific
devices which need more properties to represent an event object, then it is recommended to
extend the events.
Extending Event Object
The Procedure to Extend Event Object is similar to the steps followed in Modelling a Managed
Object except that in the Component MO Table Details screen, select event for the Select
Module option instead of topo, select com.adventnet.nms.eventdb.Event from the drop down
list for the Parent MO/Extended Object Name option.
The generated source for the Event object has the parent resource extending an event class. For
more details, refer to Model a Managed Object.
Extending the Event Class
While extending the Event class, the following points are to be noted:


The id is the primary key in the Event table.



All extended Events will have id as primary key.

Refer to Writing Extended Event Class in WebNMS Developer Guide for further details.
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Extending Alerts

An Alert represents a failure or fault in an asset with a condition that may need attention. Alerts
can be extended for incorporating additional properties. Users can have additional user
properties for their convenience. More number of user properties may result in lesser
performance as database queries increases with the number of user properties. Users should
understand the fact that user properties feature is provided for adding a few properties in the
alert object without extending the alert object. If the user wishes to have more number of user
properties, then it is better to extend the alert object and add the desired properties.
Steps Involved in Extending Alerts
The Procedure to Extend Alert Object is similar to the steps followed in Modelling a Managed
Object except that in the Component MO Table Details screen, select alert for the Select
Module option instead of topo and select com.adventnet.nms.alertdb.Alert from the drop
down list for the Parent MO/Extended Object Name option.
The generated source for the Alert object has the parent resource extending an alert class. For
more details, refer to Model a Managed Object
Extending the Alert class
While extending the Alert class the following points are to be noted.


The id is the primary key in the Alert table.



All extended Alerts will have id as primary key.

Refer to Extending Alerts in WebNMS Developer Guide for further details.
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Creating Custom Notification for Alert Filter and Event Filter



Overview



Creating Event Filter



Creating Alert Filter

Overview
Event / Alert filters allow the users to perform some action when an event / alert matching the
specified criteria is received. In WebNMS IoT there are pre-defined actions like:


Suppress Action: Suppress all or some of the Events / Alerts matching this criteria.



Run Command Action: Run a system command on the WebNMS IoT server.



Send E-mail Action: Intimate the Administrator through e-mail.



Custom Filter: Invoke your own Java class for addressing application specific needs.

In case of Event Filters, the Filter entry specifying the match criteria and the action to be
performed is configured in the event.filters configuration file present in the <WebNMS IoT
Home>/conf directory. For defining the first 4 pre-defined actions, the Event Filter Configuration
Tool can be used. Please refer the documentation Configuring Event Filters.
In case of Alert Filters, the configuration details are persisted in the alert.filters file present in the
<WebNMS IoT Home>/conf directory. The pre-defined actions can be configured using the Alert
Filter Admin Tool. For more details regarding using this tool, please refer the Configuring Alert
Filters documentation.
When a custom action / notification is to be configured, the custom filter class needs to be
created. Please refer the sections below for creating custom notification class for Event and Alert
filters.

Creating Event Filter
Select the project or source folder in the Package Explorer, you can notice Create Event Filter
menu and icon get enabled. Alternatively, you can click the Create Event Filter toolbar
button.




Select WebNMS > Filters > Fault > Create Event Filter menu.
o

"EventFilter Creation Wizard" screen pops up.

o

In the Event Filter Properties screen, enter the package name of the event
filter in the Package Name text field, enter the event filter class name in
the Filter Class Name text field.

Click Finish button.
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You will find the <Event Filter class> under <Your Project>/source folder in the Project Explorer
window.

Creating Alert Filter
Select the project or source folder in the Package Explorer, you can notice Create Alert Filter
menu and icon get enabled. Alternatively, you can click the Create Alert Filter
toolbar button.




Select WebNMS > Filters > Fault > Create Alert Filter menu.
o

"AlertFilter Creation Wizard" screen pops up.

o

In the Alert Filter Properties screen, enter the package name of the alert
filter in the Package Name text field, enter the alert filter class name in the
Filter Class Name text field.

Click Finish button.

You will find the <Alert Filter class> under <Your Project>/source folder in the Project Explorer
window.
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Note: The entry for the custom class created will be appended in the event.filters
and alert.filters file for the Event Filter and Alert Filter respectively.
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Performance Management
Performance Management

Performance module is made up of three main functional components, namely Data collection
and storage, Monitoring, and Reporting. All these are controlled from a single point which is
called Polling Engine. The Polling Engine is responsible for applying data collection
configuration, collecting data, applying thresholds on collected data and monitoring,sending
notifications on threshold rule violation, and controlling Report generation.
The performance related code generation / configuration that can be done in Eclipse are as
follows:


A Tool to create Poll Filter. Poll Filter allows manipulation of PolledData objects before
they are added to the database. The manipulations will be of addition, modification, or
deletion of PolledData objects.



An XML editor to edit the configuration files, Thresholds.conf, and Reports.conf. Follow
the links to get details on what can be defined in each of these conf files.
o

Thresholds.conf contains definition of Thresholds to be applied over
collected data.

The following section contains documents explaining how to use the above mentioned tools.


Creating Poll Filter



Configuring Thresholds
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Creating Poll Filter



Overview



Creating a poll Filter

Overview
Poll Filter is used to fine-tune the Data collection configuration. When Managed Objects are
discovered, user can configure collection of performance data by using Poll Filter. Poll Filter
essentially allows you to add/modify/delete PolledData which are created as a result of polling
objects creation. Poll Filters can perform the following :


Existing PolledData can be modified.



New PolledData can be added for the Managed object.



Existing PolledData can be removed.

The Poll Filter Creation Wizard allows you to generate the stub code for the poll filter and will
place the appropriate entry in the polling.filters file for invoking this filter in WebNMS IoT.
For more details on need for Poll Filter, refer to Writing Poll Filter in WebNMS IoT Developer
Guide.

Creating a poll Filter
Select the project or source folder in the Package Explorer, you can notice Create Poll Filter
menu and icon get enabled. Alternatively, you can click the Create Poll Filter
toolbar button.




Select WebNMS > Filters > Performance > Create Poll Filter menu.
o

"Poll Filter Creation Wizard" screen pops up.

o

In the Poll Filter Properties screen, enter the package name of the poll filter
in the Package Name text field, enter the poll filter class name in the Filter
Class Name text field.

Click Finish button.
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You will find the <Poll Filter class> under <Your Project>/source folder in the Project Explorer
window. This generated class is just the stub code implementing the PollFilter interface. The
applyPollFilter method needs to be overwritten to manipulate the polled data as per your
requirement. Also the appropriate entry for invoking this filter class is appended to the
poll.filters file placed in <Your Project>/resources/conf directory.
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Configuring Threshold

Thresholds are baselines established to monitor data collection. If collected data goes beyond
the Threshold value, it indicates that the collected value is not a recommended value.
Threshold.conf file stores the definition of Threshold objects, with a minimum or maximum
value to be compared with the collected network data.
To Import Threshold.conf file, please refer to the section Working with Files
For detailed explanation on defining thresholds refer to Defining Threshold in WebNMS IoT
Developer Guide.
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Server Configuration
Server Configuration Introduction

This section provides an overview of Server Configuration files. For configuring the new
processes or modifying the parameters to existing processes and for changing server
parameters, following Server Configuration files can be edited in Eclipse by importing them into
the project.
The files discussed are


NMSProcessesBE.conf



NMSProcessesFE.conf



threads.conf



serverparameters.conf
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Editing NmsProcessesBE.conf

NmsProcessesBE.conf is the main configuration file which contains the list of all the processes
(also called "modules") that get started when WebNMS BE Server is started. The values for the
various parameters of the modules are also specified in this file. When you want to add your
own module into WebNMS BE, you can do so by specifying the fully qualified class name of your
implementation of com.adventnet.nms.util.RunProcessInterface and the parameters to be
passed to it in the NmsProcessesBE.conf.
Import the configuration file NmsProcessesBE.conf from <WebNMS IoT Home>/conf directory
into the Eclipse Project. Open the file in the project. Edit the file and click Save to save the
changes. Read the section Working with Files for more details.
For more details, read WebNMS Module Dependency in WebNMS IoT Developer Guide.
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Editing NmsProcessesFE.conf

This is the main configuration file which contains the list of all the processes (also called
as"modules") that get started when WebNMS FE Server is started. The values for the various
parameters of the modules are also specified in this file. When you want to add your own
module into WebNMS FE, you can do so by specifying the fully qualified class name of your
implementation of com.adventnet.nms.util.RunProcessInterface and the parameters to be
passed to it in the NmsProcessesFE.conf . If a value is not given for a parameter in
NmsProcessesFE.conf file, then the same is taken from serverparameters.conf file. Overall
functioning of FE Server can be configured by changing some of the command line parameters
for the process "NmsMainFE". This has to be specified in NmsProcessesBE.conf file, if FE Server is
started in the same JVM as that of BE Server. Otherwise, these parameters can be specified in
startnmsFE.bat/sh file.
Import the configuration file NmsProcessesFE.conf from <WebNMS IoT Home>/conf directory
into the Eclipse Project. Open the file in the project. Edit the file and click Save to save the
changes. Read the section Working with Files for more details.
For more details, read WebNMS Module Dependency in WebNMS IoT Developer Guide.
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Configuring Threads

You can configure the number of threads allocated for a particular scheduler in the
threads.conf file. Entries are present for all the schedulers employed in Scheduling Service.
Import the configuration file threads.conf from <WebNMS IoT Home>/conf directory into the
Eclipse Project. Open the file in the project. Edit the file and click Save to save the changes. Read
the section Working with Files for more details.
For more details read the section Scheduling Service in WebNMS IoT Developer Guide.
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Editing Server Parameters

The serverparameters.conf is a common file where all the configuration information related to
WebNMS IoT server is kept. By default, this file contains the server-related configuration details
of various modules present in WebNMS IoT. When you add your own module into WebNMS and
if you wish to provide some configuration information relating to the server, you may do so by
making entries in serverparameters.conf. The parameter and its value have to be entered as a
Key-Value pair.
Import the configuration file serverparameters.conf from <WebNMS IoT Home>/conf directory
into the Eclipse Project. Open the file in the project. Edit the file and click Save to save the
changes. Read the section Working with Files for more details
For more details, read Server Parameters in WebNMS IoT Developer Guide.
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Configuring Policies

Policies are tasks that are executed by WebNMS IoT at a system level, at a specified time. This
policy framework enables scalable administration of the WebNMS IoT server and the IoT
modeled objects managed by it. The primary goal of the policy engine is to enable administration
of complex functions easily. In WebNMS IoT, policies are used to customize the behavior of the
application and to provide a framework for adding policies for different IoT objects.
WebNMS IoT policies can be broadly classified into two categories :


Periodic Policies : Policies are triggered periodically by the server at the specified time
interval. By default, the periodic policies are configured to be executed in the interval of
10 seconds.



Nonperiodic Policies : Policies are executed at the specified time. In this case, there is
no fixed time interval. You need to specify the time at which the policy has to be
executed. No default value is assigned for nonperiodic policies.

Import the configuration file serverparameters.conf from <WebNMS IoTHome>/conf directory
into the Eclipse Project. Open the file in the project. Edit the file and click Save to save the
changes. Read the section Working with Files for more details.
Refer to Policy in WebNMS IoT Developer Guide for more details.

Copyright @2018

42

WebNMS IoT Platform 6.0 – Eclipse Guide

Setting Logging Parameters

Logging acquires paramount importance in a development cycle as it help in debugging
purposes. The Logging Service can be used to pinpoint bugs, display configuration errors,
identify performance blockades etc. The log4j.xml file will have entries for all the default
LOG_USER entries. If you have added some custom LOG_USER entries in your application, make
sure the corresponding entries are added to log4j.xml.
It is possible to change the LogLevel in log4j.xml file.
Import the configuration file log4j.xml from <WebNMS IoT Home>/conf directory into the Eclipse
Project. Open the file in the project. Edit the file and click Save to save the changes. Read the
section Working with Files for more details.
Also refer to Logging Service in WebNMS IoT Developer Guide for more details.
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Configuring Backup Service

During any development cycle, the data relating to the application stored in the database
acquires importance. The importance of data becomes multifold in data-centric applications
such as WebNMS IoT Framework. Human error, system crash, and other disasters can result in
the loss of valuable data which could prove costly. To overcome any such eventuality, WebNMS
IoT provides Backup Service. As the name itself indicates, backup refers to the process of taking
a copy of the data and keeping it separately. In case, any data loss occurs, the backup contents
can be restored to the database and made use of. The backup of the database can be taken
during any of the following scenarios :


Taking backup when the WebNMS IoT Server is not running



Taking backup (once or at periodic intervals) when the WebNMS IoT Server is running

When WebNMS IoT Server is running, backup can be taken by specifying the time at which
backup is to be taken, in the BackUp.conf file. At the time when backup is scheduled to be
taken, the runBackup() method in BackupInterface is internally invoked. You are actually
scheduling when the backup has to be taken.
Import the file BackUp.conf from <WebNMS IoT Home>/conf directory into the Eclipse Project.
Open the file in the project. Edit the file and click Save to save the changes. Read the section
Working with Files for more details.
Refer to Backup Service in WebNMS IoT Developer Guide for more details.
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Setting Failover Parameters
WebNMS IoT Platform is designed to run in mission-critical environments which require
continuous and uninterrupted access to WebNMS IoT. Generally, sudden failure of the server is
quite often the reason for interruption of service. Failover mechanism provides a solution for
this. "Failover" refers to the process in which all the functions being performed by the primary
server (i.e., currently active-server) are automatically assumed by a redundant or standby server
upon the failure or sudden termination of the primary server as a result of which uninterrupted
access is ensured. Failover makes the WebNMS IoT systems fault-resilient. The process of
switching has been designed to be highly smooth and automatic that the end user does not feel
the impact of the failure of the primary server or the subsequent taking over by the standby.
For the failover process to take effect, you need to make some entries in the FailOver.xml file.
Import the file FailOver.xml from <WebNMS IoT Home>/conf directory into the Eclipse Project.
Open the file in the project. Edit the file and click Save to save the changes. Read the section
Working with Files for more details.
Refer to FailOver in WebNMS IoT Developer Guide for more details.
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Debugging Applications Built in Eclipse

Testing the IoT Management Application
Eclipse IDE has a provision to start the WebNMS IoT server and Application client within the
environment. This provision can be used to test the code while developing. You can test the
newly added classes and you can modify some of the files and restart the WebNMS server to
reflect the changes made in the source. This can be effectively used to test the code during
development of the project itself.


Start the server using WebNMS > Launch > Start WebNMS Server menu.



Once the server and the client are started, you can debug your sources with the server
using Run > Debug History > Start WebNMS Server_<Project name> menu.



You can also run your sources with the server using Run > Run History > Start WebNMS
Server_<Project name> menu.

Once the project is compiled successfully, it is necessary to bundle all the modified application
and files of your project into a single file called a NAR. This can be done by Packaging the Project.
To Package the Project, refer to the section Packaging the Project for more details.
To view the changes in WebNMS IoT, the NAR should be installed over WebNMS. This task can be
performed using the Nar Installer present in the Deployment Wizard. You can invoke the
Deployment Wizard by using the WebNMS > Tools > Deployment Wizard menu. For more
details, refer to the section Installing Eclipse Project in WebNMS
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Rebranding WebNMS
Overview
WebNMS IoT Platform is highly customizable and permits rebranding to cater to the end user
requirements. Rebranding is typically done after customizing WebNMS IoT and before
deployment. Rebranding denotes changing the following using the Rebranding Tool:


WebNMS references in the product



Release Version reference



WebNMS icon, logo



All images with either AdventNet or WebNMS references



WebNMS URL

Invoking the Tool
Rebranding cannot be done with respect to Eclipse Project. It has to be done directly in the
WebNMS IoT Installation. To do Rebranding, invoke <WebNMS IoT
Home>\bin\developertools>startRebrandingTool.bat
For more details read the section Rebranding Tool in WebNMS IoT Developer Guide.
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Deploying Eclipse Applications
Deploying Eclipse Applications
After creating your project, you will need to package it for installing it over WebNMS. The
Package Project Wizard in the Eclipse packages all the resources of a Project (any customized,
generated or edited files) into a .nar file, with the Application name. Packaging utility is also
available in Command Line Mode The .nar file created in the Package Properties Wizard should
be installed over WebNMS using the Installer Wizard of the Deployment Tool. Nar installed over
WebNMS can also be uninstalled using the Uninstaller Wizard of the Deployment Tool.
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Packaging the Project

Overview
The Package Project enables you to bundle all the customized/ modified application and files of
your Project into a single file called a NAR (NMS archive). To view the changes in WebNMS, the
NAR should be installed over WebNMS.
Prerequisites for Packaging a Project


The Eclipse Project should be complete.



The Eclipse Project should be saved.



The Eclipse Project should be compiled successfully.

Procedure for Packaging a Project
Select the project in the Package Explorer , you can notice Package Project menu and
icon get enabled.
o Select WebNMS > Package Project menu. Alternatively, you can click the
Package Project
toolbar button. "Package Project" screen pops up.
 In the Package Properties screen, enter the name with which the NAR
file should be created in the NAR File Name text field, enter the directory
name/path in which the generated NAR file should be stored
(Alternatively, you can use Browse button to select the output directory
and path) and enter the version of the NAR file in the NAR File Version
text field.
o Click Finish button.
You will find the NAR file <Your Project><NAR File Version>.nar in the output directory.
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Integrating Command Line Packager with Build Script
Overview
The following section will guide you to package your Eclipse Project in command line mode. The
final output is a NAR of the Project. The NAR file can be installed over WebNMS IoT using the
Installer Tool of the Deployment Wizard.

Procedure to Package using Build Script
Follow the steps given below to integrate command line Packager with the scripts for Build at
Build time.


In the Build machine, set up WebNMS 6.0 inclusive of the Eclipse Project. Say for
example the Eclipse project can be placed under <WebNMS IoT
Home>/StudioTools/Studio/projects directory.



Proceed to <WebNMS IoT Home>/ StudioTools/Studio directory to edit the file
setCommonEnv.bat/sh to set up required classpath. Please note that the plugin
jar com.adventnet.nms.IoTDevelopment_1.3.1.jar is required in the classpath for
CommandLine Packager.
Step 1
For CommandLinePackager, you need a Packager.xml file. This file is generated by
eclipse when the project is packaged from the GUI using the Package Project. In
order to generate the packager.xml , you have to package the project using Package
Project wizard atleast once. The Package Project wizard will create packager.xml file
and place it in <Eclipse Project>.This xml fle has to be given as a command line
parameter for the CommandLinePackager script.
Step 2
To modify values of the properties of the Project before creating the NAR, edit the
Packager.xml file located in <Eclipse Project> directory.
For example for the Project "myproject" the existing Entry is as follows
outputDir=C:/projects/NARDestination
The above can be changed to
outputDir=./newNARDest
If the directory "newNARDest" does not exist a new directory will be created in the
same name.
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In the Packager.xml file the path of other files can also be made relative to the
project home to facilitate commandLinePackaging.
Step 3
To create a NAR run the
java.com.adventnet.studio.framework.CommandLinePackager with
arguments -conf and provide the path to the configuration file Packager.xml.
java.com.adventnet.studio.framework.CommandLinePackager -conf
./projects/IoT/Packager.xml
In case of using the absolute path for the configuration file, all path entries in the
Packager.xml configuration file must be absolute or relative to the working
directory of the commandlinePackager.
The NAR file for the Project will be available in the output directory specified in the
Packager.xml file.
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Installing Eclipse Project in WebNMS



Overview



Getting Started



Step 1 : Locating Eclipse Nar



Step 2 : Selecting Installation location



Step 3 : Installing NAR



Command Line Nar Installation



Developer Tips

Overview
The nar for Project created using the Package Project Wizard in the Eclipse Plugin has to be
installed over WebNMS IoT. This task can be performed using the Nar Installer present in the
Deployment Wizard. The Installer wizard with an easy- to- use interface helps you walk through
the process of installing the nar.
Getting Started
You can invoke the Deployment Wizard by using the WebNMS > Tools > Deployment Wizard
menu. Alternatively you can invoke the Deployment Wizard from <WebNMS IoT Home>/
bin/developertools/DeploymentWizard.bat/sh file. An intuitive GUI comes up.
Provide the following information at each step in the Wizard.

Note: Before installing a Eclipse NAR ensure the WebNMS IoT Server is shut down
before proceeding with the NAR Installation

Step 1 : Locating Eclipse Nar


Click on the NarInstall/UnInstall tab of the Deployment Tool.



Click on the Install button.



Select the Eclipse nar file to be installed using the Browse option. Click on the OK button.

Step 2 : Selecting Installation Location


Check the ReadMe for more details about the nar.



Click Next to proceed.
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Step 3 : Installing NAR


In the final screen click Install to install the nar.

Note: The NAR Installer of the Deployment Wizard allows only one nar (created in
Eclipse) to be installed over WebNMS. To install the second nar in the same WebNMS
IoT, uninstall the first nar using the Un-Installer wizard and then install the second
nar. In short
WebNMS Allows
Installation of one NAR for one copy of WebNMS IoT
Reason
Configuration files are copied from the WebNMS into the Project workspace. After
installing a Eclipse NAR over WebNMS the configuration files of WebNMS are
overwritten by the NAR installed. If you have created a second NAR in Eclipse, the
NAR when installed will have the configuration files of the previous version of
WebNMS. Hence the Eclipse will not allow the NAR to be installed because of the
difference in Version of the configuration files in WebNMS
Command Line Eclipse Nar Installation
Follow the steps give below to install an Eclipse NAR in Command Line Mode
Step 1
To install a deployed Eclipse NAR run the script
CommandLineStudioNarInstaller.bat\sh located in <WebNMS IoT
Home>/bin/developertools directory.
Step 2
Specify as argument the absolute path of the Eclipse NAR. To provide the relative
path as argument, the path specified has to be relative to WebNMS IoT Home and
not relative to the current directory.
Step 3
Specify the database for your Resource to be stored after specifying the absolute
path of the Eclipse NAR.
Example
For example if the absolute path of the application nar is c:\WebNMS\Archive.nar
and the database is Oracle the argument of the Eclipse NAR to be installed should
be
CommandLineStudioNarInstaller.bat C:\WebNMS\Archive.nar oracle
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For details regarding uninstalling a Eclipse NAR in the command line mode read the
section Uninstalling Eclipse Project in WebNMS.

Developer Tips
Issue: If you have installed Eclipse NAR, in Windows OS there is a possibility of "Input line too
long" error while starting WebNMS Server,
Tip: The above issue occurs as Eclipse NAR file has new JARs, and, when they are added to
WebNMS, the classpath settings are eventually lengthened.
Hence, use the WebNMS NmsMainBootstrap class loader mechanism. For more details read the
section Troubleshooting Tips - Input Line too Long
and add the Eclipse related jars, to the NMS_EXT_DIRS variables.
Example: For adding a jar
set NMS_EXT_DIRS= NetMonitor/build/EclipseProject.jar
Example: For adding all the Eclipse related jars
set NMS_EXT_DIRS= %MOPATH%;%CUSTOMPATH%
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Uninstalling Eclipse Project from WebNMS



Overview



Getting Started



Uninstallation of Eclipse NAR using Deployment Wizard



Command Line Eclipse NAR Uninstallation

Overview
In the deployment scenario, the nar is created by the Package Project Wizard in Eclipse and
installed/uninstalled over WebNMS using the NAR Installer/Uninstaller of the Deployment
Wizard.
Getting Started
You can invoke the Deployment Wizard by using the WebNMS > Tools > Deployment Wizard
menu. Alternatively you can Invoke the Deployment Wizard from <Web NMS Home>/
bin/developertools/DeploymentWizard.bat/sh file. An intuitive GUI comes up.
Uninstallation of Eclipse NAR using Deployment Wizard
To uninstall, click on the Eclipse Nar in the main screen of the Installer/Uninstaller Wizard. A
dialog appears. Click on the Uninstall button to uninstall the Eclipse Nar.

1. Before Uninstalling the NAR, it is necessary to Reinitialize the Database.
2. The Uninstaller wizard allows un-installation of one nar at one instance.

Command Line Eclipse NAR Uninstallation
To uninstall a Eclipse NAR run the script CommandLineStudioNarUninstaller.bat\sh located in
<Web NMS Home>/bin/developertools directory and specify as argument the Eclipse NAR name.
For example if the name of the Eclipse NAR is Archive.nar the argument should be
CommandLineStudioNarUninstaller.bat Archive.nar
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Upgrading the Project
The eclipse project created in a previous version of WebNMS IoT can be upgraded using the
Upgrade Project option under WebNMS menu.
Follow the below steps to upgrade the project.


Select the project.



Select WebNMS > Upgrade Project menu item. The Configuration Updater dialog will be
displayed.



Use the Browse button to select the new WebNMS IoT Home directory. The Product
Version and the Service Pack Version will be displayed.



Click the Update button. Confirmation dialog is displayed. Click the OK button to
upgrade the project.
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Known Issues & Limitations
This section describes known problems and associated workarounds for the Eclipse Plugin.
Known Issue:
When two projects use the same WebNMS IoT installation, the problem will occur. When the first
project is closed and trying to create a second project with the same WebNMS IoT installation
home as the closed IoT Development project.
Workaround: While creating the new Project with same WebNMS IoT home, keep the first
project open. Eclipse will use some linked resources (class folders) from the first project instead
of re-creating them. So closing the project will restrict the linked resource from being accessed
and will raise the problem <ProjName>_Conf_Link resource is missing and <ProjName>_Link
resource is missing.

Limitations:
The below two exceptions occurs when there is a space in the directory path where WebNMS
IoT is installed and trying to install a NAR file in WebNMS. This is a JDK bug which occurs in some
scenarios where Xalan parsing of XML file is done.
Scenario 1 :
javax.xml.transform.TransformerException: java.io.FileNotFoundException:
file:\C:\Program%20Files\WebNMS\NetMonitor\build\uninstall.xml
(The filename, directory name, or volume label syntax is incorrect)
at org.apache.xalan.transformer.TransformerIdentityImpl.createResultContentHandler
(TransformerIdentityImpl.java:260)
at org.apache.xalan.transformer.TransformerIdentityImpl.transform
(TransformerIdentityImpl.java:291)
Scenario 2 :
java.net.MalformedURLException: unknown protocol: c

Workaround : Kindly install the WebNMS in a directory which does not have space characters in
its path.
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Frequently Asked Questions
This document answers frequently asked questions about the Eclipse Plugin.
Contents:


How do I install the plugin



Which version of Eclipse does WebNMS IoT support?



What version of JDK can be used to start WebNMS from Eclipse ?



Where can i find the XXX.hbm.xml file?



How to debug NMS project in eclipse?

How do I install the plugin?
(or)
Where can I download the Eclipse plugin for WebNMS IoT?
(or)
How to use Eclipse with WebNMS IoT 6.0?
(or)
Where I can get the latest plugin version?


Install the Eclipse (version Kepler or higher) in your machine.



Install WebNMS 6.0 in your machine.



The WebNMS Eclipse plugin JAR (WebNMSEclipsePlugin.jar) is available in the <WebNMS
IoT Home>/StudioTools/Studio/jars directory and unzip this jar in the <Eclipse Installation
Directory>



Start Eclipse IDE. Use the script with the - vm option as given below:
Command for Linux machine
./eclipse -vm <JDK 1.7 Home>/bin/java
Command for Windows machine
eclipse -vm <JDK 1.7 Home>\bin\java
If you are installing a newer version of our plugin over, please use the "-clean" option in
the commandline while starting Eclipse IDE:
Example: ./eclipse -vm <JDK 1.7 Home>/bin/java -clean

Which version of Eclipse does WebNMS IoT support?
Eclipse Kepler (or higher) are supported by WebNMS.

What version of JDK can be used to start WebNMS IoT from Eclipse ?
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WebNMS IoT 6.0 supports JDK 1.7 . So JDK 1.7 version must be installed to start NMS from
Eclipse. The command should be as follows,
eclipse -vm <jdk1.7_installDir>/bin/java
Where can i find the XXX.hbm.xml file?
When a MO is modeled, <Modeled MO>.hbm.xml is generated under <Your Project>/Referenced
Libraries/resources/classes/hbnlib/<Package of MO> in the Project Explorer window.
How to debug WebNMS IoT project in eclipse?
You can debug Nms Project as Java Project in Eclipse. Refer to Debugging Applications Built in
Eclipse section in Eclipse Document for more details.
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