3.2.2 Software Requirements

 

WebNMS Framework can run on different platforms such as Windows, Solaris, and Linux. Below is a list of software versions supported by WebNMS. Though WebNMS supports different software versions, only a particular software version is bundled with the product. If you wish to use any other supported version, you need to download that version from the respective web site and follow the upgrade procedure provided in the Developer Guide.

For the complete list of software versions bundled with WebNMS, refer to the section Packages Bundled.  Certain third party software such as database drivers are to be downloaded by the users from the respective sites.

 

Supported Platforms

* For 64 bit installation build, please mail to nms-support@webnms.com

 

The databases supported are PostgreSQL, MySQL, Oracle, Sybase, and MSSQL. For information on drivers, refer to Database Drivers. The default bundled database is PostgreSQL 9.0.1.

 


Linux Platform

 

The tables below list the software that are compatible with WebNMS Framework on Linux platform.

 

Back-end Server

  1. Platforms

    Java Version JRE/JDK

    Database

    Web Server and

    Servlet Engine

    MySQL

    Oracle

    PostgreSQL

    Sybase SQL Anywhere

    MSSQL

    Redhat Enterprise Linux 5.0

    JRE 1.6.0

    JDK 1.6.0

    5.0.44

    11.1.0.0.0

    9.0.1

    -

    -

    Tomcat 5.5.20                         

    RedHat Linux AS 4.0

    JRE 1.6.0

    JDK 1.6.0

    5.0.44

    11.1.0.0.0

    9.0.1

    -

    -

    Tomcat 5.5.20

    RedHat Linux 9.0

    JRE 1.6.0

    JDK 1.6.0

    5.0.44

    11.1.0.0.0

    9.0.1

    ASA 10.0.1.3415

    2005

     

    Tomcat 5.5.20

    Fedora Core 9

    JRE 1.6.0

    JDK 1.6.0

    5.0.44

    11.1.0.0.0

    9.0.1

    ASA 10.0.1.3415

    2005

     

    Tomcat 5.5.20

Front-end Server

  1. Platforms

    JRE Version

    Web Server and Servlet Engine

    Redhat Enterprise Linux 5.0

    1.6.0

    Tomcat 5.5.20

    RedHat Linux AS 4.0

    1.6.0

    Tomcat 5.5.20

    RedHat Linux 9.0

    1.6.0

    Tomcat 5.5.20

    Fedora Core 9

    1.6.0

    Tomcat 5.5.20

Client

  1. Platforms

    Browser*

    Java Web Start

    JRE Version

    Firefox**

    Chrome**

    Internet Explorer**  

    Java Plug-in Version

    Redhat Enterprise Linux 5.0

    16x

    26x

    Not Applicable

    1.6.0

    1.6.0

    1.6.0

    RedHat Linux AS 4.0

    16x

    26x

    Not Applicable

    1.6.0

    1.6.0

    1.6.0

    RedHat Linux 9.0

    16x

    26x

    Not Applicable

    1.6.0

    1.6.0

    1.6.0

    Fedora Core 9

    16x

    26x

    Not Applicable

    1.6.0

    1.6.0

    1.6.0

Top

 

 


 

Solaris Platform

 

The tables below list the software that are compatible with WebNMS Framework on Solaris operating system with SPARC platform.                                     

 

Back-end Server

  1. Platforms

    Java Version JRE/JDK

    Database

    Web Server and Servlet Engine

    MySQL

    Oracle

    PostgreSQL

     

    Sybase SQL Anywhere

    MSSQL

    Solaris 10

    (Sun and X86)

    JRE 1.6.0

    JDK 1.6.0

    5.0.44

    11.1.0.0.0

    9.0.1

    ASA 10.0.1.3415

     

    2005

    Tomcat 5.5.20

Front-end Server

  1. Platforms

    JRE Version

    Web Server and Servlet Engine

    Solaris 10

    1.6.0

    Tomcat 5.5.20

Client

  1. Platforms

    Browser*

    Java Web Start

    JRE Version

    Mozilla

    Internet Explorer

    Java Plug-in Version

    Solaris 10

    1.4

    Not Applicable

    1.6.0

    1.6.0

    1.6.0

 

 

Top



 

Windows Platform

 

The tables below list the software that are compatible with WebNMS Framework on Windows platform.

 

Back-end Server

  1. Platforms

    Java Version JRE/JDK

    Database

    Web Server and Servlet Engine

    MySQL

    Oracle

    PostgreSQL

    Sybase SQL Anywhere

    MSSQL

    Windows Vista

    JRE 1.6.0

    JDK 1.6.0

    5.0.44

    11.1.0.0.0

    9.0.1

    ASA 10.0.1.3415

    2005

    Tomcat 5.5.20

    Windows XP

    JRE 1.6.0

    JDK 1.6.0

    5.0.44

    11.1.0.0.0

    9.0.1

    ASA 10.0.1.3415

    2005

    Tomcat 5.5.20

    Windows Server 2008

    JRE 1.6.0

    JDK 1.6.0

    5.0.44

    11.1.0.0.0

    9.0.1

    ASA 10.0.1.3415

    2005

    Tomcat 5.5.20

    Windows 7

    JRE 1.6.0

    JDK 1.6.0

    5.0.44

    11.1.0.0.0

    9.0.1

    ASA 10.0.1.3415

    2005

    Tomcat 5.5.20

Front-end Server

  1. Platforms

    JRE Version

    Web Server and Servlet Engine

    Windows Vista

    1.6.0

    Tomcat 5.5.20

    Windows XP

    1.6.0

    Tomcat 5.5.20

    Windows Server 2008

    1.6.0

    Tomcat 5.5.20

    Windows 7

    1.6.0

    Tomcat 5.5.20

Client

  1. Platforms

    Browser*

    Java Web Start

    JRE Version

    Firefox **

    Chrome **

    Internet Explorer **

    Java Plug-in Version

    Windows Vista

    16x

    26x

    9x

    1.6.0

    1.6.0

    1.6.0

    Windows XP

    16x

    26x

    9x

    1.6.0

    1.6.0

    1.6.0

    Windows Server 2008

    16x

    26x

    9x

    1.6.0

    1.6.0

    1.6.0

    Windows 7

    16x

    26x

    9x

    1.6.0

    1.6.0

    1.6.0

  1.  

    Note: The Windows Vista OS has an additional security feature called "User Account Control or (UAC)". This forces the users of local administrative group to use the PC like regular users without any administrative privileges by default. Due to this, the WebNMS 5 Server when installed under the "Program Files" folder will not have permissions to copy and write files which there by prevents the server from starting. This feature can be disabled to install and start WebNMS 5 server under the "Program Files" folder itself. But, disabling this feature has some security disadvantages. The details about UAC and disabling is available in the link below:

     

    http://www.petri.co.il/disable_uac_in_windows_vista.htm

     

Top

 


  1. Note:

    *  - HTML UI - Cookies and Java Script should be enabled

        - JAVA UI - Suitable Plug-ins should be installed for starting Java Client  
    ** - The browsers supported versions are versions provided in the chart and higher versions.  

 

Database Drivers

 

Database

JDBC Driver

(WebNMS is JDBC 2.0 compliant)

PostgreSQL

 

 PostgreSQL 9.0.1(Bundled Version)

postgresql_jdbc4.jar

Oracle

 

Oracle 11.1.0.0.0

ojdbc5_g.jar

Oracle JDBC driver version 11.1.0.6.0-Production

Sybase SQL Anywhere

 

Sybase ASA 10.0.1.3415

jconn3.jar (JConnect 6.05)

MySQL

 

 MySQL 5.0.44

mysql-connector-java-v5.0.7

MSSQL

 

 MSSQL 2005 (9.00.1399)

sqljdbc.jar (Microsoft SQL Server 2005 JDBC Driver (1.2.2828.100))

JTurbo.jar (JTurbo 4.0.0.0 JDBC 3.0)

 

 

 

The Java Plug-In can be downloaded from the following link: http://java.sun.com/products/plugin/index.html.

 


Copyright © 2013, ZOHO Corp. All Rights Reserved.