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Building Multi-Protocol Agents 
  
Overview 
 
The Agent Toolkit Java Edition provides an intuitive development tools for building Multi-protocol agents. 
The developed agents provide multi-protocol access to common management information, including 
SNMP, RMI, HTTP, CORBA, and TL1. You just have to instrument once to access with any protocol.  
 
The Multi-Protocol architecture is applicable to network management, remote system maintenance, 
application provisioning, and the new management needs of the service-based network.  
 
Steps to Build Multi-Protocol Agents 
 
Following are the steps to build Multi-Protocol Agents using the AdventNet Agent Toolkit: 

1. Create a new project using JMX Compiler. 
2. Load a MIB as input to the agent.  
3. Generate the Code for the multi-protocol agent using JMX Compiler. 
4. Compile the Code.  
5. Test the multi-protocol agent using the respective browsers for the different protocols. 

In addition to providing a detailed description on building Multi-Protocol Agents using various tools, the 
guide also documents the features implemented by the Multi-Protocol Agent. The FAQ comprises of the 
solution to queries regarding multi-protocol agent and its features. Also, the Tutorials demonstrate the 
complete development process of implementing Multi-Protocol Agent for other applications. The 
Migration Guide assists the users with information about migrating from 4.2 to 5.0/5.1.0. 
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Multi-Protocol Agent Architecture 
 

 
Overview  
Instrumentation Level (MBeans)  
MBean Server  
Adaptors  

 
 
Overview 
 
AdventNet supports six adaptors/connectors for various protocols viz. SNMP, RMI, CORBA, TL1, HTTP.  
Users can write their own adaptors for other protocols and plug them into the multi-protocol agent 
architecture. Since the JMX specification does not spell out any standards for adaptors, AdventNet's 
adaptors have proprietory implementation. However, if JMX evolves with specs for protocol adaptors, 
AdventNet's adaptors can be easily migrated to the same.   
 
This chapter explains the AdventNet Multi-Protocol agent architecture, which comprises of the following 
components :  

• Instrumentation level 

• Agent Level (MBean Server) 

• Connector level (Adaptors) 
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Instrumentation Level (MBeans) 
 
The instrumentation level is the level in which the management data is collected by the agent or applied 
on the agent. This level is common for all the management protocols supported on the agent. The agent 
developer is required to implement the instrumentation at this level, and make it available as Java 
components called MBeans.  
 
What  are MBeans?  
 
A Managed Bean or MBean in short  is a Java object that implements specific interfaces and conforms to 
certain design patterns. MBeans encapsulate manageable objects as attributes and operations through 
their public methods and follow the design patterns for exposing them to management applications.  
 
For example, a read-only attribute will have just a getter method, whereas a read-write attribute will have 
getter and setter methods.  
 
Why MBeans?  
 
Any object that is implemented as an MBean and registered with the agent can be managed from outside 
the agents Java virtual machine. Such objects include the following : 

• The resources your application wishes to manage.  

• Value-added services provided to help manage resources. 

• Components of the JMX infrastructure that can be managed. 
Different Types of MBeans  
 
AdventNet supports three types of MBeans namely :  

• Standard MBean 

• Dynamic MBean 

• Model MBean 
Each of these correspond to different instrumentation requirements.  The following section covers the 
three ways to instrument a resource by writing a standard MBean, by implementing a dynamic MBean, or 
by dynamically instantiating a configurable model MBean. 
 

Standard MBean  
 

Overview  
 

A Standard MBean is the easiest way to define an MBean. It provides a static management 
interface, which is fixed at compile time and is invoked by reflection. The management 
information is exposed using the interface which drives the standard mbeans. 

 
The interface of a standard MBean is referred to as its MBean interface. Its name is formed by 
adding the suffix "MBean" to its class name. For example, the MBean interface name for the 
MBean called "MyClass"  would be "MyClassMBean.  

 
Standard MBean's Interface  

 
The Standard Mbean's interface is made up of the methods it makes available for reading and 
writing its attributes and for invoking its operations. When defining this management interface for 
the Java object, it should follow the  design patterns listed in the instrumentation part of the JMX 
specification. The management interface of a standard MBean is composed of its attributes and 
operations.  
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• Attributes 
 
Attributes are properties, which are exposed through the getter and setter methods in the 
MBean interface. Attributes may be read-only, write-only, or read-write.  For any given 
attribute name, there can be at most one setter and one getter method, and if both are 
defined, they must conform to the data-type of the attribute.  

• Operations 
 
Operations are methods that can be remotely invoked on a resource by a management 
application. These are the methods other than the getter and setter methods present in 
the interface.  They can be defined with any number of arguments of any type and can 
return value of any type. 
 
The design patterns for operations are simple: any public method defined in the MBean 
interface that is not an attribute getter or setter is an operation. For this reason, getters 
and setters are usually declared first, so that all operations are grouped together. The 
name of an operation is the name of the corresponding method. 

Running the Standard MBean Example  
 

The Standard MBean example is available in the <Agent Toolkit 
Home>/examples/jmx/standardMBean directory.   It illustrates  the usage of  the 
StandardMBean registered with the Multi-Protocol agent. To run the example, please refer to the 
Readme.html file.  

 
Dynamic MBean 

 
Overview  

 
Unlike the Standard MBean, the Dynamic MBeans do not have getter and setter methods for 
each attribute and operation. Instead, they have generic methods for getting or setting an 
attribute by name, and for invoking operations by name. These methods are common to all 
dynamic MBeans and are defined by the DynamicMBean interface.  

 
The management interface is determined by the set of attribute and operation names to which 
these methods will respond. The getMBeanInfo method of the DynamicMBean interface returns 
a data structure,  which describes the management interface. This metadata contains the 
attribute and operation names, their types, and the notifications that may be sent if the MBean is 
a broadcaster.  

 
The management interface of a dynamic MBean is static, but this interface is exposed 
dynamically when the MBean server calls its getMBeanInfo method. 

 
When Dynamic MBean is used?  

 
Let's consider a scenario where the attributes and operations exposed are likely to change often. 
In this case, the instrumentation must provide more flexibility, such as being determined 
dynamically at run time.  In such case, the standard MBean model doesn't work well, Dynamic 
MBeans bring this adaptability and provide an alternative instrumentation with more elaborate 
management capabilities.  
 

 

Note: Ultimately, the implementation remains the same whether the 
instrumentation followed is a Standard MBean model or Dynamic 
MBean model. The difference is by the way the attributes and 
operations are exposed. i.e whether by a static interface (Standard 
MBean model) or by runtime description (Dynamic MBean model).  
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The DynamicMBean Interface  
 

The javax.management.DynamicMBean interface,  exposes the attributes and operations only at 
run time. Instead of exposing the attribute and operation names directly, it exposes them through 
relevant descriptors.  The resource object's class, to be recognized as a dynamic MBean by the 
Multi-Protocol agent or one of its super classes, must implement the DynamicMBean interface.  

 
The DynamicMBean interface in the javax.management package is defined by the following 
methods : 
 

public interface DynamicMBean { 
public MBeanInfo getMBeanInfo(); 
public Object getAttribute(String attribute) throws 
AttributeNotFoundException, MBeanException, 
ReflectionException; 
public void setAttribute(Attribute attribute) throws 
AttributeNotFoundException,   
InvalidAttributeValueException, 
MBeanException, ReflectionException ; 
public AttributeList getAttributes(String[ ] 
attributes); 
public AttributeList setAttributes(AttributeList 
attributes); 
public Object invoke(String actionName, Object 
params[], String 
signature[]) 
throws MBeanException, ReflectionException ;} 

 
The getMBeanInfo method returns an MBeanInfo object,  which contains the definition of the 
MBean's management interface. It contains a list of attribute names and types, a list of 
operations and their parameters, and other management information.  

 
From the MBeanInfo object,  the Multi-Protocol agent can get the  characteristics of all the 
Attributes/Operations. With this information of the Attribute, the Multi-Protocol agent can access 
the attribute(s) value(s) through the getAttribute(s) methods. Similarly, attribute(s) can be set by 
calling the setAttribute(s) methods using the Dynamic MBean interface of the resource object.  

 
For invoking any method (the Operation that is exposed by the MBeanInfo) on the resource 
through a DynamicMBean object, the invoke method of the Dynamic MBean interface will be 
used by the JMX agent. If the operation is expected to return an object, then that object will be 
returned by this invoke method.  

 
Running the Dynamic MBean Example  

 
The Dynamic MBean example is available in the <Agent Toolkit 
Home>/examples/jmx/dynamicMBean directory.   It illustrates  the usage of  the Dynamic 
MBean registered with the Multi-Protocol agent. It would also serve to know how to develop a 
Dynamic MBean.  To run the example, please refer to the Readme.html file.  

 
Model MBean 

 
Overview  

 
The Model MBean specification is an interface that provides a management template for 
managed resources. It is a generic and configurable form of Dynamic MBean. The 
javax.management.RequiredModelMBean class is an implementation of Model MBean interface 
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along with the Dynamic MBean interface. Model MBeans are used for instrumenting resources 
programmatically at run time. 
 
To instrument a resource and expose it dynamically, follow the steps given below:  

1. Instantiate the javax.management.modelmbean.RequiredModelMBean class in a Multi-
Protocol agent 

2. Set the model MBeans management interface 
3. Designate the target object, which implements the management interface 
4. Register the model MBean in the MBean server 

How Model MBean is different from other MBeans?  
 

In the case of Dynamic MBean model, the properties of the instrumentation class, which the user 
is interested to manage, are exposed through the Dynamic MBean interface implemented by this 
instrumentation class. In Model MBean model, these properties are described, i.e., initialized, by 
XML files.  

 
The Model MBean information includes a descriptor for each attribute, constructor and 
notification in its management interface. A descriptor is an essential component of the Model 
MBean. It contains dynamic, extensible, and configurable behavior information for each MBean 
component. They provide the mapping between the attributes and the operations in the 
management interface and the actual methods that need to be called to satisfy the get, set, or 
invoke request. 

 
Merits of Model MBean 

 
The javax.management.RequiredModelMBean class acts as a generic template for creating 
manageable objects dynamically. Thus, resources, services, and applications can use this class 
by passing their instrumentation object and configure the exposure of default behavior through 
XML file or through DescriptorList and register it with the server (Multi-Protocol agent).  

 
For example,  
 

// User Instrumentation class  
agentSystemInstrument= new AgentSystemInstrument();// Initialize the 
RequiredModelMBean with the xml file. 
rmm = new RequiredModelMBean 
(com.adventnet.utils.jmx.Utilities.convertXmlToModelMBeanInfo 
("./agentProjects/jmxProject/mySources/AgentSystemInstrument.xml")); 
rmm.setManagedResource(agentSystemInstrumentExt, "objectReference"); 
// the ObjectName for the instrumentation. 
name = "AGENT_SAMPLE_MIB_JMX:type=AgentSystemInstrumentExt"; 
// finally register with the Multi-Protocol agent, i.e, MBeanServer.
server.registerMBean(rmm, new ObjectName(name)); 

 
Key Features of RequiredModelMBean supported in this release :  

• XML file initialization support  

• Flat file persistence support 

• Cached values support 
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XML Initialization  
 

Why is it required?  
 

This allows the XML encoded data, representing the metadata of a Model MBean, to be used for 
initializing the MBean. The ModelMBean(Attribute)Info[], ModelMBean(Operation)Info[], 
andModelMBean(Notification)Info[] get initialized by this XML.  

 
During initialization, the MBeanInfo of the Dynamic MBean interface gets created from the 
formed ModelMBean(Attribute)Info[], ModelMBean(Operation)Info[], 
ModelMBean(Notification)Info[].  
Retrieval of various fields present in the XML (the descriptor for each attribute/operation 
/notification) class can be done as follows : 

 
For AgentSystemInstrument.xml (the XML file for agentSystem group in agent-sample-mib.txt 
located in  <Agent Toolkit Home>/mibs directory) file,  the code for retrieving the OID for 
AgentDescr attribute from the Model MBean that is registered with the MBean Server with 
ObjectName "AGENT_SAMPLE_MIB_JMX:type=AgentSystemInstrument" is as follows: 
 

String name = "AGENT_SAMPLE_MIB_JMX:type=AgentSystemInstrument"; 
ModelMBeanAttributeInfo[] attrInfo = 
(ModelMBeanAttributeInfo[])(server.getMBeanInfo(new 
ObjectName(name)).getAttributes());  
Descriptor adss = attrInfo[0].getDescriptor(); 
// The Descriptor for AgentDescr attribute 
ObjectName snmpValue = null;  
try { 
snmpValue = new ObjectName(":" + (String) 
((Descriptor)ads.getFieldValue("protocolMap")).getFieldValue("snmp"));
} catch(MalformedObjectNameException mfe) { 
mfe.printStackTrace(); 
} 
String oid = snmpValue.getKeyProperty("value"); 
// returns ".1.3.6.1.4.1.2162.4.1.1." 
// i.e the "value" key is inner tag for "protocolMap" for "snmp" 
protocol 

• The following is the code to retrieve the description of the agent information. 

String descr = ads.getFieldValue("description"); 
//returns "Location information for the Agent" 

• For AdiskTable.xml (the XML file for AdiskTable in the XML agent-sample-mib.txt 
located in the <Agent Toolkit Home>/mibs directory) file, the code for retrieving the 
name of the first column of the table is as follows : 

Descriptor adss = attrInfo[0].getDescriptor(); 
Descriptor columnDescriptor =  
(Descriptor)adss.getFieldValue("columnAttribute1"); 
String name = 
(String)columnDescriptor.getFieldValue("name"); 
// return AdiskID 
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• The code for retrieving the SNMP syntax type of the column "AdiskName" is as follows :, 

Descriptor descr = attrInfo[0].getDescriptor(); 
int count=0; 
while(true) { 
if(descr.getFieldValue("columnAttribute"+ (++count)) == null) { 
count--; 
break; 
} 
} 
String type = null; 
for(int j=0; j<count; j++) 
{  
Descriptor columnDescr = 
(Descriptor)descr.getFieldValue("columnAttribute" + (j+1)); 
if(columnDescr.getFieldValue("name").toString().equals("AdiskName")) 
{ 
type = columnDescr.getFieldValue("type").toString(); 
// This will give the type of AdiskName 
break; 
} 
} 

 
 
Similarly, you can get the operations/notifications field information from its relevant XMLString. 
The descriptor.xml file defined by Agent Toolkit follows the schema defined in this DTD file. 

 
Flat File Persistence Support 

 
The Model MBean attribute information is saved into a flat file depending on the persistence 
policy specified for each attribute in the XML file/descriptor.  

 
This default name can be changed by calling its setter method. Thus, during the Multi-Protocol 
agent's next startup,  the Model MBean gets loaded with the stored attribute values in the 
constructor of RequiredModelMBean (Since, the RequiredModelMBean implements the 
PersistentMBean interface, which has load and store methods). The various Persist Policy 
supported are as follows :  

• Never - the attribute is never persisted. This is useful for highly volatile data or data that 
has meaning onlywithin the context of a session or execution period. 

• OnTimer - the attribute is persisted whenever the persist period service of the Model 
MBean expires. 

• OnUpdate - the attribute is persisted every time the attribute is updated. 

• NoMoreOftenThan - the attribute is persisted every time it is updated, unless the updates 
are closer together than the persistPeriod. This acts as an update throttling mechanism 
that helps to prevent, temporarily, highly volatile data from affecting the performance. 

Catched Values Support  
 

What is Caching? 
 

Caching mechanism is provided to store attribute values that are offered by the management 
resource, in the Model MBean. Maintaining the values of fairly static variables in the Model 
MBean itself, allows it to return that value without contacting the managed resource. 
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The resource may also set its Model MBean to disable caching, implying that the resource would 
be called whenever an attribute is accessed. In this case, the managed resource is invoked and 
it returns the attribute values to the Model MBean. In turn, the Model MBean returns these 
values to the MBean Server, which returns them to the request originator, usually a 
management application.  

 
What benefit does Caching provide?  

 
In general, the adaptors access the application's RequiredModelMBean as it is returned by the 
Multi-Protocol agent. If the data requested by the adaptor is current, then the managed resource 
is not interrupted with a data retrieval request. Therefore, direct interaction with the managed 
resource is not required for each interaction with the management system. This helps to 
minimize the impact of management activity on run-time application resources and performance.  

 
The attribute descriptor contains and lastUpdatedTimeStamp fields. If the current time is past 
lastUpdatedTimeStamp + curencyTimeLimit, then the attribute value is stale (or no value). If a 
getAttribute is received for an attribute with a stale value (or no value), then the getMethod for 
the attribute will be invoked and the returned value will be recorded for the attribute, 
lastUpdatedTimeStamp will be reset, and the requester will be handed the new value.  

 
If there is no getMethod defined, then the default value from MBeanInfo for the attribute will be 
returned.  

 
When to use Model MBean  

 
Model MBean usage is recommended over standard or dynamic MBeans on below scenario : 

1. When you wish to use any protocol adaptors that has model : 
 
If you wish to use SNMP adaptor, SOAP adaptor, CIM / WBEM adaptor (which has 
metadata model ), the flexibility of defining the protocol properties (like OID, CIM schema) 
for an MBean attribute can be achieved only by ModelMBeans.  On the other hand, if you 
wish to use protocol adaptors like RMI, HTTP (which doesn't have any meta model), then 
you can choose to use either standard or dynamic mbeans. 

2. Out of the box persistence support for MBean and its attributes  

3. Out of the box caching support for MBean and its attributes  

Running the Model MBean Example  
 

The Model MBean example is available in the <Agent Toolkit 
Home>/examples/jmx/modelMBean directory.   It illustrates  the usage of  the Model MBean 
registered with the Multi-Protocol agent. To run the example, please refer to the Readme.html 
file. 

 
Agent Level (MBean Server) 
 
The manager requests are received and processed at the agent level. This level handles the different  
protocols and converts manager requests into the common protocol independent instrumentation 
provided by MBeans.  The task of converting from specific protocols is done by protocol-specific 
adaptors/connectors. These interface with a common MBean server, which controls and interacts with the 
MBeans.  
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The MBeanServer is the core component of the JMX infrastructure. It provides a protocol-independent 
and information model-independent framework with services for manipulating JMX manageable 
resources.  
 
Registering a resources MBean makes it visible to management applications and exposes requests. The 
server no distinction between types of MBeans: standard, dynamic model MBeans are all managed in 
exactly same manner. < 
 
You can register objects in the MBean server through:  

• The other objects in the agent application itself 

• A remote management application (through a connector or a protocol adaptor) 

The MBean server responds to the following management requests on registered MBeans:  

• Listing and filtering MBeans 

• Discovering and publicizing the management interface of MBeans 

• Accessing MBean attributes for reading and writing. 

• Invoking operations defined in the management interface of MBeans 

• Registering and deregistering Notification listeners for MBean notifications 

Methods in MBean Server  
 
The following are the methods for creating/registering/deleting MBeans 

• createMBean (creation) 

• registerMBean (registration) 

• unregisterMBean (deletion) 

For accessing the attributes and operations on the MBean, the method names are same as specified in 
the DynamicMBean interface. The methods contain an extra parameter for passing the ObjectName 
information on the MBean, which you would like to access through the BeanServer. 

• getMBeanInfo 

• getAttribute 

• getAttributes 

• setAttribute 

• setAttributes 

• invoke 

For adding and removing NotificationListener for a NotificationBroadcaster MBean : 

• addNotificationListenter 

• removeNotificationListener 

For querying the MBeans based on a Query constraint along with a filter mechanism : 

• queryMBeans 

• queryNames 
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All management requests are handled by the MBean server, which dispatches them to the appropriate 
MBean. An MBean is identified by a unique symbolic name, called object name. The object name can be 
assigned either by the entity registering the MBean, or by the MBean itself, if its implementation has been 
designed to provide one. Managers give this object name to designate the target of their management 
requests.  
 
Generally, whatever the access the API user would like to have on the MBean, it is achieved via the 
MBean Server, with ObjectName of the MBean being passed as an extra parameter to all the methods.  
 

Creating the MBean Server  
 

The MBean Server object can be created using the createMBeanServer static method in the 
MBeanServer factory class. This method creates an instance of MBeanServer implementation 
class, which is exposed as MBeanServer interface. This implementation class is present in the 
Agent Toolkit as MBeanServerImpl class. Thus,; the following single line code will create an 
MBean Server instance :  
 

MBeanServer server = 
MBeanServerFactory.createMBeanServer(); 

 
Connector Level (Adaptors) 
 
Adaptors and connectors are protocol handlers,  which expose MBeans information to their respective 
protocol  clients/managers. The MBean (instrumentation) is common and needs to be instrumented only 
once. This instrumentation is  made available through all the adaptors/connectors.  
 
An agent may contain any number of connectors or protocol adaptors, enabling it to be managed 
simultaneously by several managers, through different protocols. It is up to the agent application to 
coordinate all the port numbers on which it intends to receive requests. 
 
The AdventNet Multi-Protocol agent supports to provide management of the Multi-Protocol agent through 
the following adaptors. You can also create custom protocol adaptors and integrate them to the 
AdventNet adaptor framework. To do this, please refer to the topic "Writing custom protocol Adapters for 
the Multi-Protocol Agent".  

• SNMP adaptor 

• HTTP connector 

• TL1 adaptor 

• RMI connector 

• CORBA connector 

• HTML adaptor 
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SNMP Adaptor Architecture 
 

SNMP Adaptor just acts as a wrapper class for AdventNet Standalone SNMP Agent, ensuring to 
provide the same SNMP agent stability that has come from the standalone SNMP agent.  

 

 
Fig.2 SNMP Adaptor Architecture  

 
CORBA Connector  

 
The CORBA Connector enables CORBA clients to manage MBeans residing in AdventNet Multi-
Protocol agent. The CORBA connector uses CORBA naming service provided by the ORB 
implementation for CORBA object lookup. The IDL implemented by this CORBA connector is 
published with the toolkit, thus exposing the MBean Server remotely accessed by a non-Java 
connector client.  

 

 
 

Fig 3. CORBA Connector Architecture 
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3.0 Supported Standards 
 

Standards Compatibility Supported 
Version Key Benefits  

JMX, Java Management 
Extensions Instrumentation 
and Agent Specification  

1.0, Final 
Release 

Defines an architecture, the design patterns , 
the APIs, and the services for application and 
network management in the Java 
programming language. 

SNMP (Simple Network 
Management Protocol) v1, v2 and v3 

Defines the communication mechanism 
between the managed entities and the 
management station, the information model 
and the security and access control 
mechanisms for sharing management 
information. 

TL1  

 

GR831 
standard 

Transaction Language 1 (TL1) is an ASCII-
based management protocol widely used in 
the telecom industry for managing the telecom 
infrastructure.  

Because TL1 is ASCII based, it can be used 
as both Human to Machine and Machine to 
Machine language, without any translations. 

JDBC 1.1 & 2.0 

Provides database vendor and technology-
independent (RDBMS, ODBMS etc.) and 
platform-neutral APIs to access data from 
multi tier and client-server applications. 

Java RMI Greater than 
1.0 

Facilitates distributed computing so that 
distributed applications with high scalability 
and performance goals can be built. 

CORBA 2.3 

Provides a programming language-
independent distributed object computing 
environment on which highly scalable 
applications can be built. 

HTTP 1.0, 1.1 

Facilitates a standard 
communication mechanism between Web 
Browser Client and the Web Server.  HTTP is 
also used as communication mechanism 
between other clients and servers. 

JSP 1.1 

Enables rapid development of web-based 
applications that are platform independent. 
JavaServer Pages technology separates the 
user interface from content generation 
enabling designers to change the overall page 
layout without altering the underlying dynamic 
content. 

Servlets 2.2 

Enables running classes in the server 
(through Servlets), based on inputs from the 
client. Presentation of dynamic  response is 
also done from the Servlet. 

JFC (Java Foundation 
Classes)  JDK1.2.2 

Facilitates building user interfaces (GUIs) that 
have a platform-independent visual 
presentation. 
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Standards Compatibility Supported 
Version Key Benefits  

XML 1.0 

Facilitates an efficient data interchange 
between components of an application and 
between applications by providing an 
extensible mechanism to describe the 
meaning and hierarchical structure of data. 
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4.0 Creating a Simple Multi-Protocol agent Using JMX 
Compiler 
 

 
4.1 Overview 
4.2 Creating a New Project  
4.3 Loading MIB in JMX Compiler  
4.4 Generating Code for the MIB  
4.5 Compiling the Generated Code  
4.6 Starting and Stopping the Agent  

 
 
4.1 Overview 
 
This chapter  guides you through a step-by-step procedure to create, compile, and run a simple Multi-
Protocol agent. This agent will be created based on the default options provided in the JMX Compiler with 
support for SNMP, HTTP, TL1, RMI, CORBA, and HTML adaptors.With this agent, you will be able to 
retrieve the default values provided in the agent. 
 
4.2 Creating a New Project 
 
Please follow the steps given below to create a new project for the simple Multi-Protocol agent :  

• Start JMX Compiler from the Launcher or by executing the JMXCompiler.bat/JMXCombiler.sh 
from the <Agent Toolkit Home>/bin directory. 

• Project Dialog appears with three tabs namely New Project, Open Workspace and Recent 
Workspace. Project dialog opens with New Project Tab if opened for the first time. If a project 
already exists, Project dialog appears with Recent Workspaces tab. 

• Create a new project from the Option File -> New Project. The Project Settings UI opens with the 
New Project tab enabled. 

• Select or create a workspace file for your project. There are two options available here : 
o Add to Current Workspace : This option will be enabled if a workspace is already open in 

your system. Choosing this option will add your project to the workspace file, which is 
already open. 

o Create or add to existing workspace : You can choose this option to create a new 
workspace file for your project or add your project to an existing workspace file available 
in your system. 

• Type the name of the new project file. The default project name is jmxproject01.prj for the first 
project opened. The JMX Compiler assigns the .prj extension to this file to identify it as the project 
file. For example, enter simpleJMXAgent and the project is named simpleJMXAgent.prj. 

• Specify the location where you want to save (and store) the project and its files. You can save 
them on a local drive in any folder or subfolder (for example, c:/simpleJMXAgent). The new 
project is created in. /jmxprojects directory by default. 

• After entering the above information, click the OK button to create a new project in the specify 
directory. Clicking the cancel button cancels the new project. 

The JMX Compiler settings is saved in the <ProjectName>.prj file, which is created for each project in the 
specified directory. Hence, you can open a particular project anytime with its current settings by selecting 
the workspace of that project.  
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4.3 Loading MIB in JMX Compiler 
 
On creating a new project,  the workspace dialog opens with the MibView Tab enabled. Please follow the 
steps given below to load a  MIB in the JMX Compiler, for the simpleJMXProject created above:  

• Load the MIB for which code is to be generated for the project by selecting the MIB -> Load MIB  
option in the Menu bar or load mib icon in the Toolbar. 

• The MIBs in <Agent Toolkit Home>/mibs directory get listed. You can make use of these MIBs 
or a MIB that you have already defined. Browse and select the required MIB File. In this chapter, 
you will load the AGENT-SAMPLE-MIB for which code is to be generated. 

• You can also load multiple MIBs in the JMX Compiler by following the above steps. 
You will find the MIB displayed as a tree in the top panel of the workspace dialog. The Settings Menu 
provides various options based on which code is generated.  In this example, you implement the 
simpleJMXAgent with default options.  
 

 

Note: You can use MIB Editor to create your own Mib File.  MIBs created by other 
sources can also be used to  generate code in the JMX Compiler.  To know about the 
steps involved in defining MIBs using MIB Editor, please refer to the topic Defining a 
MIB 

 
4.4 Generating Code for the MIB 
 
Please follow the steps given below to generate code for the AGENT-SAMPLE-MIB. The generated code 
will be based on the Model MBeans specified by JMX specification. 

1. >Select the Build->Generate Source option or the  generate icon on the toolbar, which generates 
source files corresponding to the AGENT-SAMPLE-MIB. 

2. The Debug window opens and displays information about the generated source files under the 
projects directory. After the code generation, it says Code generation succeeded for project : 
simpleJMXAgent.prj. 

3. The files are generated in <Agent Toolkit Home>/jmxprojects/simpleJMXAgent/agent/src 
directory. 

4. You can  also view the files generated for the project in the Fileview Tab of the WorkSpace 
dialog. 

4.5 Compiling the Generated Code 
 
After generating the code for the loaded MIB file(s), the next step in agent development is compiling the 
source code. You can instrument the source code according to your requirements before compilation. In 
this example, you compile the source code without any instrumentation. Compiling the generated code 
can be done either from the JMX Compiler UI  or from the Command prompt.  
 

From JMX Compiler UI  
 

Follow the steps given below to compile the generated code from the JMX Compiler UI. 
1. Select the Build -> Compile Source option or the compile icon on the toolbar to compile 

the source file. 
2. The compilation Output panel opens and displays information about Compilation of files 

under the projects directory. 
3. On successful compilation, the message Compilation Success is displayed. Now, you 

have successfully compiled your agent. 

AdventNet Inc. 24



Multi-Protocol Agent 

From Command Prompt  
 

You can also compile the source from the command prompt. Please follow the steps given below 
to compile the source files from the command prompt. 

1. Open a command prompt/terminal. 
2. Go to the <Agent Toolkit Home>/jmxprojetcs/simpleJMXAgent directory. 
3. Update the path variable. 
4. Execute the following  command javac -d agent\bin agent\src\*.java 

 

Note: Before executing javac, update the PATH variable, if you want to 
run the SDK executable javac.exe conveniently from any directory. To 
know how to set the path variable, please refer to Troubleshooting- 
General Section 

 
The above command compiles all the files under agent/src directory. If the compilation is 
successful, the compiled class files can be found under 
jmxprojects/simpleJMXAgent/agent/bin directory. 

 
Now, all the files have been compiled and the simpleJMXAgent can be started.  

 
4.6 Starting and Stopping the Agent 
 
After successfully compiling the Multi-Protocol agent, you can start the Agent either from the JMX 
Compiler UI or from the Command prompt as explained in the proceeding sections.  
 

Starting and Stopping the Agent from JMX Compiler UI 
1. To start the agent, select Build -> Start Agent option in the Menu bar. This starts the 

agent at the default port numbers specified for the adaptors in the UI options. This action 
is reflected  with the following message: 
 
Starting agent of project jmxproject05.prj 
RMI Connector Server started t port; [1099] 
SnmpAgent is started ... at port 8001 
HTTP Connector started at port 8050 
CORBA Connector Server started at port:[1050] 
TL1 Server started on 9099 

2. To stop the agent, select Build -> Stop Agent option in the Menu bar. This action is 
reflected with the following message: 
 
Stopping agent .. 
Agent stopped.. 

Starting and Stopping From the Commmand Line 
 

Follow the steps given below to start  Agent from the command prompt. 
1. Open a command prompt/terminal. 
2. Go to the <Agent Toolkit Home>/jmxprojects/simpleJMXAgent/agent/bin directory 

where the compiled files are available. 
3. Execute the run.bat/.run.sh command. This instantiates the different adaptors and starts 

the Multi-Protocol agent. The adaptors get started at the default port numbers. The 
default port numbers, where they get started are: 
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HTML Adaptor - 8030 
SNMP Adaptor - 8001 
RMI Adaptor - 1099 
CORBA Adaptor - 1050 
HTTP Adaptor - 8050 
TL1 Adaptor - 9099 
 
The port numbers can be specified for the different adaptors from the command line also. 
The various command line options are : 
 
String usage = "[-a enables_Http_authentication] [-sp snmp_port] [-hp html_port] [-rp 
rmi_port] [-cp corba_port] [-hcp http_port] [-tp tl1_port] [-d debuglevel (1-6)]"; 

4. On executing the run.bat/sh command, the following message is displayed : 
 
RMI   Connecter Server started at port:[1099] 
SnmpAgent is started... at port 8001 
HTML Adaptor started at port 8030 
HTTP Connector started at port 8050 
CORBA Connecter Server started at port:[1050] 
TL1 Server started on 9099 
 
This means that the Multi-Protocol agent has been successfully started on RMI port 
1099,  SNMP port 8001, HTML port 8030, HTTP port 8050, CORBA  port 1050, and TL1 
port 9099. 

5. To stop the Agent, use Ctrl + C, This would kill the application. 
 
Now that the Agent is developed and started, the next step is to test the Multi-Protocol agent  by sending 
SNMP, HTTP, TLI, RMI, CORBA & HTML requests using the respective protocols. To know how to 
perform Testing on the Multi-Protocol agent, please refer to Testing the Multi-Protocol agent section.  
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5.0 Configuring the Multi-Protocol agent 
 

 
5.1 Overview  
5.2 Configuring Source Code Generation  
5.3 Configuring SNMP Adaptor  
5.4 Configuring HTML Adaptor  
5.5 Configuring RMI Adaptor  
5.6 Configuring CORBA Adaptor  
5.7 Configuring HTTP Adaptor  
5.8 Configuring TL1 Adaptor 
5.9 Configuring JMX Standard Services  
5.10 Configuring AdventNet Services  
5.11 Compile Options 

 
 
5.1 Overview 
 
JMX Compiler allows you to configure the Project from the User Interface (UI) itself. This configuration is 
done using the Settings panel invoked using any one of the following: (1) Project -> Settings menu option 
(2) Settings icon from the toolbar (3) Ctrl+Shift+S hot key.  This chapter describes the various settings 
that can be configured while working with the Multi-Protocol agent. 
 
5.2 Configuring Source code generation 
 
Selecting Source Code Generation -> General option, from the Project -> Settings tree,  provides general 
code generation options, based on which code is generated for the Multi-Protocol agent. Each option 
provided in this panel, is explained below. 
 

5.2 1Package Name 
 

The Package Name provided in this option, will be taken as the package name for the generated 
Java files. The default package name provided is com.myCompany.myPackage. You can 
specify any other name other than the default name provided.  

 
5.2.2 Agent Name  

 
The Agent Name provided in this option, refers to the Main File Name.  The default name 
specified is AdventNetJMXAgent. You can specify any other name other than the default name 
provided. 

 
5.2.3 Merge with previous stub files  

 
This option is used to merge the user added code, with the newly generated code. If this option 
is not selected, the information added by the user will be lost.  By default, merge with stub files 
option is checked. For more information on Merging, please refer the topic Code Merging.  

 
5.2.4 JMX Notification on Set 

 
The easiest way to test the Notification generation is, send the Notification, if the trap variable is 
accessed by the manager. If the option, JMX Notification on Set is selected in Settings -> Source 
generation, the JMX Compiler will generate code fragment (call to send the corresponding 
notification) in the following files : 
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• For a Scalar group : xxxInstrumentExt.java 

• For a Table group : xxxEntryExt.java 
This code is generated for each trap variable defined in the MIB. The corresponding Notification 
function is generated in the Main file. On calling this function the corresponding Notification will 
be sent to the registered managers. This function can be called from anywhere in the agent.  

 
If this  flag is not SET, then the code fragment will not be generated. This option is selected by 
default.  
 

 

Note: Trap variable, is one of the objects defined in the trap or 
notification construct of the MIB. Hence it is required to define the Trap 
type or Notification type before choosing the option to generate 
notification on SET.  

 
5.2.5 Using CommandLine Tool 
 
Agent Toolkit provides command line options for code generation. This feature is not designed to 
be used as a standalone utility but intended to add command line control to GUI-assisted agent 
development process. The project file serves as the input. 
 
5.2.6 Location of Commandline Utilities 
 
The script files responsible for invoking the Command Line Utilities are available under 
<ATKT_Home>/bin directory where <ATKT_Home> is the working directory of Command Line 
Utility. The relevant script files are generated under the working directory as 
JMXAgentSourceGen.bat / JMXAgentSourceGen.sh files. 
 
5.2.7 Operating the Commandline Utilities 
 
To accomplish the command line source generation, the following command has to be executed. 
 

//Syntax of the Command in Windows Operating Environment 
ATKT_Home\bin\XXXAgentSourceGen.bat -x <Project file location> 
 
//Syntax of the Command in Linux/Solaris Operating Environment 
sh ATKT_Home\bin\XXXAgentSourceGen.sh -x<Project file location> 
 
//A typical input will look like this: 
ATKT_Home\bin\JMXAgentSourceGen -x 
C:\AdventNet\JavaAgent\jmxprojects\TestProject\TestProject.prj 

 
5.2.8 Instrument with Interface  

 
Select the option to support interface mode of code generation. For a non-table group node, the 
Interface file will be generated as xxxInterface.java. For a table node, the Interface file will be 
generated as xxxEntryInterface.java file.  You have to implement this interface.  

 
This option is not selected by default.  
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5.2.9 Synchronized Set Methods  
 

The option Synchronized set methods generates code with the set methods in the 
entry/instrument files as synchronized. This option may be extremely useful when running the 
multiple agents in a single JVM with the same stubs answering for requests on all the agents  

 
This option is selected by default.  

 
5.2.10 Package Agent  

 
The option Package Agent in Build Menu, when selected,  copies the required agent binaries for 
running the agent from the  <AdventNet>/JavaAgent directory into <Agent Toolkit 
Home>/jmxprojects/<projectname>/agent folder. This makes the agent self-contained and it can 
be used as an independent project.  Please refer the topic Packaging the Agent for more 
information.  

 
5.2.11 Asynchronous Message Processing  

 
Asynchronous Message Processing is supported in SNMP and TL1 protocols.  It enables the 
SNMP/TL1 adaptor in the Multi-Protocol agent to handle more than one request simultaneously.  

 
Asynchronous Message processing is achieved by using Multithreading. Every functionality of 
the SNMP/TL1 Agent runs in a separate thread and can be accessed for Asynchronous 
Message processing.  

 
The user can enter the number of threads that the agent needs to support. The default number 
of threads configured in the JMX Compiler is 2.  The maximum number of requests that can be 
handled at a time is 20.  

 
Configuring Asynchronous Message Processing using API calls : 

 
For running the SNMP adaptor in asynchronous mode add the following piece of code in the 
Main file generated inside the method generated for registering the SNMP adaptor. 
 

snmpadaptor.setAsynchronousMode(new Boolean(true)); 
 
By default the number of threads created will be one. And the maximum number of threads that 
can be handled is 20. This can be altered by calling snmpadaptor.setMaxThreads(int) in the 
Main file. This code gets generated, if asynchronous mode is set "true".  

 
5.2.12 View based Authorization 

 
View-Based Authorization Support provides an authentication mechanism to restrict the users' 
access to a Multi-Protocol agent. The users entitled to log on to the system alone would be 
configured with a user name and password, along  with the details of the privileges they can 
avail,  i.e., the extent of access allowed. The unauthorized client would not be able to infiltrate.  

 
Please refer the topic, View-Based Access Support for MBeans in Multi-Protocol Agent for 
more information. 
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5.2.13 Debug Level  
 

When the Agent is running, it generates log messages for you to know about the Agent 
processing. These log messages are stored in a text file called agent(n).log.  Each log message 
has an associated log Level. The Level gives a rough idea about the importance and urgency of 
a log message. You can select the level of log message to be recorded in the log file. Each of 
these Debug levels are explained in the topic,  Logging support for the Multi-Protocol agent.  

 
5.2.14 Storage Model  

 
Data held by the Multi-Protocol agent may either be stored  in Text files, XML files, Databases, 
runtime Memory or can be retrieved from external applications (user storage model). The 
storage options depend on the data held by the run time agent. Please refer the topic Supported 
Storage Types for MBeans to know more about the storage options provided by the Multi-
Protocol agent. 

 
5.3 Configuring SNMP Adaptor 
 
The JMX Compiler provides options to configure the SNMP adaptor supported by the Multi-Protocol 
agent. By default code is generated for SNMP adaptor, with the default configurations.  
 
To disable support for the SNMP adaptor or configure the SNMP adaptor settings, select Adaptors -> 
SNMP -> General  in the Settings tree structure.  
 

5.3.1 General Configuration 
 

The following general options for the SNMP adaptor can be configured here.  
 

SNMP Adaptor : When this option is selected,  code is generated for SNMP Adaptor to get 
registered with MBean Server thus allowing management through SNMP.  If this option is not 
selected, the Multi-Protocol agent will be generated without SNMP support.  

 
SNMP Port :  Specify the port number where the SNMP agent is started.  The default port 
number is 8001.  

 
Version: The supported SNMP versions are v1/v2c/v3.  Select the version to be supported by 
the SNMP agent. 
 
Disable Startup Trap: By default, the generated agent sends coldstart trap at the agent startup to 
the managers being configured. The user can disable the trap at agent startup by enabling the 
option provided in the MIB Compiler UI by choosing Project->Settings->Source Generation -
>Disable Startup Trap.  

 
5.3.2 Configuring acl table/vacl table for v1v2Authentication  

 
The SNMP Adaptor of the Multi-Protocol agent supports Community based Authentication and 
View based access control for SNMPv1 and SNMPv2c requests. On receiving a SNMPv1 or 
SNMPv2c message from the manager, the agent will check for authentication with the received 
community string and the received SNMP message type (GET,GET-NEXT etc.). The view based 
access for v1/v2c agents is specified purely based on the community specified in the aclTable. 
Only if the community is authenticated in the aclTable, can that be given view based  access.  

 
Please refer the topic, SNMP Adaptor - Authentication which explains the options provided in 
the JMX compiler to configure the acl and vacl Tables.  

 

AdventNet Inc. 30



Multi-Protocol Agent 

5.3.3 Configuring Trap Forwarding Table  
 

For sending Traps and Notifications to multiple Managers, a table called the Trap Forwarding or 
Manager Table is maintained by the SNMP agent. This table stores all the Manager's 
information.  

 
Please refer the topic SNMP Adaptor - Traps which explains the options provided in the JMX 
Compiler to configure the Trap Forwarding Tables. 
 
5.3.4 Configuring USM and VACM Tables 

 
To configure the SNMPv3 agent with USM and VACM entries,the USMUserTable and VACM 
tables are maintained by the SNMP agent. 

 
Please refer the topic,SNMP Adaptor - SNMPv3 which explains the options provided in the JMX 
Compiler to configure the USM and VACM Tables. 

 
5.4 Configuring HTML Adaptor 
 
The JMX Compiler provides options to configure the HTML adaptor supported by the Multi-Protocol 
agent. By default code is generated for HTML adaptor, with the default configurations. To disable support 
for the HTML adaptor or configure the HTML adaptor settings, select  Adaptors -> HTML -> General in the 
Settings tree structure.  
 

5.4.1 General Configuration 
 

The following general options for the HTML adaptor can be configured here.  
 

HTML Adaptor  
 

When this option is selected, code is generated for HTML Adaptor to get registered with MBean 
Server thus allowing management through HTML. If this option is not selected, the Multi-Protocol 
agent will be generated without HTML support. 

 
HTML Port  

 
Specify the port number where the HTML service is started. The default port number is 8030.  

 
5.4.2 SSL 

 
SSL refers to the Secured Socket Layer protocol which provides authenticated and encrypted 
communication between clients and servers.  Select the SSL Support  option in Adaptors -> 
HTML -> SSL  to provide SSL support to the HTML Agent.  

 
Please refer the topic HTML Adaptor - Using SSL for Communication Through HTML 
Adaptor to know more about SSL.  

 
5.4.3 Authentication 

 
The HTML Adaptor of AdventNet Agent Toolkit supports authentication feature. A simple 
challenge-response authentication mechanism is adopted, where the server may challenge the 
client and the client responds with the authentication information. When a user connects to the 
agent through the HTML Adaptor, authentication is done based on user name and password. 

 
Please refer the topic HTML Adaptor -  Authentication to know more about the authentication 
feature  
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5.5 Configuring RMI Adaptor 
 

The following options provided in Settings -> Adaptors -> RMI,  is used for configuring the RMI 
Connector. 

 
RMI Connector  

 
When this option is selected, code is generated for RMI Connector to get registered with MBean 
Server thus allowing management through RMI. If this option is not selected, the Multi-Protocol 
agent will be generated without RMI support.  

 
RMI Port 

 
Specify the port number where the RMI Service gets  started. The default port number is 1099. 

 
Authentication 

 
The RMI adaptor exposes the attributes and operations of all the MBeans registered with the 
MBean server of the JMX Agent. You may want to restrict the access to the MBean information. 
This can be done using the Authentication feature. Here, the user is authenticated based on the 
user name and password.  

 
The Authentication feature may be enabled either from the JMX Compiler user interface or by 
using API calls.  Please refer the topic RMI Adaptor to know more about  configuring 
authentication 

 
5.6 Configuring CORBA Adaptor 
 

The following options provided in Settings -> Adaptors -> CORBA,  is used for configuring the  
CORBA Connector.  

 
CORBA Connector 

 
When this option is selected, code is generated for CORBA Connector to get registered with 
MBean Server thus allowing management through CORBA.   If this option is not selected, the 
Multi-Protocol agent will be generated without CORBA support. 

 
CORBA Port 

 
Specify the port number where the CORBA Service gets  started. The default port number is 
1050.  

 
Authentication  

 
The CORBA connector exposes the attributes and operations of all the MBeans registered with 
the MBean server of the Multi-Protocol agent. You may want to restrict the access to the MBean 
information. This can be done using the Authentication feature. Here, the user is authenticated 
based on the user name and password. 

 
The Authentication feature may be enabled either from the JMX Compiler user interface or by 
using API calls.  Please refer the topic CORBA Adaptor to know more about configuring 
authentication. 
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5.7 Configuring HTTP Connector 
 
The following options provided in  Adaptors -> HTTP,  is used for configuring the  HTTP Connector.  
 

5.7.1 General 
 

HTTP connector  
 
When this option is selected, code is generated for HTTP Connector to get registered with the 
HTTP; Server thus allowing management through HTTP. If this option is not selected, the Multi-
Protocol agent will be  generated without HTTP support 

 
HTTP Port  

 
Specify the port number where the HTTP Service gets  started. The default port number is 8050.  

 
SSL 

 
SSL refers to the Secured Socket Layer protocol which provides authenticated and encrypted 
communication between clients and servers.  Select the SSL Support  option in Adaptors -> 
HTTP -> SSL  to provide SSL support to the HTTP Agent.  

 
Please refer the topic HTTP Connector - Using SSL for Communication Through HTTP 
Connector  to know more about SSL.  

 
5.7.2 Authentication 

 
The HTTP Connector of AdventNet Agent Toolkit supports authentication feature. A simple 
challenge-response authentication mechanism is adopted, where the server may challenge the 
client and the client responds with the authentication information. When a user connects to the 
agent through the HTTP Connector, authentication is done based on user name and password.  

 
Please refer the topic HTTP Connector -  Authentication to know more about the 
authentication feature  

 
5.8 Configuring TL1 Adaptor 
 

5.8.1 General 
 

The options provided in Settings -> Adaptors -> TL1,is only for configuring the TL1 adaptor. The 
following General Settings options are available for the TL1 Adaptor.  

 
TL1 Adaptor 

 
When this option is selected, code is generated for TL1 Adaptor to get registered with MBean 
Server thus allowing management through TL1. If this option is not selected, the Multi-Protocol 
agent will be generated without TL1 support. 

 
Craft Interface 

 
TL1 managed devices can be managed both locally by craft interface and remotely over any 
transportation protocol by an OSS. Selecting this option will take Craft  interface as the default 
startup mode. 
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TCP/IP Interface 
 

If this option is selected by default then the TL1 agent use TCP/IP interface on startup. This 
option is selected by default.  

 
Self-Monitoring 

 
Selecting this option will enable the self monitoring feature in the TL1 Agent. The Self Monitoring 
feature allows the TL1 Agent to monitor the following agent details : 

• Input Request Received 

• Autonomous Messages Sent 

• Acknowledgement Messages Sent 

• Pending Messages 

• Output Responses 
Please refer the topic Self Monitoring to know more about using this feature. 

 
Built-In-Commands 

 
Selecting this option will add the Build in Commands support in the TL1 Agent. The following 
Built in Commands are  supported by the TL1 Agent. 

• Inhibit Autonomous Messages 

• Allowing Autonomous Messages 

• Clearing Autonomous Messages 

• Setting Source Identification 

• Getting list of build in commands 

• Getting all registered commands 
Please refer the topic Build in commands to know more about using this feature. 

 
TL1 Port  

 
Specify the port number from where the TL1 agent should be started. The default port number is 
9099. 

 
5.8.2 Security 

 
Security is implemented in the TL1 Agent as per GR 815 and 835, to prevent the possibility of 
deliberate or accidental attack on the TL1 NE.  The Settings -->Adaptors -> TL1 Security option 
opens the TL1 Security Table Configurations Dialog for the TL1 security. 

 
Following options are available in the Security settings.  

 
Enable Security  

 
If you do not require security for your project, do not enable this option. If this option is enabled, 
User Security gets enabled by default. It is mandatory, if security is enabled. The other securities 
namely Command, Channel, Operation, and resource can be enabled here if required.  
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Log File Size 
 

This is the size of the log file in Kilobytes which logs the security-related information.  
 

Security View 
 

For the securities enabled in the Security Block, the corresponding security view can be selected 
here, and the values for its parameters can be added and modified from the table below the 
Security View. Please refer the topic, TL1 Adaptor - Security to know more. 

 
5.9 Configuring JMX Standard Services 
 
AdventNet Agent Toolkit supports the following JMX standard services. These services can be configured 
from the JMX Compiler by selecting JMX Standard Services  in the Project -> Settings tree.  The links 
provided will take you to the respective chapter which describes in detail the implementation details and 
the procedure to configure the service from JMX Compiler UI.  

• Management Applet service 

• Timer service 

• Monitor service 

5.10 Configuring AdventNet Services 
 
In addition to the JMX Mandatory services AdventNet Agent Toolkit provides the following some 
proprietary services. The JMX Compiler allows you to configure these services  by selecting AdventNet 
Services  in the Project -> Settings tree. The links provided will take you to the respective chapter which 
describes in detail the implementation details and the procedure to configure the service from JMX 
Compiler UI. 

• Cascader service 

• Discovery service 

• JMX-SNMP Proxy service 

5.11 Compile Options 
   
The following options are available under Settings -->Compile Options. 
 
Compile Options 
 
This option is used for giving "javac" options as input while compiling. The various options of "javac"  can 
be got by typing "javac  -help" in the command line. 
 
Classpath Settings 
 
This option is used to add the required classpath settings that will be used during the source compilation. 
You can browse and select the required class files/jar files to be added to the classpath settings, using 
the Add button. Similarly, if any settings are not required, the same can be deleted using the delete 
button. 
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6.0 Testing Multi-Protocol agent 
 

 
6.1 Overview 
6.2 SNMP Testing using MIB Browser 
6.3 Configuring MIB Browser 
6.4 RMI/CORBA/HTTP Testing using MBean Browser 
6.5 Configuring MBean Browser 
6.6 TL1 Testing using TL1 Browser 
6.7 Sample TL1 Commands 
6.8 Configuring TL1 Browser 
6.9 HTML Testing using HTML Browser 

 
 
6.1 Overview 
 
This section explains the steps involved in testing the Multi-Protocol agent using various adaptors. It is 
assumed  that a Multi-Protocol agent is created using AGENT-SAMPLE-MIB following the steps given in 
the topic Creating a Simple Multi-Protocol agent using JMX Compiler and the Multi-Protocol agent is 
started at the following port numbers :  

• HTML Adaptor - 8030 

• SNMP Adaptor - 8001 

• RMI Adaptor - 1099 

• Corba Adaptor - 1050 

• Http Adaptor - 8050 

• TL1 Adaptor -9099 

6.2 SNMP Testing using MIB Browser 
 
To test the agent in SNMP Adaptor,  

• Start the MIB Browser  by selecting the Tools -> MIB Browser option from the Menu bar or by 
selecting the MIB Browser icon. Now, the MIB Browser opens with  the AGENT-SAMPLE-MIB  
loaded in it. 

 

Note: The MIB Browser can also be started .from the Launcher or by 
executing the MibBrowser.bat/ MibBrowser.sh from the <Agent 
Toolkit Home>/bin directory 

• Expand the AGENT-SAMPLE-MIB tree. Select the enterprises node and do a query by selecting 
Operations -> GET or clicking on the GET icon. Now, you should see the agent responding with 
the default values as shown in the screen shot  given below: 
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To know more about the SNMP operations that can be performed on the agent, please refer to the topic, " 
Testing the Agent", under the section Building SNMP Agents.  
 
6.3 Configuring  MIB Browser  
 
Please refer the topic "Testing the SNMP Agent": in the Building SNMP Agents Section to know more 
about using MIB Browser and its configurations.  
 
6.4 RMI/CORBA/HTTP Testing using MBean Browser 
 
To test the agent using the RMI Connector / CORBA Connector or HTTP Connector, 

• Start the MBean Browser by selecting the Tools -> MBean Browser option from the Menu bar or 
by selecting the MBean Browser icon from the status bar.   

 

Note: The MBean Browser can also be started from the Launcher or by executing the 
MBean Browser.bat/MBean Browser.sh from the <Agent Toolkit Home>/bin directory. 

• Select "RMI Client " in the remote browser and click "connect" button. It gets connected to the 
Multi-Protocol agent using the RMI protocol.  You can see the MBeans in a tree structure in the 
left hand frame of the MBean Browser. 

• To access the attributes and to invoke operations on MBeans, select the nodes from the tree. 
Click to view the attributes displayed in the right frame. To modify the values, simply overwrite the 
old value with the new one in the attribute panel displayed  or else click operations and perform a 
set command. 
 
For example, select Operations for type=AgentSystemInstrumentExt. Select the operation, 
setAgentDescr and specify the value as simpleJMXAgent.Click OK button. You will find the 
modified value as shown in the screen shot below. 
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• Select "CORBA Client " in the MBean browser and click "connect" button.  It gets connected to 

the JMX server using the IIOP protocol.  It should display the changes made above. 

• For HTTP, select  HTTP Client in the MBean Browser and click "connect" button. It gets 
connected to the JMX server using the HTTP protocol.  Access the attributes and invoke 
operations on MBeans by selecting nodes from the tree. 

• Using MBean Browser, you can also perform the following services on the Multi-Protocol agent 
through RMI/CORBA/HTTP: 

o Register/Unregister an MBean from the MBean tree structure, using Settings -> 
Register/Unregister option. 

o Discover AdventNet Multi-Protocol agents in the network, using  Settings -> Discovery 
Service option. 

o Poll the agent at specified intervals to know the status of the connector, using Settings -> 
Heartbeat Service. 

o Change the client settings,  using Settings -> Client Settings option. 
o Select View -> Notifications to view the messages sent by the agent to the manager. 

6.5 Configuring MBean Browser  
 
The AdventNet MBean Browser is a Manager application which enables the user to access a Multi-
Protocol agent's MBeans and use the provided services through the RMI / CORBA/ HTTP protocol 
adaptor or connector. To accomplish this, the Multi-Protocol agent must be started which instantiates the 
different adaptors/connectors at their specified port numbers.  
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The MBean Browser uses the client side API provided for accessing the MBeans through the connectors 
(RMI Adaptor or CORBA Adaptor) at the server side. The default hostname and the ports are:  

• Corba - localhost:1050  

• RMI - localhost:1099  

• HTTP - localhost:8050 
Once the MBean Browser establishes connection with a particular adaptor or connector, access to all the 
MBeans registered with the MBean server is provided through the respective connectors. The Remote 
Object Browser supports the MBean Tree View by listing all the MBeans registered with the MBean 
Server in a tree structure.  
 
This section explains how to work with the test tool - MBean Browser.  
 

6.5.1 Connect/Disconnect  
 

To connect or disconnect to the server, do the following steps:  

• Select the client through which you would like to connect to the server, from the Client 
Menu  or from the Toolbar bar icon. You can opt for the client of your choice from the 
three options  provided. The options are RMI, CORBA and HTTP client.  Icons are also 
provided for the same. You can connect to only one protocol at a time. 

• On choosing the client, choose Operations -> Connect from the Menu bar or from the 
toolbar icon. Once the connection is established with the server, you will get the message 
"Connection  established with <server name> at port <port number> in localhost " in the 
Status bar. 

 

Note: Make sure the agent is running at the required port before trying 
to establish a connection with the server from MBean Browser. 

• All the MBeans registered with the MBean server, will be listed in the left-hand side tree 
structure. The MBeans are grouped according to the Domains and listed under the root 
domain. 

• To disconnect the established connection, select Operations -> Disconnect from the 
Menu bar or from the toolbar icon. 

• To connect through a different client,  you have to first disconnect the existing 
connection, select the client and get connected to the server. 

6.5.2 Configuring Discovery Service 
• To discover the Multi-Protocol agents in a network, from MBean Browser, select the 

option Settings -> Discovery. This will display the Discovery Service Panel . Here, the 
default multicast group for AdventNet discovery service is 225.225.225.255 and multicast 
port is 8222. You can change this to any other IP Address and Port number. Also, specify 
the Timeout value within which the discovery client has to discover the Multi-Protocol 
agent. 

o Select the Start button to discover the Multi-Protocol agents running in the 
network, which has implemented the discovery service with the same multicast 
group and port. 

6.5.3 Configuring Heart Beat Mechanism 
 

In a client-server architecture, the connection between these two entities is indispensable for any 
transaction to be performed. The heart beat mechanism determines the existence of such 
connection through constant monitoring action.  
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The RMI/ CORBA/ HTTP client (Manager) is connected to the server (Agent) through the 
respective connectors. If the server is down or the agent to which the client is connecting is not 
running at the specified port due to some reason, the manager does not know the status of the 
agent and keeps sending queries and waits for the reply for a particular time interval. If there is 
no response even after the specified time interval it throws an error message.  
 
To avoid this delay, the manager can poll the agent at specified intervals, to know the status of 
the connector. This is done using the Heart Beat Service. 

 
Select Operations -> Heartbeat Service. This  displays the Heart Beat Settings dialog. 
In order to start the Heart Beat service select the Enable Heartbeat option. 

 
Specify the time interval (in seconds) at which the manager has to poll the agent as Heartbeat 
rate and click OK. 
 
This will enable the Heartbeat service in the manager.  
 
6.5.4 Register/Unregister MBean 

 
The Register/Unregister service allows the user to Register or Unregister an MBean with the 
MBeanServer through the MBean Browser.  

• Select the Settings -> Register/Unregister option which will display the corresponding 
panel to enter the values. The various fields that are to be entered by the user to 
register/unregister an MBean are listed below: 

o Action 
o DomainName 
o Keys 
o ClassName 
o XML FileName ( optional) 
o ClassLoader. ( optional) 

The mandatory fields to register the MBean are DomainName , Key/Value Pairs, ClassName.  
DomainName :The DomainName is the domain under which the MBean has to be registered.  
For example, Adaptors, Services, JMImplementations etc Keys: The DomainName and the 
Key/Value Pairs together form the ObjectName.  For example, type=AgentSystemInstrument 
ClassName :The ClassName is the name of the class of the MBean. This class should be in the 
CLASSPATH for the MBean to get registered or else, the MBean does not get registered.  

 
XML File Name : Defining this field is optional. The XML FileName has to be specified in the 
case of registering a ModelMBean. The XML File Name path should be specified in relation with 
the JMX server.  
 
Class Loader : Defining this field is optional. If the ClassLoader is not specified, the default Java 
ClassLoader is used to register the MBean with the MBeanServer. If the classloader is explicitly 
said, then that ClassLoader is used to register the MBean.  
 
UnRegister :To UnRegister the MBean from the MBeanServer, it is enough to specify the 
ObjectName of the MBean.(i.e) the DomainName and the Key/Values pair of the MBean.  
 

 

Note: The XML FileName has to be specified in the case of registering 
a ModelMBean 
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6.5.5 Configuring Client Settings 
 

The settings for the client can be specified using the option Settings -> Client Settings .  This will 
display the following user interface with the default values. Please enter the values for the 
various fields before trying to connect to the agent.  

 
Client :  Select the Client through which you would like to connect to the server RMI/ CORBA/ 
HTTP.  
Host Name : Specify the host name of the Multi-Protocol agent.  
Port Number : Specify the port number where the Multi-Protocol agent is running.  

 
6.5.6 Filtering MBeans  

 
When MBean Browser is connected to a server, all MBeans registered with the server are listed 
in the MBean tree view. The Filter Service helps the user view only those MBeans that satisfy a 
given filter condition ( Filter pattern).  

 
The Syntax for Filter pattern according to JMX Specifications is given below: 
<DomainName>:<key>=<value>  
 
*is used to denote any character sequence, including an empty one  
?    is used to denote a single character  
   
Enter the Filter Pattern in the space provided above the MBean tree on the left side of the 
browser. Now, only those MBeans which have DomainName, Key and Value matching those in 
the Filter pattern will be displayed in the tree view .  
   
For example, 

 
To view the list of all MBeans present in the domain JMImplementation, the syntax to be given in 
the Filter MBean is :  
   
JMImplementation:* or *Implementation:*  
   
To view particular MBeans of the domain JMImplementation having key and value as type and 
XXX respectively, the syntax to be followed for the Filter Pattern is :  
   
*Implementation:type=XXX      (or)  
JMImplementation:type=XXX  

 
6.5.7 View Notifications 

 
Management applications need to react to a state change or to a specific condition when it 
occurs in an underlying resource. XMOJO JMX implementation supports JMX Notification Model 
which allows MBeans to broadcast such management events, which are called notifications.  

   
Select the View -> Notification option to view the notification details generated by the agent. 

 
6.6 TL1 Testing using TL1 Browser 
 
To test the agent using TL1Adaptor, follow the steps given below:  

• Start the TL1 Browser  by selecting the Tools -> TL1 Browser option from the Menu bar or by 
selecting the TL1 Browser icon from the status bar.  Now, the Browser is started. 
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Note:The TL1 Browser can also be started from the Launcher or by executing the 
TL1Browser.bat/ TL1Browser.sh from the <Agent Toolkit Home>/bin directory. 

• Load command set file and corresponding data set file, which is under 
<projectName>/agent/src/com/myCompany/myPackage directory by selecting File -> Load 
option or load icon.  A dialog prompts with the default command set and data set file. Select the 
Add option to browse and select the AGENT-SAMPLE-MIB.tcs file and AGENT-SAMPLE-
MIB.dat  file .  Click OK to add it to the TL1 tree. 

• Choose Operations -> Connectoption in the Menu Bar.  Enter the Host Name and Port Number 
where the agent is running in the dialog box that appears. By default  the host name will be 
localhost and port number will be 9099. Click OK. Now,  you will be connected to the Agent. 

• The next step is to Authenticate into the TL1 Agent . To do this, load the tl1security.tcs file using 
the File -> Load option. Select the  command ACT-USER  in the TL1 Security tree. The default 
user name and password for the Administrator are "root" and "public" respectively.   Hence, 
select ACT-USER command and specify the user name as root in the AID block and the 
password (PID) public in the MPB block. 

• After entering the user name and password values send the input message by selecting the  
in the toolbar or by selecting Operations -> Send  from the menu bar.  Now,  you will be 
authenticated into the TL1 Agent. The following autonomous message will be sent by the Agent 
to notify the completion of authentication. 

 
 
Select AGENT-SAMPLE-MIB.tcs , expand the tree and select the node, for example 

AGENT_SAMPLE_MIB-AgentSystem under GET-SCALAR group. Do a query by selecting the   
icon or by selecting Operations -> Send  from the menu bar. You will find the response from the agent 
displayed in the response block as shown below. 
 

 
 
Here, the agent responds with the default values specified .  You can repeat this operation with other 
commands listed in the TCS tree.  
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6.7 Sample TL1 Commands 
 
Few example TL1 Commands used for querying the MIB have been given under for better understanding,  

1. GET-SCALAR::AGENT_SAMPLE_MIB-AgentSystem-agentLocation:1::;  
This will get the value for agentLocation.  

2. GET-SCALAR::AGENT_SAMPLE_MIB-AgentSystem:1::; 
This will get the values of all the child nodes under the AgentSystem group.  

3. GET-ADISKTABLE::AGENT_SAMPLE_MIB-AdiskTable-adiskCapacity:2::3; 
This will give instance 3 for column adiskCapacity. 

4. GETALL-ADISKTABLE::AGENT_SAMPLE_MIB-AdiskTable:3::; 
This will give all the rows in the adiskTable.  

5. GETALL-ADISKTABLE::AGENT_SAMPLE_MIB-AdiskTable:4::3; 
This will give the 3rd row in the adiskTable.  

6. GETALL-ADISKTABLE::AGENT_SAMPLE_MIB-AdiskTable:5::3,5; 
This will give the rows 3 to 5 in the adiskTable.  

7. SET-SCALAR::AGENT_SAMPLE_MIB-AgentSystem-agentName:6::agent; 
This will set the value "agent" for agentName.  

8. SET-ADISKTABLE::AGENT_SAMPLE_MIB-AdiskTable adiskCapacity:7::1:240; 
This will set the value 240 for the 1st instance of adiskCapacity. If a table has multiple indices, 
they can be specified seperated by comma. Eg) ....:1,2:Team;  

9. CREATE-ADISKTABLE::AGENT_SAMPLE_MIB-AdiskTable:8::1,Name,10,4,6; 
This will create a row for adiskTable with the given values. Note that the index is given as one of 
the values. Here 1 is the index.  

10. DELETE-ADISKTABLE::AGENT_SAMPLE_MIB-AdiskTable:9::1; 
This will delete the row with instance 1 in the adiskTable.  

Thus, GET is used to get the value of a node. 
     SET is used to modify the value of a node in a table or a scalar group. 
     CREATE is used to create a row in the table and 
     DELETE is used to delete a row in the table.  
 
The Access Identifier specifies the MIB name, group name and the node name separated by hyphen. The 
Message Payload block contains the message - Instance, Value to be set etc. 
 
6.8 Configuring TL1 Browser 
 
Please refer the topic Configuring TL1 Browser Settings in the Building TL1 Agents section to know more 
about using TL1 Browser and its configurations.  
 
6.9 HTML Testing using Web Browser 

• Start the Web Browser by selecting Tools -> Web Browser . This opens the HTML Browser with 
URL: http://localhost:8030. You will find the MBeans listed in a tree structure in LHS frame. 

• The MBeans are grouped under different domains. Select a Domain name, for example 
AppMBeans, which displays the MBeans in the selected domain .  Select the MBean whose 
attribute you want to view and the related page gets displayed in the main frame as shown in the 
screen-shot below. 

• The attributes of the selected MBean are listed in table format with the following information: 
Attribute Name, Attribute Type, Attribute Access, Attribute Value, and Attribute Description. 
Values of Read-Write attributes are presented in editable text field. 
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• Attributes of Tabular data type are displayed as a Table. New rows can be added using the New 

Row button at the bottom of the page. The Delete button can be used to delete a row from the 
table. In case the the attribute value is of type array then a link is provided in the attribute value 
column and on clicking the link,  the values are listed in a separate page. 

• The dynamic HTML pages also allow you to perform operations on MBeans. If operations can be 
performed on an MBean, then the Operations button is displayed at the right-top corner of the 
the MBean attribute page. Clicking this button  lists the operations that can be performed on the 
MBean. Selecting an operation displays the following information pertaining to the MBean 
operation: 

o Operation Name: The name of the MBean operation. 
o Return Type: The data type of the value returned after performing the operation. 
o Description: Short description about the operation. 

• Apart from these, SET operations are provided with text fields to specify the attribute values.  
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7.0 Instrumenting General Code 
 

 
7.1 Overview 
7.2 Generated Code Structure  
7.3 Instrumenting the Generated Code  

 
 

 
7.1 Overview 
 
Instrumentation of the managed resources, an application, a service or an object representing a device, is 
the way that you can expose their desired output.  As specified in the previous chapter, the Agent Toolkit 
supports code generation for JMX instrumentation for a given MIB, using the JMX Compiler. 
 
The generated code will be based on the Model MBeans specified by JMX specification. Following the 
Model MBean, the specification provides the flexibility for Initialization with XML file, Persistence, and 
Caching for the attribute values.  
This chapter explains the process of adding the actual functionality to the generated code, so that the 
agent responds with the desired information.  
 
7.2 Generated Code Structure 
 
On generating the code, the instrumentation file and relevant XML files for the RequiredModelMBean will 
be generated along with the main file under respective directories. 

• Instrumentation files are generated under 
jmxprojects/<projectname>/agent/src/com/myCompany/myPackage/directory. 

• XML files are created under jmxprojects/projectname/agent/bin/conf/xml/mbeans/ directory. 
The typical set of files generated for a MIB group are explained below: 
 

7.2.1 Main File 
 

The default name of the Main File is AdventNetJMXAgent.java. You can configure the Main file 
name in the JMX Compiler by selecting Source Code Generation -> General  option, from the 
Project -> Settings tree.  Specify the Main file name in the Agent Name option.  

 
Composition of the Main File  

 
The main file has the MBean Server instantiated and the code for the initialization of all the 
adaptors lies here. Also, the generated instrumented objects are made as Model MBeans (using 
the RequiredModelMBean) and registered with the MBean Server. Thus, it does the following:  

1. Instantiates the MBean Server. 
2. Initializes the interested adaptors (which are chosen while code generation). 

 
Necessary code for sending traps (if trap definition is present in the MIB) will be present 
here. 
Any AdventNet SNMP Agent bean (e.g., SNMP Proxy, Dynamic Registration, etc.,) plug-
in to SNMP Adaptor can be done here.  

3. Makes all the generated JMX instrumentation codes into ModelMBean using the 
javax.management.RequiredModelMBean  class, initialized with the relevant XML file and 
registered with the MBeanServer.  For example, the following code is generated in the 
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main file AdventNetJMXAgent.java, for registering the agentSystem MBean of  the 
AGENT-SAMPLE-MIB, 

agentSystemInstrumentExt=new 
AgentSystemInstrumentExt(); 
xmlLocation = this.getClass().getResourceAsStream 
("/conf/xml/mbeans/AgentSystemInstrument.xml"); 
rmm = new 
RequiredModelMBean(com.adventnet.utils.jmx.Utilities. 
convertXmlToModelMBeanInfo(xmlLocation)); 
rmm.setManagedResource(agentSystemInstrumentExt, 
"objectReference"); 
notifTable.put(agentSystemInstrumentExt , rmm); 
name = 
"AdventNetJMXAgent:type=AgentSystemInstrumentExt"; 
server.registerMBean(rmm, new ObjectName(name)); 
rmm.load(); 

 
Because Notification is defined for the scalar group "agentSystem", the code gets generated as 
AgentSystemInstrumentExt  with the code notifTable.put(agentSystemInstrumentExt , rmm);  

• Note that the following code will be generated in the Main File, if any notification is 
defined for that MIB. While sending notifications, this method will be called from the 
xxxInstrumentExt file or xxxEntryExt file which will return a 
ModelMBeanNotificationBroadcaster and the sendNotification() method of this object will 
be called. 

private static Hashtable notifTable = new Hashtable(); 
public static ModelMBeanNotificationBroadcaster 
getNotifHandler(Object 
source) 
{ 
return 
(ModelMBeanNotificationBroadcaster)notifTable.get(sourc
e); 
} 

 
 
If the user has written his own MBean (such as Dynamic MBean, Standard MBean), then it can 
be registered with the MBean Server in this main file. Look at the example in 

 
<Agent Toolkit Home>/examples/jmx/dynamicMBean directory for Dynamic MBean and 
<Agent Toolkit Home>/examples/jmx/standardMBean directory for Standard MBean.  

 
The AgentSystemInstrument.java and AdiskTable.java are the objects to be wrapped by the 
RequiredModelMBean for the agentSystem group and the adiskTable in the MIB respectively. 
The RequiredModelMBean for these classes are initialized by their relevant XML files generated, 
namely AgentSystemInstrument.xml and AdiskTable.xml. 
 
The stub files where the user has to fill in the code are AgentSystemInstrument and AdiskEntry 
java files. Note that the AgentSystemInstrument will be persisted using the Model MBean 
persistence support as specified in its XML file, while for AdiskTable,the persistence is through 
the FileToVector support. If FileToVector option is turned off while code generation, then the 
AdiskTable also gets persisted using the Model MBean persistence support. 
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7.2.2 Instrumentation Files 
 

The JMX protocol-independent instrumentation file will be generated for each scalar and table 
MBean defined in the MIB. 

 
Instrument Files  

 
For each scalar MBean, one instrument file will be generated with the name xxxInstrument.java. 
This file will have the getter and setter methods for all the attributes in the MBean. For example,  
the instrument file generated for the scalar group agentSystem of the agent-sample-mib is  
AgentSystemInstrument.java. Following are the key features of Instrument files:  

• Instrument files are generated for all scalar MBeans. 

• Instrument files have the getters and setters for each attribute in the scalar MBean. 

• Instrumentation for the attributes present in the scalar Mbean can be done in this file 
only. 

Entry Files  
 

For each table MBean, one instrument file will be generated with the name xxxEntry.java. This 
file will have the getter and setter methods for all the columns in the table. In addition to this file, 
one more file will be generated for each table MBean with the name xxxTable.java. This file is 
registered as a modelMbean in the MBean server. This file is used to identify an entry in the 
table and call the corresponding getter and setter methods in the xxxEntry.java file.  

 
For example, the instrument file generated for the table group adiskTable of the agent-sample-
mib is AdiskEntry.java .  The AdiskTable.java is registered as a model MBean in the MBean 
server. Following are the key features of Entry files:  

• Entry files generated for all table MBeans. 

• Entry files have the getters and setters for each table attribute 

• Instrumentation for tables can be done in these Entry files. 

7.2.3 XML File 
 

For each scalar / table MBean , the relevant XML file is generated with the name 
xxxInstrumentr.xml for scalars and xxxTable.xml for tables. This file contains the 
attribute/operation information for making xxxInstrument.java or xxxTable.java as model Mbean. 

 
It also has the protocol-dependent details (for example, OID SYNTAX type details for SNMP) for 
each attribute of the MBean. These information get converted to relevant descriptor objects 
when its RequiredModelMBean instance is initialized with the XML file.  

 
For example, the XML file generated for the scalar group agentSystem of the agent-sample-mib 
is AgentSystemInstrument.xml . The XML file generated for the table group adiskTable is 
AdiskTable.xml  

 
7.2.4 Other Files 

 
Notification File 
 
This file gets generated when Notification is defined for that particular group. This file extends 
the xxxInstrument.java file for a scalar MBean and xxxEntry.java file for a table MBean and has 
all Notification details present in it.  
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For example, Notifications are defined in agentSystem group and adiskTable of the agent-
sample-mib. Hence, the Notification file generated for the scalar group agentSystem is 
AgentSystemInstrumentExt.java and for adiskTable is AdiskEntryExt.java  
 
Persistence Files 

 
The XMLtoVector file/FiletoVector file is generated  if persistence for tables in 'File to Vector' 
format or 'XML to Vector' format is provided. Depending on the storage option, this file is 
generated. This file has methods such as readFromfile() and writeIntoFile() for reading and 
writing into file.  

 
For example, if storage option for the adiskTable Mbean is provided in XML format, the 
AdiskTableXMLToVector.java file is generated. 

 
TL1 Command Set and Data Set Files 

 
To support common instrumentation for TL1 Adaptors (to be chosen in the UI of the JMX 
Compiler), two files get generated additionally. This is used to query the agent. The tcs folder 
gets generated when the TL1 Adaptor option is selected in the JMX Compiler. The two files that 
are generated additionally (.dat and .tcs) get stored under the 
jmxprojects/<projectname>/agent/src/com/myCompany/myPackage/folder.  

 
run.bat/sh File 

 
This file is used to run the Multi-Protocol agent. This file is generated in the <Agent Toolkit 
Home>/jmxprojects/projectname/agent/bin directory. 

 
7.3 Instrumenting the Generated Code 
 
Instrumentation (editing the generated code) for a desired function is done based on the  application and 
requirement of the user.  
 

7.3.1 Editing Files Generated for Scalars 
 

In section 5.4.2.2. Instrument files, we saw what are the stub files generated for a scalar group 
for the given MIB using JMX Compiler tool.  In this section, we will see how to instrument or fill in 
the stub file of the agentSystem group present in the agent-sample-mib.  

 
AgentSystemInstrument.java  

 
This class contains the protocol - independent stubs for the various objects defined in the 
agentSystem group of agent-sample-mib.txt MIB file. Users can fill in their stubs here. The 
instrumentation code has to be filled between these tags in order to support code merging when 
regenerated. 
 

/* User code starts here */ 
 /* User code ends here */ 

 
These are the custom tags, which can be used anywhere in the generated code. The user has to 
just include his code in the file with these tags. When code is regenerated, the JMX Compiler 
looks for these tags and preserves the changes in the newly generated code. If either of the tags 
is not given, code merging will not be proper.  Please refer to the topic "Code Merging" for more 
information.  
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For example, the getter method generated for the attribute agentDescr of the agentSystem 
Mbean is given below.  
 

/** 
* Handles the JMX Get Request for agentDescr 
*/ 
public String  getAgentDescr() 
throws AgentException { 
// Fill up the stub with required processing 
return agentDescr; 
} 

 
This getter method will be called from the adaptors when any GET/GETNEXT request is meant 
for the attribute agentDescr. By  default, it returns the default value "agentDescr not initialized".  
You have to add the required code within the user tags, so that the attribute agentDescr returns 
the desired output.  

 
7.3.2 Editing Files Generated for Tables  

 
The files generated for adiskTable of the agent-sample-mib are as follows :  

• AdiskTable.java 

• AdiskTable.xml 

• AdiskEntry.java 
AdiskTable.java  

 
This class contains getter and setter methods for just one attribute which is of type 
javax.jmx.openmbean. TabularData of name "AdiskTable". The utility methods in 
com.adventnet.utils.jmx.Utilities class take care of conversion of entries (AdiskEntry) to 
TabularData. AdiskTable class also has provision for setting the Vector/Hashtable of AdiskEntrys 
(the key for the Hashtable is Object[ ] of index objects.)  

 
AdiskTable.xml  

 
This XML file has only one attribute descriptor for "AdiskTable". The table's column information 
is furnished as various attribute descriptors inside the AdiskTable attribute description. This kind 
of specifying column information is of proprietary manner.  

 
AdiskEntry  

 
Instance of this class specifies a row of this table. It has the column's getter and setter methods. 
Users can fill in their stubs here.  
 

 
/**  
*Handles the  JMX  Get Request for adiskID 
*/ 
public Integer getAdiskID() 
throws AgentException { 
// fill up with necessary processing 
return adiskID; 
} 
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7.3.3 Code Merging  
 

Code merging, is an option provided for users who prefer to shift between releases. It is mainly 
used for migration purposes. Say, if a developer using 5.0 version of Agent Toolkit decides to 
migrate to the 5.1 version, then he can make use of this Merging option wherein the manually 
added code (using the tags) is merged with the code, present in the file generated by the new 
version of the toolkit, to attain the functions available in the old version. If this option is not 
enabled before regenerating a file, all the code added by the user would be lost. 
  
The user code is normally  added to the generated files using the following tags.  

 
// User code starts here 
//Add your code here.... 
// User code ends here 

 
OR 

 
/* User code starts here */ 
Add your code here  
/* User code ends here */ 

 
OR  

 
// AdventNet code ends here 
// Your code can be added here  
// AdventNet code starts here 

 
These are the custom tags which can be used anywhere in the generated code. The user has to 
just include his code in the file with these tags. When regenerated, the JMX Compiler looks for 
these tags and preserves the changes in the newly generated code. If either of the tags are not 
given merging will not be proper. Please note that the last tags are also supported and when 
these get generated in certain files, the user has to just include the codes between these tags 
which is generated, by default. Thus code merging is supported on all generated java files. 

 
             Enabling Code Merging Option in the JMX Compiler UI 
   
              This feature is enabled/disabled in the JMX Compiler UI as follows:  
                
              1) Click Project->Settings->Source Code Generation->General 
              2) Enable/Disable Merge with previous stub files in the General panel of Source Code  

Generation  
            
   

 
   
 
   
 
 

AdventNet Inc. 50



Multi-Protocol Agent 

8.0 Sending Notifications from MBeans 
 

 
8.1 Overview  
8.2 Implementing Notifications  
8.3 Notification Types  
8.4 Sending Notifications  
8.5 Viewing Notifications 

 
 
8.1 Overview 
 
Management applications need to react to a state change or to a specific condition when it occurs in an 
underlying resource. XMOJO JMX implementation supports JMX Notification Model which allows MBeans 
to broadcast such management events, which are called Notifications. To receive the broadcasted 
Notifications, management applications and other objects register as listeners with the broadcaster 
MBean. The MBean notification model of JMX enables a listener to register only once and still receive all 
different events that may occur in the broadcaster.  
The JMX notification model relies on the following components:  

• A generic event type, Notification which can signal any type of management event. The 
notification event may be used directly or subclassed, depending on the information that needs to 
be conveyed with the event. 

• The NotificationBroadcaster interface, which needs to be implemented by each MBean 
wanting to emit notifications. This listeners to get registered to it to receive the notifications 
emitted by an MBean. 

• The NotificationListenerInterface , which needs to be implemented by the objects requesting to 
receive notifications sent by MBeans. The notification model allows a listener to receive all types 
of events from a broadcaster. 

• The NotificationFilter interface, which needs to be implemented by objects that act as 
notification filter. This interface lets the notification listener provide a filter to be applied to 
notifications emitted by an MBean  to specify only those events that are needed.  Using a filter, a 
listener only needs to register once in order to receive all selected events of an MBean. 

Any type of MBean, standard or dynamic, may be a notification broadcaster, a notification listener, or both 
at the same time. Notification filters are usually implemented as callback methods of the listener itself, but 
this is not a requirement. A JMX Notification event is generated for all the supported protocols namely 
SNMP, HTML, HTTP, RMI, CORBA, and TL1.  
 
This may lead to a special case of a Standard MBean, which has an empty management interface: its 
role as a manageable resource is to be a broadcaster of Notifications. It must be a concrete class with a 
public constructor, and it must implement an MBean interface, which in this case defines no methods. 
The only method in its class is those implementing the NotificationBroadcaster interface. This MBean may 
be registered in a Multi-Protocol agent, and its management interface contains only the list of notifications 
that it may send.  
 
8.2 Implementing Notifications 
 
An MBean wanting to emit notifications must implement the NotificationBroadcaster  Interface. This 
interface may be implemented by any type of MBean.  This interface specifies three methods,  which 
MBeans acting as notification broadcasters must implement: 

• Adding Notification Listeners 

• Getting Notification Information 

• Removing a Notification Listener 
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Adding Notification Listeners  
 

Any notification that is emitted must be received at the other end.  The objects that are 
configured to receive these notifications are called Listeners. These Listeners must be registered 
with the Notification broadcaster to receive the notification. A listener is registered when it has 
been added to the broadcaster’s list of notification recipients. 

 
The method addNotificationListener() available in the NotificationBroadcaster Interface is used 
to add a listener to to the broadcaster’s list of notification recipients. When the broadcaster 
sends a notification, it will send it to all listeners that are currently registered through this 
interface. 

 
The addNotificationListener() method takes the following parameters: 

• The NotificationListener object,  which implements  the NotificationListener interface.  
This object will handle notifications emitted by the registered MBean. 

Notification Listener Interface 
 

This interface must be implemented by all objects interested in receiving notifications sent by 
any broadcaster.  This interface defines a unique callback method, handleNotification(), which 
will be invoked by a broadcaster MBean when it emits a notification.  

 
Besides the Notification object, the listener’s hand-back object is passed as an argument to the 
'handleNotification' method. This is a reference to the same object that the listener provided 
upon registration. It is stored by the broadcaster and returned unchanged with each notification.  

 
Because all notifications are characterized by their type string, notification listeners implement 
only one handler method for receiving all notifications from all potential broadcasters. This 
method should then rely on the type string, other fields of the notification object, and on the 
hand-back object to determine the broadcaster and the meaning of the notification. 

• The NotificationFilter object,  which implements the Notification Filter Interface.   If  
filter is defined, it prevents the handler from receiving unwanted notifications. If not, no 
filtering will be performed before handling notifications. 

o Notification Filter Interface 
 
This interface is implemented by objects acting as a notification filter. It defines a 
unique method, isNotificationEnabled, which will be invoked by the broadcaster 
before it emits a notification. This method takes the Notification object that the 
broadcaster intends to emit and, based on its contents, returns true or false, 
indicating whether or not the listener should receive this notification.  
 
The filter object is provided by the listener when it registers for notifications with 
the broadcaster. Each listener may provide its own filter. The broadcaster must 
apply each listener’s filter, if defined, before calling the handleNotification method 
of the corresponding listener.  
 
Listeners rely on the filter to screen all possible notifications and handle only the 
ones in which they are interested. An object may be both a listener and a filter by 
implementing both the NotificationListener and the NotificationFilter interfaces. In 
this case, the object reference will be given for both the listener and the filter 
object when registering it with a broadcaster.  

o The hand-back object,  which is the context to be sent to the listener when a 
notification is emitted. The hand-back object is provided by the listener upon 
registration and is opaque to the broadcaster MBean. The implementation of the 
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broadcaster interface must store this object and return its reference to the 
listener with each notification. This hand-back object can allow the listener to 
retrieve context information for use while processing the notification. The same 
listener object may be registered more than once, each time with a different 
hand-back object. This means that the handleNotification method of this listener 
will be invoked several times, with different hand-back objects. 

The Notification MBean has to maintain a table of listener, filter, and hand-back objects. When 
the MBean emits a  notification, it invokes the handleNotification method of all the registered 
NotificationListener objects, with their respective hand-back object. 

 
Getting Notification Information 

 
The method getNotificationInfo() in the NotificationBroadcaster  Interface gives a potential 
listener the description of all notifications this broadcaster may emit. This method returns an 
array of MBeanNotificationInfo objects, each of which describes a notification.  

 
Removing a Notification Listener  

 
The method removeNotificationListener() in the NotificationBroadcaster  Interface unregisters 
the listener from a notification  broadcaster. This method takes a reference to a 
NotificationListener object, as well as a hand-back object.  

 
If the hand-back object is provided, only the entry corresponding to this listener and hand-back 
pair will be removed. The same listener object may still be registered with other hand-back 
objects.  If the hand-back is not provided, all entries corresponding to the listener will be 
removed. 
 

 

Note: As an alternative method of implementing Notifications, an 
MBean wanting to emit Notification can extend the Class 
NotificationBroadcasterSupport which implements the  
NotificationBroadcaster Interface 

 
8.3 Notification Types 
 
The type of the Notification is assigned by the broadcaster object and conveys the semantic meaning of a 
particular notification. The type is given as a String field of the Notification object. This string is 
interpreted as any number of dot-separated components, allowing an arbitrary, user-defined structure in 
the naming of notification types. 

• All notification types prefixed by “jmx.” are reserved for the notifications emitted by the 
components of the JMX infrastructure defined in the specification, such as: 

o JMX.mbean.registered 

o JMX.mbean.unregistered 

Otherwise, notification broadcasters are free to define all types they wish to use when naming the 
notifications they emit. Usually, MBeans will use type strings that reflect the nature of their notifications 
within the larger management structure in which they are involved.  
 

AdventNet Inc. 53



Multi-Protocol Agent 

8.4 Sending Notifications 
 
Notifications are send to all listeners registered with the Notification Broadcaster on the occurrence of an 
event. The event may be a change in state of managed resource or occurrence of a specific condition.  
This is implementation specific.  
 
To send Notifications, follow the steps given below:  

• Define the Notification : The Notification class represents a notification emitted by an MBean. It 
contains the necessary methods to create the notification object. 

public Notification(java.lang.String type, 
java.lang.Object source, long sequenceNumber, long 
timeStamp, java.lang.String message) 

 
A Notification message format contains the following details:  

1. Notification Type;- The Type specified in the notification.  It may be a standard notification 
type or user defined. 

2. Notification Source Object - The source from where the notification is emitted. 

3. Notification Sequence Number;- The notification sequence number within the source 
object. 

4. Notification Time Stamp - The date when the  notification was emitted. 

5. Notification Message - A detailed message about the notification. 

• Call the sendNotification() method of the registered listeners, passing the defined notification. 
This method can be called from anywhere from the MBean which is a Notification Broadcaster. 
For example, if you want to send a Notification when a get method is invoked on Attribute xxx,  
you have to define the Notification and call the sendNotification() method in the get method 
generated for xxx. 

8.5 Viewing Notifications 
 
The Notification mechanism is designed to forward only notifications from registered MBeans on the 
agent side to proper listeners on the manager side.  
 

Viewing Notifications Through RMI/CORBA/HTTP Adaptors 
• Start the Multi-Protocol agent . The agent gets started with Corba service at default port 

1050, RMI server at port 1099 and HTTP Server at port  8050. 

• Start the MBean browser using the MBeanBrowser.bat/MBeanBrowser.sh file in the 
<Agent Toolkit Home><bin> directory. 

• Select "RMI client" in the remote browser and click "connect" button; it gets connected to 
the Multi-Protocol agent using the RMI protocol. 

• Select the View -> Notification option to view the notification details generated by the 
agent. 

Similarly, you can connect to the CORBA client/HTTP client and view the generated notifications.  
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.  
 

Viewing Notifications Through SNMP Adaptor  
• Start the Multi-Protocol agent . The agent gets started with SNMP service at default port 

8001. 

• Start the MIB Browser using the MibBrowser.bat/MibBrowser.sh file in the <Agent 
Toolkit Home>/bin directory. 

• Select View -> Trap Vieweroption or Trap Viewer icon Set the port to 8003 in Trap 
Viewer. ClickStart button. 

• The traps emitted will be listed in the trap viewer as shown below. 

 
 

Viewing Notifications Through TL1 Adaptor  
• Start the Multi-Protocol agent . The agent gets started with TL1 service at default port 

9099. 

• Start the TL1 Browser using the TL1Browser.bat/TL1Browser.sh file in the <Agent 
Toolkit Home>/bin directory. 

• Load  command set file and corresponding data set file, which is under 
./<projectName>/tcs  directory  by selecting File -> Load option or icon. Click O.K to add 
it to the TL1 tree. 
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• Load tl1security.tcs file  to login to the TL1 Agent. 

• Choose Operations -> Connect option in the menu bar. Enter the Host Name and Port 
Number where the agent is running. Click OK. Now, you will be connected to the Agent. 

• Authenticate into the TL1 Agent using the command ACT-USER in the TL1 Security tree. 
The default user name and the password for the Administrator are "root" and "public" 
respectively. Hence, select ACT-USER command and specify the user name as root in 
the AID block and the password (PID) public in the MPB block. 

• After entering the user name and the password values, send the input message by 
selecting Operations -> Send  from the menu bar. 

• The autonomous message will be displayed as shown below: 
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9.0 Protocol Adaptors Supported in the Multi-Protocol agent 
 

 
• 9.1 Overview  
• 9.2 Protocol Adaptors Supported by the Multi-Protocol agent 

 
 
9.1 Overview 
 
Protocol adaptors provide a view of the agent and its registered MBeans through a basic interface on the 
protocol-specific browser. The adaptor could be plugged into the MBean Server as an MBean to render 
manageability to it. This offers greater flexibility to its operation as it can be invoked or stopped from 
service through any of the other available adaptors. 
To plug in an adaptor, do the following steps: 

1. Name the MBean with a meaningful object name. 
2. Instantiate the class with a constructor allowing the user to specify a non-default port. 
3. Register the MBean with the MBean server. 
4. Start the adaptor to make it active. 

All the adaptors must extend the abstract class Abstract Adaptor, which captures the common behavior of 
all the adaptors. This implements the following interfaces: Adaptor, MBeanRegistration, 
NotificationBroadcaster, and  Serializable. The AbstractAdaptor class contains many methods,  which 
define some of the generic behavior exhibited by all the adaptors.  
 
Functions of some of these methods are listed below:  
 

Returns the host on which the adaptor resides 
Returns the port at which the adaptor listens 
Returns the state of the adaptor 
Returns the state of the adaptor in string format 
Sets the port at which the adaptor is listening 
Starts the Adaptor 
Stops the Adaptor 
Adds Notification Listener 
Removes Notification Listener  

 
Implementation of custom protocol adaptors  and the methods available for the same are explained in the 
chapter 5.19 "Writing custom protocol adaptors for the Multi-Protocol agent " 
 
9.2 Protocol Adaptors Supported by the Multi-Protocol agent 
 
The advantage with Multi-Protocol agent is that it provides access to a common code through multiple 
protocols. The generated code is common and needs to be instrumented only once. This instrumentation 
is made available through all the adaptors/protocols. The AdventNet Multi-Protocol agent supports the 
following protocol adaptors. 

• SNMP Adaptor 
• HTML Adaptor 
• TL1 Adaptor 
• RMI Connector 
• CORBA Connector 
• HTTP Connector 
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9.2 HTML Adaptor 
 
Adaptors allow management applications access the Multi-Protocol agent and manipulate the MBeans it 
contains by giving a representation of the MBean directly in different protocols such as HTML, HTTP, 
IIOP, etc. Thus, the common instrumentation of the Multi-Protocol agent can be accessed through the 
HTML protocol using the HTML Adaptor.  
This section has the following topics that discuss the various details pertaining to the HTML Adaptor:  
 
Creating a JMX Agent with HTML Adaptor 
 
This topic leads you through the steps of registering a HTML Adaptor to the Multi-Protocol agent. It also 
discusses how you can access and test the JMX Agent using the HTML Adaptor. 
 
Using Java Server Pages (JSP) 
 
The HTML Adaptor exposes the agent information in the form of HTML pages served by JSP. This topic 
discusses about the following:  

• JSP : An Overview 

• Using JSP  To View MBean Attributest> 

• Performing Operations on MBeans 

• Customizing JavaServer Pages 

• Registering MBeans at Run Time 

• Deregistering MBeans at Run Time 

Using Dynamic HTML Pages 
 
This topic exclusively discusses about enabling creation of dynamic HTML pages, using these pages to 
view MBeans and customizing them to suit your requirements.  
 
Authentication in HTML Adaptor 
 
An option to authenticate the users, before allowing them to access the agent information using HTML 
Adaptor, is available in AdventNet HTML Adaptor. This topic describes the steps involved like  

• Enabling this feature. 

• Including new user names and passwords to the list of users. 

• Deleting user names from the list. 

Using SSL for Communication Through HTML Adaptor  
 
Secure Sockets Layer (SSL) is supported in AdventNet HTML Adaptor. This topic discusses the steps 
involved in configuring the various features required in enabling SSL support. 
 
Plugging in Your Own Web server  
 
The AdventNet HTML Adaptor uses Jetty Web server by default. But it is possible to plug in your own 
Web server too. This topic discusses the steps involved in plugging in your Web server.  
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9.3 TL1 Adaptor 
 

 
9.3.1 TL1 Adaptor : An Overview  
9.3.2 Registering TL1 Adaptor  
9.3.3 Features Supported by the JMX TL1 Agent  

 
 
9.3.1 TL1 Adaptor: An Overview 
 
The com.adventnet.adaptors.tl1.TL1Adaptor class from AdventNet acts as an adaptor for TL1 protocol 
to make the agent accessible from the management applications (e.g., AdventNet TL1 Browser) outside 
the agent's JVM. 
 
This class itself acts as an MBean for exposing the TL1 adaptor configuration parameters, which can be 
viewed and changed through some other protocol adaptors/connectors (say HTML or IIOP).  
 
This class extends the com.adventnet.adaptors.common.AbstractAdaptor class.  This  class abstracts 
the common behavior of all Adaptors. All Protocol Adaptors must extend this class. This class also 
implements the  javax.management.MBeanRegistration interface. Thus,  the method preRegister(..) in 
this MBeanRegistration interface allows this adaptor to perform any operation it needs before being 
registered with the MBeanServer.  
 
The TL1 agent gets actually started only inside the preRegister(..) method at the specified port, 
mentioned in the key "port" of the ObjectName (the name with which this adaptor gets registered with the 
MBeanServer). If the key "port" is absent, then the TL1 Agent (NE) gets started at the default port 9099.  
If the port is already occupied, then the agent starting fails.  
 
9.3.2 Registering TL1 Adaptor 
 
To create a Multi-Protocol agent with TL1 Adaptor support, the adaptor must be registered with the 
MBean server of the Multi-Protocol agent. This can be done either from the JMX Compiler or using API 
calls.  
 

Using JMX Compiler UI 
• Select Project -> Settings option; the Settings dialog appears 
• Select Adaptors -> TL1 -> General option from the Settings tree in the dialog. 
• Configure the following options in the General panel that appears on the right side: 

o Enable TL1 Adaptor option. 
o Enter the Port Number (port at which TL1 Adaptor must be started). 

On code generation, code is generated to register the TL1 adaptor with the MBean server. 
 

Using API 
 

To register TL1 Adaptor using API, add the following code to the registerAdventNetAdaptors()  
method of the agent's main file.  
 

tl1adaptor= new TL1Adaptor(); 
tl1adaptor.setDebugLevel(debugLevel); 
tl1adaptor.setStandAlone(false); 
name = "Adaptors:type=TL1Adaptor"; 
tl1adaptor.setPort(tl1Port); 
server.registerMBean(tl1adaptor, new ObjectName(name)); 
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9.3.3  Features Supported by the JMX TL1 Agent 
 
The various features supported by the JMX TL1 agent through Agent Toolkit's TL1 Adaptor are as 
follows:  

• Delayed Activation Feature 

• Built in Commands Support 

• Self Monitoring 

• Security 

• Transport Provider Interface 

• Craft Interface Support 

• Automatic Acknowledgement 

• Multiple Port Support 
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9.4 RMI Adaptor 
 

 
9.4.1 Overview 
9.4.2 Registering RMI Adaptor  
9.4.3 Authenticating the User While Accessing the Agent Through RMI Adaptor  
9.4.4 Using SSL for Communication through RMI Adaptor 
9.4.5 Testing the JMX Agent Through the RMI Client 

 
 
9.4.1 Overview 
 

RMI 
 

Remote Method Invocation (RMI) enables the programmer to create distributed applications ( 
involving communication between different Java technology-based applications). RMI enables 
these applications to invoke methods of remote Java objects from other Java virtual machines, 
possibly on different hosts. A Java technology-based program can make a call on a remote 
object once it obtains a reference to the remote object, either by looking up the remote object in 
the bootstrap naming service provided by RMI or by receiving the reference as an argument or a 
return value. A client can call a remote object in a server, and that server can also be a client of 
other remote objects. 

 
RMI Adaptor 

 
The Multi-Protocol agent has common instrumentation that can be accessed through various 
protocols such as HTML, HTTP, RMI, CORBA, SNMP, and TL1. The RMI Adaptor enables the 
Java manager to access the Multi-Protocol agent information using the Java Remote Method 
Invocation (RMI) system.  

 
This topic discusses  adding the RMI Adaptor to the Multi-Protocol agent and testing the agent 
through RMI Adaptor. 

 
9.4.2 Registering RMI Adaptor 
 
To create a Multi-Protocol agent with RMI Adaptor, the adaptor must be registered with the MBean server 
of the Multi-Protocol agent. This can be done either from the JMX Compiler user interface or using API 
calls. It is the com.adventnet.adaptors.rmi.RMIAdaptor that acts as the RMI Adaptor. It extends the 
AbstractAdaptor class present in the com.adventnet.adaptors package.  
This RMI Adaptor itself is registered with the MBean server as an MBean. Therefore, its configuration 
parameters can also be viewed and changed through other protocol adaptors. The various methods of 
registering the RMI Adaptor are explained in the following sections.  
 

9.4.2.1 Using JMX Compiler UI 
 

The RMI Adaptor can be added to the Multi-Protocol agent from the JMX Compiler user interface 
before generating code for the agent.  Follow the steps given below to register the RMI Adaptor 
from UI: 

1. Select Project -> Settings menu option. Settings dialog appears. 
2. Select Adaptors -> RMI option from the tree in the dialog. 
3. Configure the following in the panel that appears on the right side: 

• Enable RMI Connector option. 

• Enter the Port Number (Port at which the RMI Adaptor is to be started. 
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Now, when code is generated for the agent, code required for registering the RMI Adaptor is 
also generated in the agent's main file. For more information on creating a Multi-Protocol agent, 
please refer to the topic Creating a Simple Agent using JMX Compiler  in the Buliding Multi-
Protocol agent section.  
 
When this code is compiled and the agent is started, the RMI Adaptor is started at the specified 
port. The default port is 1099. The agent can be started directly from the JMX Compiler UI or 
from the command line using the run.bat (for windows)/ run.sh (for unix) file (present in the 
<projectdir>/agent/bin). 
 
Starting the agent from the command line offers additional flexibility of configuring the port 
number using the command line options. The command line option [-rp rmi_port] allows you to 
configure the port number before starting the agent.  
 
For more information on command line options, please refer to the section Starting the Agent in 
the topic Testing the Agent.  

 
9.4.2.2 Using API  

 
The RMI Adaptor can also be registered using API calls. For this, the following code has to be 
added to the registerAdventNetAdaptors() method of the Agent's main file:  
 

rmiadaptor = new RMIAdaptor(); 
name = "Adaptors:type=RMIAdaptor";   
rmiadaptor.setPort(rmiPort);  
server.registerMBean(rmiadaptor, new ObjectName(name)); 

 
The package com.adventnet.adaptors.rmi.RMIAdaptor must also be imported into the agent's 
main file. Inorder to stop the adaptor when the agent is shut down, the following code (shown in 
bold) has to be added to the shutDownJmxAgent()  method of the agent's main file:  
 

rmiadaptor.stopService(); 
MBeanServerFactory.releaseMBeanServer(server); 

 
When this code is compiled and the agent is started, the RMI Adaptor is started at the specified 
port. The default port is 1099. The setPort(rmiPort) method can be used to change the port at 
which the adaptor is started. 
 

 

Note: In case the port number specified for starting the agent is 
already occupied, the server creation fails 

 
9.4.3 Authenticating the User While Accessing the Agent Through RMI Adaptor 
 
The RMI adaptor exposes the attributes and operations of all the MBeans registered with the MBean 
server of the Multi-Protocol agent. You may restrict the access to the MBean information. This can be 
done using the Authentication feature. Here, the user is authenticated based on the user name and 
password.   
 
The Authentication feature of RMI Adaptor is exposed as a Service MBean. It may be enabled either from 
the JMX Compiler user interface or by using API calls. Both the methods are explained in Enabling 
Authentication Support in Multi-Protocol agent.  
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9.4.4 Using SSL for Communication through RMI Adaptor 
 
SSL (Secure Sockets Layer) protocol is used for authenticated and encrypted communication between 
clients and servers. AdventNet RMI adaptor supports SSL. Secure Sockets Layer has been implemented 
on both the server and the client side of the RMI Adaptor. Thus, secured connection can be established 
between the server and the client. 
 
For SSL support in RMI adaptor, a keystore and keypassword is mandatory on the server side and a trust 
store and trust store password is mandatory on the client side. 
 

9.4.4.1 Enabling SSL Support 
 

SSL can be enabled for the RMI Adaptor either from the JMX Compiler UI while generating the 
agent code or by directly adding the required code in the generated agent main file. 

 
9.4.4.1.1 From UI: 

 
Follow the steps given below to enable SSL support for RMI Adaptor from the JMX 
Compiler UI: 

1. Select Project->Settings menu option. The Settings dialog appears. 
2. Select Adaptors-> RMI ->SSL option from the tree in the left frame of the 

Settings dialog. 
3. Enable the 'SSL Support' option. 
4. Enter the Key Store value. The default value present is 

'etc/adventnetkey'. In case you are using a keystore other than the 
sample adventnetkey, use the Browse button to specify the location of 
the keystore. 

5. Enter the Key Password corresponding to the keystore specified. The 
password for "adventnetkey" is "adventnet". 

6. Enter the Server Socket Factory and Client Socket Factory values. The 
default values are 
com.adventnet.adaptors.rmi.RMISSLServerSocketFactory and 
com.adventnet.adaptors.rmi.RMISSLClientSocketFactory respectively. 

7. Enter the port through which SSL communication takes place. The 
default SSL Port value of '0' means that any anonymous port is selected 
for communication. 

8. If Client Authentication is required, select the 'Client Authentication' 
check box and specify the necessary Trust Store and Trust Store 
Password values. The default values for Trust Store and Trust Store 
Password are 'cacerts' and 'changeit' respectively. 

9. Click on OK to complete the configuration. 
9.4.4.1.2 Using API: 

 
To provide  SSL support for RMI Adaptor using API, add the following code to the 
registerAdventNetAdaptors() method of the agent's main file. 

 
        rmiadaptor.setSSLEnabled(true); 
        Hashtable sslProps = new Hashtable(); 
        sslProps.put("keyStore","etc/adventnetkey"); 
        sslProps.put("keyStorePassword","adventnet"); 
        sslProps.put("trustStore","etc/cacerts"); 
        sslProps.put("trustStorePassword","changeit");
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        sslProps.put("clientAuth","false"); // If Client Authentication is required, "true" should be 
passed as  value 
        
sslProps.put("rmiServerSocketFactory","com.adventnet.adaptors.rmi.RMISSLServerSocket
Factory"); 
        
sslProps.put("rmiClientSocketFactory","com.adventnet.adaptors.rmi.RMISSLClientSocketFa
ctory"); 
        sslProps.put("sslPort","0"); 
        rmiadaptor.setSSLProps(sslProps); 

 

 

Warning: If keystore is not present in the corresponding directory, a file not found 
exception will be thrown while starting the agent. 

 
9.4.4.2 Packages for SSL Support 

 
For SSL support, the packages related to SSL can be downloaded from Sun Microsystems Inc, ( 
http://java.sun.com/products/jsse/ ). After downloading the packages, the jars (jsse.jar, jnet.jar, 
jcert.jar) from the JSSE package must be set in the classpath of the agent and setenv.bat. The 
setenv.bat will be available under the <Agent Toolkit Home>/bin directory and this will be used 
by MBean Browser for setting the tools classpath. 
 

 
Note: For jdk 1.4 and above, the JSSE packages are bundled with jdk itself. 

 
9.4.5 Testing the Multi-Protocol agent Through the RMI Client 
 
The RMI Adaptor exposes the Multi-Protocol agent information through the RMI protocol. Therefore, the 
RMI Client can be used to test the Multi-Protocol agent. For this, either of the following can be used:  

• MBean Browser, a GUI test tool. 

• RMI Client APIs. 
9.4.5.1 Using MBean Browser  

 
The MBean Browser is a UI tool that allows you to test the Multi-Protocol agent using RMI, 
CORBA, or HTTP protocol. To test the agent using RMI Adaptor, you have to connect to the 
agent through the RMI Adaptor. Once you connect to the agent through the RMI Adaptor, all 
MBeans registered with the MBean server of the Multi-Protocol agent are listed. Now, you can 
use the MBean Browser to do the following:  

• View the MBean's attributes. 

• Perform operations on the MBeans 

• View the notifications sent by the agent 

• Create and register new MBeans with the MBean server 
Follow the steps given below to connect to the agent through RMI Adaptor:  

1. Start MBean Browser from the Launcher or by executing the MBeanBrowser.bat / 
MBeanBrowser.sh from the <Agent Toolkit Home>/bin directory. 

2. Select Settings -> Client Settings menu option. Enter the following details in the dialog 
that appears: 
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• Client: Select the client through which you would like to connect to the server 
(select RMI Client). 

• Host Name: Specify the machine name where the agent is running. If the agent 
is running in the same machine, specify Host name as localhost. 

• Port Number: Specify the port in which the HTTP connector is running (default 
port is 1099). 

3. Now, select Operations -> Connect menu option. 
In case Authentication is enabled, a dialog is displayed where you have to enter the user name 
and password. Now, connection is established with the agent through the RMI Adaptor and all 
MBeans registered with the MBean server are listed in the left side tree. 

 
9.4.5.1.1 Viewing MBean Attributes  

 
The MBeans registered with the Multi-Protocol agent are grouped according to the 
Domains and listed under the root domain in the tree. The attributes and the operations 
of an MBean are listed as nodes.  

 
Click the Attributes node. The attributes of the MBean are displayed on the right frame. 
If the MBean is a scalar, the attributes and their corresponding values are listed on the 
right frame. In case the MBean is of tabular data type, the table is displayed on the right 
frame. The index columns are highlighted.  
Values of attributes having Read-Write access are displayed in editable format. Their 
values can be changed directly. Enter the new value for the attribute and click Submit 
button.  

 
New rows can be added to table MBeans using the Add Row button. Select a row in 
the table and click the Modify Row button or Delete Row button to modify or delete the 
row. If an attribute's value is of type array, a button is displayed and on clicking the 
button, all the values are listed in a separate pop-up dialog.  

 
In order to view only a few MBeans from the list displayed in the tree, you can use the 
Filter MBean option. Here, you can filter the MBeans based on the Object name of the 
MBeans. Follow the steps given below to filter the MBeans: 

1. Enter the Filter condition at the top of the MBean tree. (The filter 
condition must resemble the format of the MBean's object name 
Domain:key=value.) 

2. Click the Requery button at the bottom of the tree.  
All MBeans with object names satisfying the filter condition specified are listed in the 
tree. To view all the MBeans, enter the filter condition as *:*. 

 
9.4.5.1.2 Performing Operations on MBeans  

 
To view the operations available for an MBean, click the Operations node for the 
MBean from the tree. All operations associated with the MBean are displayed as 
buttons in the right frame. Click the button to perform the operation. 

 
If the operation is a GET operation, the value retrieved is displayed in a pop-up dialog. 
If the operation is a SET operation, the dialog appears with a text field to enter the new 
value. Specify the value and click OK. This performs the SET operation. Other 
operations such as Start service, Stop service, etc., are performed when the operation 
button is clicked.  

 
You can also register/unregister an MBean using the Settings -> Register/Unregister 
MBean option.  
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9.4.5.1.3 Viewing Notifications Sent by the Agent  

 
Notifications are unsolicited messages sent by the agent to the managers when it 
encounters some critical events. Some of the critical events that trigger  notifications 
are registering/ de-registering an MBean, performing SET on some MBean attribute 
(only when the JMX Notification on SET option is enabled in the JMX Compiler UI), etc. 

 
Some services such as timer service (used to send predefined notifications at specified 
date and time) and monitor service (used to send notifications when the monitored 
attribute reaches a threshold value) also trigger notifications depending upon their 
configurations.  

 
Notifications sent by the Multi-Protocol agent can be viewed through the RMI Adaptor. 
Follow the steps given below to view notifications using MBean Browser. 

1. Select View -> Notifications menu option. 
2. A dialog is displayed with the list of notifications. 

All the notifications sent by the agent are displayed in table format containing the 
following information: Sequence number, Type of Notification, Source from which the 
notification was received, Time stamp, Notification Message, and additional User data, 
if any. The Remarks button at the bottom of the table can be used to view detailed 
information pertaining to a notification.  

 
9.4.5.2 Using Client APIs 

 
The RMI Adaptor acts as a server and exposes the agent information. In order to access and 
manipulate this information,  AdventNet Agent Toolkit provides client-side APIs. The RMI Client 
APIs can be used by Java Managers to connect to the agent and access its information through 
the RMI Adaptor. These APIs make the task of MBean management easier. They also support 
remote notifications allowing you to view the notifications sent by the agent. 
 
The RMIClient API is present in the com.adventnet.adaptors.clients.rmi package. This class 
extends the com.adventnet.adaptors.clients.AbstractClient and implements the 
com.adventnet.adaptors.clients interface. This interface is a common interface to be 
implemented by all connector clients.  
 
This RMIClient API has methods that allow you to  do the following:  

• Connect to the agent using the RMI Adaptor 

• Query MBeans registered with the MBean server 

• Get MBean attributes 

• Set MBean attributes 

• Listen to remote notifications 
Please refer to the Javadocs for more information on each method of RMIClient API. AdventNet 
MBean Browser is also built using these APIs.  
 
The remote notifications can be viewed through the client-side APIs by implementing the 
NotificationListenerInterface. A client-side application, which implements NotificationListener, 
can register to the MBeans in the MBean Server of the Multi-Protocol agent using the 
addNotificationListener. This hides the complexity involved in handling remote notifications and 
allows you to view the notifications. 
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9.5 CORBA Adaptor 
 

 
9.5.1 Overview  
9.5.2 Registering CORBA Adaptor  
9.5.3 Authenticating the User While Accessing the Agent Through CORBA Adaptor  
9.5.4 Testing the Multi-Protocol agent Through the CORBA Client  

 
 
9.5.1 Overview 
 

CORBA 
 

CORBA (Common Object Request Broker Architecture) is a distributed object architecture that 
allows objects to interoperate across networks regardless of the language in which they were 
written or the platform on which they are deployed. Its design is based on OMG Object Model. 
The OMG Object Model defines common object semantics for specifying the externally visible 
characteristics of objects in a standard and implementation-independent way.  

 
In this model clients request services from objects (which will also be called servers) through a 
well-defined interface. This interface is specified in OMG IDL (Interface Definition Language). A 
client accesses an object by issuing a request to the object. The request is an event, and it 
carries information including an operation, the object reference of the service provider, and 
actual parameters (if any). 

 
CORBA Adaptor 

 
The Multi-Protocol agent has common instrumentation that can be accessed through various 
protocols such as HTML, HTTP, RMI, CORBA, SNMP, and TL1. AdventNet Agent Toolkit 
supports CORBA Adaptor. The CORBA Adaptor provides a mechanism for interacting with a 
management system using CORBA. This adaptor exposes the Multi-Protocol agent information 
to the management system.  

 
This topic discusses adding the CORBA Adaptor to the Multi-Protocol agent and testing the 
agent through CORBA Adaptor. 

 
9.5.2 Registering CORBA Adaptor 
 
To access the MBeans registered with the  MBean server of the JMX Agent using CORBA, the agent has 
to be created with a CORBA Adaptor. For this, you have to register the CORBA Adaptor with the MBean 
server of the Multi-Protocol agent. The com.adventnet.adaptors.corba.CorbaAdaptor class acts as the 
CORBA Adaptor. It extends the com.adventnet.adaptors.AbstractAdaptor. 
 
This CORBA Adaptor itself is registered with the MBean server as an MBean. Therefore, its configuration 
parameters can also be viewed and changed through other protocol adaptors. The various methods of 
registering the CORBA Adaptor are explained in the following sections.  
 

9.5.2.1 Using JMX Compiler UI 
 

The CORBA Adaptor can be added to the Multi-Protocol agent from the JMX Compiler user 
interface before generating code for the agent. Follow the steps given below to register the 
CORBA Adaptor from UI: 

1. Select Project -> Settings menu option. Settings dialog appears. 

AdventNet Inc. 67



Multi-Protocol Agent 

2. Select Adaptors -> CORBA option from the tree in the dialog. 
3. Configure the following in the panel that appears on the right side: 

o Enable CORBA Connector option. 
o Enter the Port Number (Port at which the CORBA Adaptor is to be started). 

Now, when code is generated for  the agent, code required for registering the CORBA Adaptor is 
also generated in the agent's main file. For more information on creating a Multi-Protocol agent, 
please refer to the topic "Creating a Simple Agent using JMX Compiler" in the "Buliding Multi-
Protocol agent" section. 

 
When this code is compiled and the agent is started, the CORBA Adaptor is started at the 
specified port. The default port is 1050. The agent can be started directly from the JMX Compiler 
UI or from the command line using the run.bat (for windows)/ run.sh (for Unix) file (present in the 
<projectdir>/agent/bin). 

 
Starting the agent from the command line offers additional flexibility of configuring the port 
number and enabling authentication using the command line options. The command line option 
[-cp corba_port] allows you to configure the port number before starting the agent.  

 
For more information on command line options, please refer to the section "Starting the Agent" in 
the topic "Testing the Agent". 

 
9.5.2.2 Using API 

 
The CORBA Adaptor can also be registered using API calls. For this, the following code has to 
be added to the registerAdventNetAdaptors() method of the Agent's main file:  
 

corbaadaptor = new CorbaAdaptor();  
name = "Adaptors:type=CorbaAdaptor"; 
corbaadaptor.setPort(corbaPort);  
server.registerMBean(corbaadaptor, new 
ObjectName(name)); 

 
The package com.adventnet.adaptors.corba.CorbaAdaptor must also be imported into the 
agent's main file. In order to stop the adaptor when the agent is shut down, the following code 
(shown in bold) has to be added to the shutDownJmxAgent()  method of the agent's main file: 
 

corbaadaptor.stopService(); 
httpconnector.stopService();   
MBeanServerFactory.releaseMBeanServer(server);  

 
When this code is compiled and the agent is started, the CORBA Adaptor is started at the 
specified port. The default port is 1050. The setPort(corbaPort) method can be used to change 
the port at which the adaptor is started.  
 

 

Note: In case the port number specified for starting the agent is 
already occupied, the server creation fails. 

 
9.5.3 Authenticating the User While Accessing the Agent Through CORBA 
Adaptor 
 
The CORBA adaptor exposes the attributes and operations of all the MBeans registered with the MBean 
server of the Multi-Protocol agent. You may restrict the access to the MBean information. This can be 
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done using the Authentication feature. Here, the user is authenticated based on the user name and 
password.  
 
The Authentication feature of CORBA Adaptor is exposed as a Service MBean. It may be enabled either 
from the JMX Compiler user interface or by using API calls. Both the methods are explained in Enabling 
Authentication Support in Multi-Protocol agent.  
 

9.5.3.1 Using UI  
 

The Authentication feature can be enabled and user entries can also be added from the JMX 
Compiler user interface. Follow the steps given below to enable Authentication for CORBA 
Adaptor:  

1. Select Project -> Settings menu option. The Settings dialog appears. 
2. Select Adaptors -> CORBA option from the tree in the settings dialog. 
3. Enable Authentication from the panel that appears on the right side frame. 

User entries can also be added from the JMX Compiler user interface. The user name and 
password entries are persisted in a text file.  

 
9.5.3.2 Adding User Entries from UI 

 
User entries can be added from the JMX Compiler user interface before code generation. If user 
entries are added after code generation, the code has to be regenerated after adding the new 
entries. Follow the steps given below to add user entries from the UI: 

1. Select Project -> Settings menu option. The Settings dialog is displayed. 
2. Select Adaptor -> CORBA option from the tree in the Settings dialog. 
3. Ensure Authentication is enabled in the panel that appears on the right side 

frame. 
4. Click the Add button at the bottom of the table. 
5. Enter the following values in the pop-up dialog that appears: 

o User Name 
o Password 

6. Click OK button. The user entry gets added to the table. 
Any number of user entries can be added using this method.  

 
9.5.3.3 Using APIs 

 
Authentication feature can also be enabled by using API calls. For this, the following code 
(shown in bold) has to be added to the agent's main file: 
 

corbaadaptor= new CorbaAdaptor();  
name = "Adaptors:type=CORBAAdaptor";   
corbaadaptor.setPort(corbaPort);  
server.registerMBean(corbaadaptor, new 
ObjectName(name));  
corbaadaptor.enableAuthentication(true); 

 
The enableAuthentication(boolean authenticate) method enables authentication feature when 
the boolean parameter "authenticate" takes the value "true". 

 
9.5.4 Testing the Multi-Protocol agent Through the CORBA Client 
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The CORBA Adaptor acts as a server and exposes the Multi-Protocol agent information. Therefore, the 
CORBA Client can be used to test the Multi-Protocol agent. For this, either of the following can be used:  

• MBean Browser, a GUI test tool. 

• CORBA Client APIs. 
9.5.4.1 Using MBean Browser 

 
The MBean Browser is a UI tool that allows you to test the Multi-Protocol agent using RMI, 
CORBA, or HTTP protocol. To test the agent using CORBA Adaptor, you have to connect to the 
agent through the CORBA Adaptor. Once you connect to the agent through the CORBA 
Adaptor, all MBeans registered with the MBean server of the Multi-Protocol agent are listed. 

 
Now,  you can use the MBean Browser to do the following: 

• View the MBean's attributes. 

• Perform operations on the MBeans 

• View the notifications sent by the agent 

• Create and register new MBeans with the MBean server 
Follow the steps given below to connect to the agent through CORBA Adaptor:  

1. Start MBean Browser from the Launcher or by executing the 
MBeanBrowser.bat/MBeanBrowser.sh from the <Agent Toolkit Home>/bin 
directory. 

2. Select Settings -> Client Settings menu option. Enter the following details in the 
dialog that appears: 

o Client: Select the client through which you would like to connect to the 
server (select CORBA Client). 

o Host Name: Specify the machine name where the agent is running. If 
the agent is running in the same machine, specify Host Name as 
localhost. 

o Port Number: Specify the port in which the HTTP connector is running 
(default port is 1050). 

3. Now select Operations -> Connect menu option. 
In case Authentication is enabled, a dialog is displayed where you have to enter the user name 
and password. Now, connection is established with the agent through the CORBA Adaptor and 
all MBeans registered with the MBean server are listed in the left side tree. 

 
Viewing MBean Attributes  

 
The MBeans registered with the Multi-Protocol agent are grouped according to the Domains and 
listed under the root domain in the tree. The attributes and the operations of an MBean are listed 
as nodes.  

 
Click the Attributes node. The attributes of the MBean are displayed on the right frame. If the 
MBean is a scalar, the attributes and their corresponding values are listed on the right frame. In 
case the MBean is of tabular data type, the table is displayed on the right frame. The index 
columns are highlighted. 

 
Values of attributes having Read-Write access are displayed in editable format. Their values can 
be changed directly. Enter the new value for the attribute and click Submit  button. 
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New rows can be added to table MBeans using the Add Row button. Select a row in the table 
and click the Modify Row button or Delete Row button to modify or delete the row. If an 
attribute's value is of type array, a button is displayed and on clicking the button, all the values 
are listed in a separate pop-up dialog. 

 
In order to view only a few MBeans from the list displayed in the tree, you can use the Filter 
MBean option. Here, you can filter the MBeans based on the Object name of the MBeans.  
Follow the steps given below to filter the MBeans: 

1. Enter the Filter condition at the top of the MBean tree. (The filter condition must resemble 
the format of the MBean's object name Domain: key=value.) 

2. Click the Requery button at the bottom of the tree. 
All MBeans with object names satisfying the filter condition specified are listed in the tree. To 
view all the MBeans, enter the filter condition as *:*  

 
Performing Operations on MBeans 

 
To view the operations available for an MBean, click the Operations node for the MBean from 
the tree. All operations associated with the MBean are displayed as buttons in the right frame. 
Click the button to perform the operation.  

 
If the operation is a GET operation, the value retrieved is displayed in a pop-up dialog. If the 
operation is a SET operation, the dialog appears with a text field to enter the new value. Specify 
the value and click OK. This  performs the SET operation. Other operations such as Start 
service, Stop service, etc.,  are performed when the operation button is clicked. 

 
Viewing Notifications Sent by the Agent  

 
Notifications are unsolicited messages sent by the agent to the managers when it encounters 
some critical events. Some of the critical events that trigger  notifications are registering/ de-
registering an MBean, performing SET on some MBean attribute (only when the Generate trap 
on SET option is enabled in the JMX Compiler UI), etc.  

 
Some services such as timer service (used to send predefined notifications at specified date and 
time) and monitor service (used to send notifications when the monitored attribute reaches a 
threshold value) also trigger notifications depending upon their configurations.  

 
Notifications sent by the Multi-Protocol agent can be viewed through the CORBA Adaptor. 
Follow the steps given below to view notifications using MBean Browser. 

1. Select View -> Notifications menu option. 
2. A dialog is displayed with the list of notifications. 

All the notifications sent by the agent are displayed in table format containing the following 
information: Sequence number, Type of Notification, Source from which the notification was 
received, Time stamp, Notification Message, and additional User data, if any. The Remarks 
button at the bottom of the table can be used to view detailed information pertaining to a 
notification.  

 
9.5.4.2 Using Client APIs 

 
The CORBA Adaptor acts as a server and exposes the agent information. In order to access and 
manipulate this information, AdventNet Agent Toolkit provides client-side APIs. The CORBA 
Client APIs can be used by Java Managers to connect to the agent and access its information 
through the CORBA Adaptor.  These APIs make the task of MBean management easier. They 
also support remote notifications allowing you to view the notifications sent by the agent. 
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The CorbaClient API is present in the com.adventnet.adaptors.clients.corba package. This 
class extends the com.adventnet.adaptors.clients.AbstractClient and implements the 
com.adventnet.adaptors.clients interface. This interface is a common interface to be 
implemented by all connector clients.  

 
This CorbaClient API has methods that allow you to do the following:  

• Connect to the agent using the CORBA Adaptor 

• Query MBeans registered with the MBean server 

• Get MBean attributes 

• Set MBean attributes 

• Listen to remote notifications 
Please refer to the javadocs for more information on each method of CorbaClient API. 
AdventNet MBean Browser is also built using these APIs.  

 
The remote notifications can be viewed through the client-side APIs by implementing the 
NotificationListenerInterface. A client-side application  which implements NotificationListener can 
register to the MBeans in the MBean Server of the Multi-Protocol agent using the 
addNotificationListener. This hides the complexity involved in handling remote notifications and 
allows you to view the notifications. 
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9.6 HTTP Connector 
 
A Multi-Protocol agent has common instrumentation that can be accessed through different protocols 
such as SNMP, TL1, HTML, CORBA, RMI, and HTTP. It is the HTTP Connector that exposes the agent 
information through HTTP Protocol.  
 
This section has the following topics that discuss the various details pertaining to the HTTP Connector:  
 
9.6.1 Creating Multi-Protocol agent with HTTP Connector  
 
This topic leads you through the steps of registering a HTTP Connector to the Multi-Protocol agent. It also 
discusses how you can access and test the JMX Agent through the HTTP Connector. 
 
9.6.2 Authentication in HTTP Connector  
 
An option to authenticate the users, before allowing them to access the agent information using HTTP 
Connector, is available in AdventNet HTTP Connector. This topic describes the steps involved such as:  

• Enabling this feature. 

• Including new user names and passwords to the list of users. 

• Deleting user names from the list. 

9.6.3 Using SSL for communication through HTTP Connector  
 
Secure Sockets Layer (SSL) is supported in AdventNet HTTP Connector. This topic discusses the steps 
involved in configuring the various features required in enabling SSL support. 
 
9.6.4 Plugging-in your own Web server  
 
The AdventNet HTTP Connector uses Jetty Web server by default. But it is possible to plug in your own 
Web server too. This topic discusses the steps involved in plugging in your Web server.  
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10.0 Enabling Authentication Support in Multi-Protocol agent 
 

 
10.1 An Overview  
10.2 Architecture  
10.3 Enabling Authentication  
10.4 Enabling Authorization  
10.5 Authorizing the Request  
10.6 Default Views Specified  
10.7 Configuring Views  

 
 
10.1 An Overview 
 
A Multi-Protocol agent exposes critical information about the device or application being managed 
through its management interface. To ensure security to the system, a check has to be kept on the 
unauthorized people who try to access and modify such information by performing operations on it.  
 
Authentication mechanism helps you in restricting the users who can access the system. Authenticated 
users are configured with the help of a user name and password.  
 
Authorization mechanism enables you to curtail the access level of a user by allowing him to work with 
only a subset of the management information exposed by the agent. Thus, strict security from 
unauthorized person would be ensured, who would be denied permission to accessing information. 
 
10.2 Architecture 
 
The Authentication service is implemented as a dynamic MBean. Authentication service MBean can be 
configured only if Authentication is enabled for at least one of them viz. RMI, CORBA. The parameters 
necessary for enabling authentication (user name and password) are gathered from the UI and written 
into an XML file named AuthInfo.xml found under <Agent Toolkit 
Home>/jmxprojects/projectname/agent/bin/conf. MD5 is an encryption mechanism for encrypting the 
password. 
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If authentication service is enabled and the authentication context is configured, any request originating 
from the client would be checked for authentication before being processed. The client can establish a 
connection with the server (MBean server of the agent) only on providing the user name and password of 
the context. When the client tries to establish connection with the server, the authenticate operation of the 
Authentication Service MBean registered with the MBean server is invoked. It prompts the client for the 
user name and password of the context. If the user name and password furnished on the client side 
match the ones available on the server side, the connection is established. 
 
10.3 Enabling Authentication 
 
Each request that comes in is processed through the adaptor meant specifically to cater to the needs of 
the protocol in which the request is framed. 
 
The method for enabling/disabling authentication is present in each adaptor and it would be invoked at 
the outset. The Boolean variable used for the purpose could be set as true or false depending on whether 
authentication is enabled or not. If the feature is inactive, the query is directed to the MBean Server for 
undergoing the routine processing.  
 

 
Note: Authorization is enabled only if the Authentication is enabled.  

 
Authentication can be enabled/disabled  for all the adaptors supported by the Multi-Protocol agent. The 
following are the sections that can be referred to for details about authentication of the respective 
adaptors, 
 
1. Authentication and Authorization section of SNMP Adaptor for SNMP Adaptors.  
2. Authentication in HTML Adaptor section of HTML Adaptor  for HTML Adaptors. 
3. Authentication in HTTP Connector section of HTTP Connector  for HTTP connector. 
4. System Access Control section of Security in TL1 agent for TL1 Adaptors. 
 
Authentication for RMI and CORBA using JMX Compiler UI and API is explained below: 
 

Using JMX Compiler UI  
 

Authentication support can be enabled for a particular adaptor (RMI and CORBA ) which 
involves two steps as follows: 
 
Enabling Authentication 

   
 1. Click Settings-->Adaptor. 
 2. Select RMI/CORBA or both for which the authentication should be enabled. 
 3. Select the check box labeled Enable Authentication. 
 4. Click OK to finish configuration. 
 
Adding Users 
 
 1. Click Settings-->AdventNet Services. 
 2. Select Authentication from the left panel. 
 3. Click the Add button. AuthenticationEntry dialog pops up. 
 4. Enter the user name and password as applicable to the enabled adaptor(s). 
 5. The adaptors enabled for authentication are reflected in the Choose Context section. It can 
also be  
enabled/ disabled here.    
 6. Click OK to finish configuration, which closes the AuthenticationEntry dialog. 
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Using API  

 
The authentication feature can be enabled by adding the following code to the 
registerAdventNetAdaptors() method in the agent's main file: 

 
RMI adaptor 
 

rmiadaptor.enableAuthentication(true); 
 
CORBA adaptor 
 

corbaadaptor.enableAuthentication(true); 

 
10.4 Enabling Authorization (View-Based Access) 
 
View-Based Access Support provides an authorization mechanism to restrict the users' access to a 
subset of the information exposed by a Multi-Protocol agent. The users entitled to log on to the system 
alone would be configured with a user name and password, along with the details of the privileges they 
can avail, i.e.,  the extent of access allowed. The unauthorized client would not be able to infiltrate.  
 
After enabling authentication, you can proceed to authorize the authenticated users. The method for 
enabling authorization is available in the respective adaptors. A Boolean is used to check whether 
authorization is enabled or not. If false (i.e., authorization is not enabled), the request proceeds to the 
MBean Server for getting processed. If true, the request passes through the authorization module.   
 
Authorization support can be enabled for all the adaptors, using the JMX Compiler UI or using API.  
 

Using JMX Compiler UI  
 

Authorization can be enabled by using JMX Compiler UI as follows: 
1. Select Project -> Settings option. In the Settings Tree Structure, select Source Code 

Generation -> General, which displays the General Settings dialog on the right side. 
2. Select the option View based Authorization. 

Using API 
 
Authorization can also be enabled by adding the relevant code in the agent's main file. Add the 
following piece of code in the agent's main file to register ViewAuthorizer,  
 

/Registering the ViewAuthoriser. 
ViewAuthoriser vu = new ViewAuthoriser(); 
name = "Security:type=authoriser"; 
server.registerMBean(vu,new ObjectName(name)); 

 
SNMP adaptor 
 

snmpadaptor.setViewBasedAccess(true); 
snmpadaptor.getSnmpAgent().setViewBasedFlag(true); 

 
HTML adaptor 
 

htmladaptor.enableAuthorisation(true); 
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RMI adaptor 
 

rmiadaptor.enableAuthorisation(true); 
 
CORBA adaptor 
 

corbaadaptor.enableAuthorisation(true); 

 
HTTP adaptor 
 

httpconnector.enableAuthorisation(true); 

 
10.5 Authorizing the Request 
 
After verifying that authentication and authorization are enabled, the adaptor creates a ContextInfo for 
the authorized request using the following information,  based on the inputs received from the 
client/manager, 

• User name - the name of the user who makes the request. 

• Context name  - the adaptor name through which the request is made. 

• Object name - the MBean name for which the request is made. 

• Attribute name - the MBean attribute for which the request is made. 

Now, the authorized request with the ContextInfo is passed to the authorization module. This module has 
the ViewAuthorizer, which implements the ViewAuthoriserMBean interface. This undertakes the 
responsibility of serving an authorized request. Here, the Contextinfo created by the adaptor is compared 
with the pre configured user information available in the XML file format.  
 
The administrator would configure the different users of a system in an XML file with the help of UserInfo, 
GroupInfo, and the ViewInfo. The validity of an incoming request is verified by comparing the ContextInfo 
with this pre- configured user  information. 

• UserInfo    -  Comprises the user name, the context of the request, and the name of the group in 
which the user is configured. 

• GroupInfo  -  Comprises the group name and the view name specified for the group. 

• ViewInfo    -  The object name together with the various accessible attributes and allowable 
operations provided for the Viewname. 

From the ContextInfo of a request, the user name is compared with the UserInfo for that particular context 
to find the group to which the user belongs. For that particular group of users, the domains and MBeans 
accessible are determined from the GroupInfo of that group.  
 
All the configuration details for all the Contexts, Groups, and the Access Level are specified through a 
configuration file. This configuration is XML based and supports wild card pattern matching. 
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10.6 Default Views Specified in the XML File 
 
AdventNet has provided the following default views in the XML file vbac.xml in <Agent Toolkit 
Home>/jmxprojects/projectname/agent/bin/conf directory,  
 
userName contextName groupName viewName  

root RMI IIOP HTTP admin 

adminView  

• MBean Name = "*" 
o attributeName = "*", 

access = "rw" 
o operationName = "*" 

• MBean Server is "*" 
o operationName = "*" 

 
Each user is configured for a particular view that is allowed for him and this view determines the 
access for that particular User. The granularity level for this configuration can be extended till the 
methods that are accessible by the  User on a particular MBean.  
 
The above table specifies that  a user with user name "root" is configured with contextName as RMI / 
IIOP / HTTP and group name as "admin". 
The view name provided for this group is "adminView".   This adminView is provided access to all the 
Attributes and Operations of all the MBeans registered with the MBean server, denoted by  "*".  
 
For example, when a request comes from an RMI client with user name as "root" for an  MBean name, 
say xxx, the ContextInfo is formed using the following information:  
 
user name = root 
context name = rmi 
object name = xxx  
 
The user name "root" is compared with the user name and Context names configured in the table, to find 
the group to which the user belongs. The group specified for user name "root" with context name "RMI" is 
"admin". Now, the views provided for the admin group is determined. Because the view for the admin 
group is provided for all the attributes and operations of all MBeans,  the request is processed. 
 
The above user entry is specified in the XML file in the following format, 
 

- <accessControl>  
- <users> 
<user userName="root" contextName="RMI" groupName="admin" />  
  <user userName="root" contextName="IIOP" groupName="admin" />  
  <user userName="root" contextName="HTTP" groupName="admin" />  
  </users>  
- <groups> 
  <group groupName="admin" viewName="adminView" /> 
  </groups> 
- <views> 
- <view viewName="adminView"> 
 <mbean mbeanName="*">  
- <attributes> 
<attribute name="*" access="rw" type="included" /> 
  </attributes> 
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- <operations> 
- <operation name="*" type="included"> 
- <params> 
  <param type="void" />  
  </params>  
</operation> 
</operations> 
</mbean>  
- <mbeanServer>  
- <operations> 
- <operation name="*" type="included"> 
- <params> 
  <param type="void" />  
  </params> 
  </operation> 
  </operations> 
</mbeanServer>  
</view> 

 
10.7 Configuring Views 
 
The user views can be configured by the administrator at agent startup or at agent run time.  
 

Configuring View through XML File at Agent Startup 
 

User views can be configured at agent startup, by editing the default vbac.xml available in 
<Agent Toolkit Home>/jmxprojects/projectname/agent/bin/conf directory.  As specified in 
the previous section, this file contains the default views provided by AdventNet.  

 
The administrators can create new views specific to their requirements, modify existing views, or 
delete views which are not required in this XML file. 
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11.0 Logging Service 
 

 
11.1 Logging Service : An Overview  
11.2 Logging ServiceMBean  
11.3 Logging Levels  
11.4 Setting Logging Levels  
11.5 Viewing Log Files  
11.6 Printing of log messages to module specific log files 
11.7 Dynamically adding new logging modules and loggers at runtime  
11.8 Archive Support  
11.9 Customizing Logging Service 

 
 
11.1 Logging Service : An Overview 
 
At run time, agent generates log messages for the user to know about the agent processing. These log 
messages are stored in a text file .  Each log message has an associated log Level. The Level gives a 
rough idea about the importance and urgency of a log message. The user can select the level of log 
message to be recorded in the log file. Log messages with log level less than that chosen by the user are 
discarded and are not recorded in the log file.  
 
Salient features of AdventNet Logging Service : 

• Pinpointing bugs, configuration errors, performance blockades, etc. 
• Printing of log and error messages of various modules. 
• Printing of log messages to module-specific log files can be availed by specifying the log 

filename, logging levels, etc. 
• Enabling/disabling Logging for various modules at run time. 
• Dynamically adding new Logging modules and Loggers at run time. 
• Smart Archiving Support for Log files. 

11.2 Logging Service MBean 
   
AdventNet Multi-Protocol agent has implemented Logging Service as an MBean so that it may be 
registered in an agent and configured by remote applications. The LogFactoryController is the MBean 
used to configure and customize logging. The MBean enables one to configure logging at run time. The 
following code snippet generated in the main file is used to register this MBean.  
 

//Registering the LogFactoryController MBean. 
LogFactoryController logFactoryController= new 
LogFactoryController(); 
name = "Service:type=logging";  
server.registerMBean(logFactoryController,new ObjectName(name)); 

   
11.3 Logging Levels 
 
The AdventNet Logging Service supports the following logging levels:  

• Disabled (0) :  This level indicates that the log messages do not get stored in the text file. 
• Fatal (1) : Fatal level indicates that the application has encountered a severe error that may make 

the system unstable. These errors need to be attended to immediately. When this level is chosen, 
only critical messages such as details on Agent crash, Authentication errors, Agent already open 
in another session, etc., get stored in the log file. 
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• Error (2) : Error level indicates that an error has occurred and the application cannot handle the 
request as designed. This may automatically be corrected during execution or the application 
should be capable of handling those situations when a similar request comes again. Selecting 
this level stores all the Error and Exception messages in the log file along with the fatal 
messages. 

• Warn (3) : Warning messages indicate that the application has met with an expected error. All 
Warning messages get stored in the log file when debug level is Warn. Log messages 
corresponding to log levels 1 and 2 are also stored in the log file. 

• Debug (4) : On choosing this log level, the application moves into the debug mode. It will be used 
for generating debugging information and should not be used in general cases. 

• Info (5) : The Info level does not signify the occurrence of any error but logs all important events. 
Any information that might be required for reference gets stored in the log file under this info level. 

• Trace (6) : In this mode, the application logs every activity from entering a method to exiting. 
Hence, selecting this level may affect performance. The Trace level should be used only to solve 
any complex problem. 

11.4 Setting Logging Levels 
 
You can specify the required logging level using JMX Compiler UI or using API. 
 

Using JMX Compiler UI 
 

• Select Project -> Settings option.  In the Settings Tree Structure, 
select Source Code Generation -> General. This displays the dialog 
for the General Settings on the right side. 

• The log level can be selected from the Debug Level option. 

 
Using API  

 
The logging level can also be specified by adding the relevant code directly in the generated 
main file.  The following code snippet will set the log level to debug level.  
 

LogFactory.setLoggingLevel(debugLevel); 

 
11.5 Viewing Log Files 

• The log messages get stored in a text file named agent.log. 
• This file gets created as soon as the Agent is started and produces reports based on the 

specified debug level . Log messages include debug levels equal to and lesser than the level 
specified. 

• These messages can be viewed from the logs folder in <Agent Toolkit 
Home>/jmxprojects/projectName/agent/bin/logs directory. 

• Once the Agent is stopped and restarted ,the older log messages get shifted to agent1.log and 
the newly started Agent  transfers its log messages to agent.log.  This keeps continuing until 
agent9.log. 

• Later, the log messages are zipped and placed under the archives folder of the logs directory 
excepting for the latest one.  Please refer to Archive support to know more about this feature. 

• Thus, agent.log always shows the log messages of the recently started Agent. 
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11.6 Printing of log messages to module specific log files 
 
To write log messages to module specific  log files, get the corresponding logger. For example, if you 
want to write the logging related to JMX core, to be in a file called JMX.log, please use 
LogFactory.getInstance("JMX","JMX.log",".").  Then use this logger for logging purposes.  
 
11.7 Dynamically adding new logging modules and loggers at runtime 
 
LogFactory.getInstance(String loggerName) will yield a new logger with the specified loggername.  
 
11.8 Archive Support 
 
Each time the agent is restarted, a separate log file is created. In some cases, we may need  to keep 
these log files for future reference. In order to achieve this,  the Archiving support has been added. This 
feature gives you the option to preserve the log files, if you wish. 
 
The log files will be stored in a zip file bearing archive file name in the format <filename>.zip. The 
individual log file will be stored with the name in the format  <filename>_date_in_desired_format.txt. For 
example, if the filename is agent.txt then archive file name would be agent.zip. 
 
11.9 Customizing the Logging Service 
 
You can customize logging services such as changing the debug level, changing the filename/directory 
name, enabling/disabling logging support, etc., at agent run time. This can be done from MBean 
Browser/HTTP Console or using the API methods.  
 

 

Note: To customize using MBean Browser, the browser must be started and 
connected to the server. 

 
11.9.1 To Set Logging Level for the Multi-Protocol agent  

 
You can set a logging level for the Multi-Protocol agent. This can be done either using the 
MBean Browser/ HTTP Console or by calling the appropriate methods.  

 
11.9.1.1 Using MBean Browser/ HTTP Console  

• Select Service, type = logging, from the Domain tree structure. 

• Select the Operation -> SetLoggingLevel. 
• Specify the logging level. 

• Click OK button. 
11.9.1.2 Using API  

 
The following method must be called inside the agent.  The parameter int level should be any 
one of the logging levels explained above.  
 

LogFactory.setLoggingLevel(int level) 

 
11.9.2 To Change Log File Name and Directory 

 
You can change the default log file name and logging directory as per your requirement. This 
can be done either using the MBean Browser or by calling the appropriate methods.  
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11.9.2.1 Using MBean Browser 
• Select Service, type = logging , from the Domain tree structure. 

• Select the Operation -> changeLoggingLocation. 
• Specify the filename and the Directory Name in the options provided. You must specify 

the absolute path of the directory. 

• Click OK button. 
11.9.2.2 Using API 

 
The following method must be called inside the agent.  The parameter to be passed are Log file 
name and the directory name.  
 

LogFactory.changeLoggingLocation(java.lang.String 
name, java.lang.String location) 

 
11.9.3 To Disable Logging for a Specific Adaptor / Client  

 
You can disable logging service for a specific adaptor/client. This can be done either using the 
MBean Browser or by calling the appropriate methods.  

 
11.9.3.1 Using MBean Browser 

• Select Service, type = logging , from the Domain tree structure. 

• Select the Operation -> stoplogging. 
• Specify the name of the adaptor in which logging service is not required. 

• Click OK button. 
11.9.3.2 Using API 

 
The following method must be called inside the agent.  The adaptor name should be passed as 
the adaptor.  
 

stopLogging(java.lang.String name) 

 
11.9.4 To Start and Stop the Logging Service  

 
You can stop and restart the logging service at agent run time. This can be done either using the 
MBean Browser or by calling the appropriate methods.  

 
11.9.4.1 Using MBean Browser 

• Select Service, type = logging , from the Domain tree structure. 

• Select the Operation -> stoplogging, for stopping the logging service. 

• Select the Operation -> startlogging, for restarting the logging service. 
11.9.4.2 Using API  

 
The following method must be called inside the agent. 
 

stopLogging() 
startLogging() 
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12.0 Supported Storage Types for MBeans 
 

 
12.1 Supported Storage Types for MBeans : An Overview  
12.2 Configuring Storage Types for MBeans  
12.3 Configuring a Database  

 
 
12.1 Supported Storage Types for MBeans : An Overview 
 
Data held by the Multi-Protocol agent may either be stored in Text files, or in XML files, or in databases or 
be retrieved from external applications using system calls or from internal applications. The storage 
options depend on the data held by the run time agent. The AdventNet Multi-Protocol agent supports to 
provide the following storage options for the data held by agent.  

• Text File :  Provides a text file for all the attributes of tabular MBeans at agent startup. When the 
agent is restarted, the agent API reads the data in the text file and stores all the data in memory. 
For Scalar MBeans, the text files are created for each attribute only after processing the request 
and not at agent startup. 
 
The text file is generated in the <Agent Toolkit 
Home>/jmxprojects/projectname/agent/bin/fileToScalar directory, only when a get/set is  
made on its value. This file will have the latest value of the scalar node and the agent will read the 
same when it is restarted. Entries can be modified or included in the text file during run time and 
these entries take effect only when the agent is restarted.  

• XML File : Provides a xml file for all the attributes of tabular MBeans at agent startup. When the 
agent is restarted, the agent API reads the data in the text file and stores all the data in memory. 
XML can be a persistent storage type only for Tabular MBeans. 
 
The XML file is generated in the <Agent Toolkit 
Home>/jmxprojects/projectname/agent/bin/xmlToVector directory, at agent startup. This file 
will have the latest value of the tables node and the agent will read the same when it is restarted. 
Entries can be modified or included in the XML file during run time and these entries take effect 
only when the agent is restarted. 

• Database : Provides storage in databases. Usually, databases are used to hold large volumes of 
data . In some cases, the data may also be dynamic in nature. If storage type in database is 
enabled,  the agent API establishes the connection between agent and the database at agent 
startup. 
 
The Database name,  URL, driver,  user name, password, and table name can be specified in the 
Database Settings option provided in the JMX Compiler. 

• Runtime Memory : Does not provide storage of data in text files, XML files, or databases.  The 
entire data maintained by the agent will be stored in memory at agent startup. 

• User Defined:  This option can be used if  you wish to store the tabular data values in a different 
place and would like the table to respond only when the request reaches the Agent. This option 
makes use  of the User Storage Model, wherein a JmxTableModelListener Interface is 
implemented. The interface, when initialized, calls the respective methods present in the 
interface.  
 
Please refer to the topic "JMXTableModelListener" for more details.  

 
Note: For non-tabular data, only Runtime Memory and Text File storage are supported. 
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12.2 Configuring Storage Types for MBeans 
 
You can configure the required storage option for the MBean attributes using the JMX Compiler UI.  Code 
is generated based on the options specified.  
 

Using JMX Compiler UI  
• Select Project -> Settings option. In the Settings Tree Structure, select Source Code 

Generation -> Storage Model. This displays the dialog for the Storage Model on the 
right side. 
 
Storage Option for Tables 

• For tabular data, select the storage option from the list provided for Tables. This provides 
the specified storage type for all the tables present in the MIB. If storage is provided in 
Database, configure the database settings, using the Configure -> Database option.  

• To customize the storage option for all or any of the Table nodes in the MIB, select Node 
Storage Type. From the tables listed in the MIB tree, select a table and define the 
storage type for that table.  

• For example, you want to provide storage in Database for the adiskTable and storage  in 
text file for all other tables in the AGNT-SAMPLE-MIB. To do this, select Text File option 
for Tables. Then, click adiskTable in the MIB tree and select Node Storage Type as 
Database.  
 
Storage Option for Scalars 

• For nontabular data, select the required storage option from the list specified for Scalars. 
This provides the specified storage type for all the scalars present in the MIB. 

• Node Storage Type. From the scalars listed in the MIB tree, select a scalar node and 
define its storage type. 

• For example, you want to provide storage in text file for all scalar nodes in the MIB, 
except the node agentLocation in agentSystem of AGENT-SAMPLE-MIB.  To do this 
select Text File option for Scalars. Then, click scalar node agentLocation in the MIB tree 
and select Node Storage Type as RAM.  

12.3 Configuring Database 
 
If storage in Database is provided for all or any of Tables of a MIB, the following Database parameters 
have to be provided to access the database.  Select  the Database option for configuring the following :  

• Database Name 

• url 

• Driver 

• UserName 

• Password 
For example, let us assume that we have to provide storage in Database for the adiskTable of the 
AGENT-SAMPLE-MIB.  In order to proceed with this, do the following : 

1. Add the database file, (from an application which provides a ODBC driver) to the ODBC Data 
Source Administrator.  Provide a unique name for the file as "DatabaseTest".  

2. Once this is done,  you have to associate this data source to the adiskTable object in the MIB file. 
In this case, the DATABASE-URL should be "jdbc:odbc:DatabaseTest".  
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3. Specify the Database driver name as "sun.jdbc.odbc.JdbcOdbcDriver".  
4. Specify a User Name and a Password. For Example, the User Name can be "AdventNet" and the 

Password can be "adventnet".  

 

Note: The Database Name, URL, Driver, UserName,  and Password must be the same 
for all the Tables,  which provide database storage 
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13.0 External Storage of Data for Tables 
 

 
13.1 JMXTableModelListener : An Overview  
13.2 Methods Present in JMXTableModelListener Interface 

 
 
The AdventNet Multi-Protocol agent supports storage of tabular data in text files, XML files, databases, 
and RAM. In some cases, tabular data may be held in some other form or stored externally in a different 
place. The JmxTableModelListener Interface is implemented to handle this type of user storage models.  
 
13.1 JMXTableModelListener : An Overview 
 
To use the JmxTableModelListener, the XXXTable.java has to implement the 
com.adventnet.utils.jmx.JmxTableModelListener interface. This interface is used for handling tables in 
JMX when user needs the choice of handling the table entries rather than the Multi-Protocol agent holding 
them in memory.  
 
To implement this interface, follow the steps given below :  

• Select Project -> Settings option. In the Settings tree structure, select Source Code Generation 
-> Storage Model. This displays the dialog for the Storage Model on the right side. 

• Select the storage option for the all or any of the table as User Defined 
For example, if Storage option is specified as User Defined for the adiskTable of the AGENT-SAMPLE-
MIB, the following code is generated in the AdiskTable.java file.  
 

public class AdiskTable implements JmxTableModelListener 
 
With this, the Agent gets initialized with User Storage Model and thus any request from the manager for 
that particular table is forwarded to the Interface implemented for this purpose. Data is retrieved from the 
table only when the request reaches the Agent. The interface, when initialized, calls the respective 
methods present in the interface. These methods will be exposed to the MBeanServer through the 
xxxTable.xml file. Users have to instrument these methods according to their requirement, so that it 
returns the required information. The xml files are generated in 
./jmxprojects/<projectname>/agent/bin/conf/xml/mbeans directory.  
 
13.2 Methods Present in JMXTableModelListener Interface 
 
The interface has the following methods defined in it.  

• To Get the Entry for the Given Row (Identified by the Instance)  
The getEntry() method is used to get the entry for the given row, identified by the instance.  This 
method will be called when a GET is done on a Table specifying the instance. 
 
It takes an Object array with index objects, which identify the row , as the parameter. It returns the 
CompositeData object of that instance. Each row in the table is a CompositeData object.  

public CompositeData getEntry(Object[] indexObjects) 
{ 
return null;  
} 
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• To Get the Next Entry for the Given Row (Identified by the Instance) 
 
The getNextEntry() method is used to get the next entry of the given row, identified by the 
instance.  This method will be called while doing a walk on the Table, after calling the 
getFirstEntry(). It takes an Object array with index objects, which identify the row as the 
parameter. It returns the CompositeData object of that instance.  

public CompositeData getNextEntry(Object[] 
indexObjects); 
{ 
return null; 
} 

• To Get the First Entry in the Table 
 
The getFirstEntry() method is used to get the first entry in the table.  This method will be called 
when a walk is done on a table. After calling the getFirstEntry(), the getNextEntry() will be called 
while doing a walk on a Table.  
 
The return type of this method is a CompositeData entry object.  

public CompositeData getFirstEntry(); 
{ 
return null; 
} 

 

 

Note: The methods getEntry(), getNextEntry(), and getFirstEntry() will 
be called only through SnmpAdaptor 

• To Add a Row to the Table 
 
The addRow() method is used to add a row to the table. This method will be called when the 
manager is trying to add a row in the table. This method takes the following parameters: The 
Object array with index objects, which identify the row, and the Composite data entry. 

public void addRow(Object[] indexObjects, CompositeData 
entry) 
throws Exception; 

• To Delete a Row from the Table 
 
The deleteRow() method is used a delete a row from the table. This method will be called when 
the manager is trying to delete a row from the table.  
 
This method takes the object array with index objects, which identifies the row, as its parameter. 

public void deleteRow(Object[] indexObjects) throws 
Exception; 

• To Modify an Existing Row in the Table 
 
The modifyRow() method is used to modify the values of a row in the table.  This metod will be 
called when the manager is trying to modify  a row in the table.  
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This method takes the following parameters : The Object array with index objects, which identify 
the row,  and the Composite data entry.  

public void modifyRow(Object[] indexObjects, 
CompositeData entry) 
throws Exception; 

 

 

Note: The methods addRow(), deleteRow(), and modifyRow() will be 
called from all the threeadaptors - SNMP, HTML, and TL1.  

• To Return the Total Number of Rows in the Table 
 
The totalRows() method is used to give the total number of rows in the table as an integer. 

public int totalRows(); 

• To Get All the Entries in the Table 
 
The getEntries() method is used to get all the entries in the table . It takes the startIndex and 
endIndex (both as int datatype) as the parameters and returns a List of CompositeData instances 
in the table.  
 
The HTML adaptor calls this method while viewing the entries in the table. The TL1Adaptor calls 
this method while doing a GETALL on the Table.  

public java.util.List getEntries(int startIndex,int 
endIndex) 

For example, if the first five rows need to be retrieved from the table, the adaptors will invoke this 
method by passing 1, 5 as the parameters to this method. For getting the first row alone, the 
parameters passed would be 1, 1. Because this returns an ArrayList of CompositeData 
instances, the getEntry() method will be invoked after this to get the actual entries.  
 

 

Note: The methods totalRows() and getEntries() will be used by the 
HTML and TL1 adaptors. Users who wish to have only SNMP interface 
need not implement this method 
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14.0 Loading MBeans Dynamically Using MLet Service 
 

 
14.1 MLet Service : An Overview  
14.2 Loading MBeans From a URL  
14.3 Creating the MLet Service in the Agent  
14.4 Running the MLet Example  

 
 
14.1 MLet Service : An Overview 
 
MLet, the management applet service allows you to instantiate and register in the MBean Server, one or 
more MBeans coming from a  remote URL. The MLet service does this by loading an MLet text file, which 
specifies the information on the MBeans to be obtained. The location of the MLet text file is specified by a 
URL. When an MLet text file is loaded, all classes specified in MLet tags are downloaded, and an 
instance of each MBean specified in the file is created and registered. This makes it possible to create 
dynamically extensible agents.  
 
Moreover, the MLet itself is registered with the MBeanServer as a Standard MBean (i.e. 
javax.management.loading.MLet class implements the javax.management.loading.MLetMBean 
interface).  Thus, the MLet service itself can be remotely managed.  
 
14.2 Loading MBeans From a URL 
 
In order to download an MBean, you must first have its corresponding MLet definition in a Text file. The 
contents of the MLet file is defined in the form of  HTML like tag called <MLET> which specifies 
information about the MBeans to be loaded. The tag contains information for downloading the class, such 
as the classname and the location of its class file. You may also specify  arguments to the constructor 
used to instantiate the MBean.  
 

14.2.1 MLet Tags  
 

The MLet service loads a URL, which identifies the file containing <MLET> tags, one for each 
MBean to be instantiated, in the Multi-Protocol agent. The MLET tag has the following syntax:  
 

<MLET 
CODE = class | OBJECT = serfile 
ARCHIVE = "archivelist" 
[CODEBASE = codebaseURL] 
[NAME = MBeanName] 
[VERSION = version] 
> 
[arglist] 
;</MLET> 

 
The elements of this tag are explained below:  
CODE = class 

 
This attribute specifies the full Java class name, including package name, of the MBean to be 
obtained. The compiled .class file of the MBean must be contained in one of the JAR files 
specified by the ARCHIVE attribute. Either the CODE or the OBJECT attribute must be present.  
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OBJECT = serfile 
 

This attribute specifies the .ser file that contains a serialized representation of the MBean to be 
obtained. This file must be contained in one of the JAR files specified by the ARCHIVE attribute. 
If the JAR file contains a directory hierarchy, this attribute must specify the path of the file within 
this hierarchy, otherwise a match will not be found. 
 
ARCHIVE = archiveList 

 
This mandatory attribute specifies one or more JAR files containing MBeans or other resources 
used by the MBean to be obtained. One of the JAR files must contain the file specified by the 
CODE or OBJECT attribute. If archive list contains more than one file:  

• Each file must be separated from the one that follows it by a comma (,) 

• The whole list must be enclosed in double quote marks (""). All JAR files in the archive 
list must be stored in the directory specified by the code base URL, or in the same 
directory as the MLet file, which is the default code base when none is given. 

CODEBASE = codebaseURL 
 

This optional attribute specifies the code base URL of the MBean to be obtained. It identifies the 
directory that contains the JAR files specified by the ARCHIVE attribute. This attribute is used 
when the JAR files are not in the same directory as the MLet text file. If this attribute is not 
specified, the base URL of the MLet text file is taken as the code base URL.  

 
NAME = MBeanName 

 
This optional attribute specifies the string format of an object name to be assigned to the MBean 
instance when the MLet service registers it in the MBean server. 
 
VERSION = version 

 
This optional attribute specifies the version number of the MBean and associated JAR files to be 
obtained. This version number can be used to specify whether or not the JAR files need to be 
loaded from the server to update those already loaded by the MLet service. The version must be 
a series of non-negative decimal integers each separated by a dot (.), for example 2.14.  
 
arglist 

 
The optional contents of the MLet tag specify a list of one or more arguments to pass to the 
constructor of the MBean to be instantiated. The MLet service looks for a constructor with a 
signature that matches the types of the arguments specified in the arglist. Instantiating objects 
with a constructor other than the default constructor is limited to constructor arguments for which 
there is a string representation. 

 
Each item in the arglist corresponds to an argument in the constructor. Use the following syntax 
to specify the argList:  
 

<ARG TYPE=argumentType VALUE=argumentValue> 
 
where:  

• argumenttype is the class of argument (for example Integer). 

• argumentValue is the string representation of the value of the argument. 
Please have a look at the Sample MLet file for your reference. 
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14.3 Creating the MLet Service in the Agent 
 
Once the MLet file is defined, the URL for the same can be specified using the JMX Compiler UI or using 
the API. 
 

Using JMX Compiler UI 
• Select Project  -> Settings option.  In the Settings Tree Structure, select JMX Standard 

Services -> Management Applet, which displays the Management Applet dialog on the 
right side. 

• Select the option Enable MLet Service. 
• Select the Add button to display the MLet URL dialog. 

• Specify the URL of the MLet Text file and click OK button to add the entry. 
The default URL specified in this option is http://localhost:8080/sample-mlet.txt. For this, the 
remote server must be started at local host at port number 8080 and the MLet text file must be 
present in the specified directory.  (In this example, the sample-mlet.txt file is in the current 
directory where the remote server is started).  

 
Similarly,  you can specify any number of URLs for creating the MLet Service.  

 
Using API  

 
The MLet Service can also be created by adding the relevant code directly in the generated 
main file.  The following sample code snippet  creates the MLet Service MBean, with the URL : 
http://localhost:8080/sample-mlet.txt. In this example, the web server must be started at local 
host at port number 8080 and the MLet text file must be present in the specified directory.  (In 
this example, the sample-mlet.txt file is in the current directory where the web server is started).  
 

//Registering the MLet Service  
MLet mlet = new MLet(); 
name = "Services:type=MLet"; 
server.registerMBean(mlet,new ObjectName(name)); 
mlet.addURL(new URL("http://localhost:8080/sample-
mlet.txt"")); 

 
While adding the above code snippet, we must import the package 
javax.management.loading.MLet. 

 
14.4 Running the MLet Example 
 
An example on the MLet service is present in the <Agent Toolkit Home>/examples/jmx/mlet directory. 
This is a simple example to illustrate the use of dynamic loading of management applet (MLet) provided 
by the XMOJO JMX implementation.  
 
The Readme.html file  explains the usage of the example and the steps involved in running the example . 
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15.0 Master Subagent Architecture in Multi-Protocol Agent 
 

 
15.1 Master - Subagent Architecture in Multi-Protocol : An Overview  
15.2 The Cascader Service MBean  
15.3 Creating the Cascading Service MBean in the Master Agent  
15.4 Starting the Cascader Service MBean  
15.5 Cascader Service MBean Attributes  
15.6 Cascading Service Functionality  
15.7 Running the Cascader Service Example 

 
 
15.1 Master - Subagent Architecture in Multi-Protocol Agent : An Overview 
 
It is easy to manage a large number of agents when they have a hierarchical structure of master agents 
and subagents. Managers communicate only with the master agents and access the subagents 
transparently, as if the information actually resided in the master agent. This Master - Subagent 
architecture in JMX can be achieved in three ways : 

• Using the Cascader Service MBean when the subagent is a RMI/CORBA/HTTP agent 

• Using JMX SNMP Proxy when the subagent is a SNMP agent 

• Using SNMP Proxy (Note: This feature would be applicable only if SNMP Adaptor is instantiated 
in the master-agent and the sub-agent is a Multi-Protocol agent with SNMP Adaptor or a 
standalone SNMP agent. The MBean server is eliminated in this transaction. The communication 
medium between the master-agent and the sub-agent is SNMP.)  

AdventNet SNMP Adaptors can be used as subagent to Third-party agents (including OS Native agent). 
For more details, refer Making AdventNet Agents as Subagents to Third-Party Agents (including OS 
Native agents) from Implementing SNMP proxy of Building SNMP Agent section. 
This topic deals with Master - Subagent Architecture in Multi-Protocol Agent using the Cascader Service 
MBean.  
 
15.2 The Cascader Service MBean 
 
Master Agent : The agent whose MBean server contains an active cascading service is called a master 
agent in relation to the other agent which is mirrored. Master agents concentrate and relay the information 
in their subagents and can provide their own specific information as well. 
 
Subagent :The agent to which the cascading service is connected is called the subagent in relation to its 
master agent. 
A Master agent can have any number of subagents, each controlled individually by a different Cascader 
MBean. The Cascader service can work with RMI, CORBA and HTTP protocols. 
 
The cascading service allows you to access the MBeans of a subagent directly through the MBean server 
of the master agent. The cascader service can be configured to use RMI, CORBA or  HTTP protocol to 
connect with the subagent.  There will be a cascader MBean instance per subagent configured  with 
subagent's host:port.  
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Figure 1: AdventNet Cascading service architecture 

 
For each of the subagent’s MBeans, the cascading service instantiates a mirror MBean that is registered 
in the master agent. The mirror MBeans are actual MBean objects registered in the master agent’s 
MBean server with the same object name. All attributes, operations, and notifications may be accessed 
through the mirror MBean. The mirror MBean forwards all management requests through the cascading 
service to the corresponding MBean in the subagent. 
 
The cascading service is dynamic, i.e., whenever MBeans in a subagent are registered or deregistered,  
mirrored MBeans get registered or deregistered. 
 
15.3 Creating the Cascading Service MBean in the Master Agent 
 
A Cascader Service  MBean is created for every subagent you wish to manage through the master 
agent.  This can be done from the JMX Compiler UI or using the API. 
 

Using JMX Compiler UI  
 

A cascader service MBean is created for each subagent entry.  A subagent entry can be added 
using JMX Compiler UI, as given below:  

• Select Project  -> Settings option.  In the Settings Tree Structure, select AdventNet 
Services -> Cascader Service,  which displays the Cascader dialog on the right side. 

• Select the Add option, which displays the Entry Parameters for the subagent. Here, you 
can specify the following details : 

o The subagent host IP Address or name. 
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o The port number at which the subagent is running. 
o The Protocol used by the subagent - RMI/CORBA/HTTP. 
o The timeout value to receive a response from the subagent. 

• Click the OK button to add the subagent entry to the Cascading Table. 
Similarly, you can add any number of subagent entries in the Cascading Table.  

 
Using API :  

 
The following code snippet, added in the main file, creates a cascader service MBean for a 
subagent running at localhost with port number 1099, using RMI protocol.  
 

// add the following import statement 
import com.adventnet.services.cascading.Cascader;  

//register the cascading service with the MBean server 
Cascader cascader_0 = new Cascader("localhost",1099,"RMI"); 
name = "Services:type=Cascader,name=Cascader_0; 
server.registerMBean(cascader_0, new ObjectName(name)); 
cascader_0.startService(); 

 
Similarly, you can add any number of subagent entries, by adding the given code snippet for 
each subagent . The subagent host name, port number, and protocol used  must be configured 
in the code. 

 
15.4 Starting the Cascader Service MBean 
 
To start the Cascader Service MBean we have to explicitly call the startService method of the Cascader 
MBean after which the MBeans of subagent will get reflected under Master Agent. The subagent should 
be started beforehand with the protocol with which we want to communicate our cascader to subagent. It 
can also be started in the following ways :  

• From the manager (MBean Browser) by connecting to the Master Agent and invoking the 
startService operation of Cascader MBean listed in the Services Domain. 

• From the API, by calling the startService() method of the corresponding Cascader MBean. 
Once the cascader service is activated the MBeans in the subagent are mirrored in the master agent.  For 
example, lets say the subagent1 (running in 'localhost' with RMI adaptor at port 1099) has 2 MBeans 
registered with it  with below object names:  
 
SubAgent1:type=MBean5 
SubAgent1:type=MBean6 
 
When the cascader service corresponding to subagent1 is activated :  

1. The cascader service will use Agent Toolkit client API  to connect to the subagent1 using RMI. 
Thus cascader in RMI client role will know the MBeans and its object names in subagent1.  

2. This cascader service instance will register itself with the master agent for the above 2 MBean 
object names. 
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3. Request Handling:  When manager queries the master agent for SubAgent1:type=MBean5, the 
query reaches the cascader service instance (since it has registered for this objectname).  This 
cascader service instance will proxy the request to the subagent1 using RMI.  Get the response 
from the subagent1, which will be sent as response to the manager.  

4. Notification handling:  The cascader service will register with the subagent1 as 
NotificationListener for remote notifications.  Any notifications emitted by the MBeans in the 
subagent1 will be propagated to cascader service by the subagent1 protocol adaptor (here, RMI 
adaptor).  After receiving the notifications the cascader service acting in NotificationBroadcaster 
role will broadcast the notification to its notification listeners.  The protocol adaptors in the master 
agent are listeners for all the notification broadcaster mbeans in the local agent (master agent).  
Hence the protocol adaptors in master agent will receive the notifications send by the cascader 
service and notifies to the managers.  

15.5 Cascader Service MBean Attributes 
 

Exposing Writable Attributes  
 

The Cascader MBean exposes three writable attributes : the subagent host, port, and protocol. 
Neither of these attributes may be modified when the cascading service is active. In order to 
start the service with different host, port and protocol, we must first do the stopService operation 
of cascader mbean from any of the browsers. This disconnects masteragent from the subagent 
thereby all the mirrored mbean taken from subagent will be removed.  After modifying the port 
number or protocol of the subagent, we have to start the service by doing startService operation 
of CascaderMbean. Now you could see the list of all MBeans mirrored from specified subagent. 

 
Exposing the Readable Attributes 

   
The Cascader MBean exposes three readable attributes:  the state of the Cascader MBean 
(Active/Inactive),  the total number of  Remote Objects in the Subagent, and the list of Remote 
Objects. 

 
When the cascading service is stopped or its MBean is removed from the master agent, all of its 
mirror MBeans are deregistered.  

 
15.6 Cascading Service Functionality 

• Adding or removing an MBean in the master agent will trigger a notification that any cascading 
service connected to the master agent will receive. 

• When an MBean is unregistered from the subagent, the cascading service MBean removes its 
mirror MBean from the master agent. 

• When a new MBean is registered in the subagent, the cascading service instantiates its mirror 
MBean, sets up its connection to the new MBean, and registers the mirror with the master agent’s 
MBean server. 

• Mirror MBeans are registered in the master agent with the same object name as the mirrored 
MBean in the subagent. 

• Any changes in the subagent’s MBeans are automatically applied to the set of mirror MBeans, to 
ensure that both master agent and subagent remain consistent. 

15.7 Running the Cascader Service Example 
 
Please refer  the Cascader Example present in the <Agent Toolkit Home>/example/jmx/cascader 
directory. This is a simple example to illustrate the usage of Cascading service provided by the XMOJO 
JMX implementation. This creates a Master-Sub agent architecture in JMX. 
 
The Readme.html file  explains the usage of the example and the steps involved in running the example. 
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16.0 Accessing Legacy SNMP Agents through Multiple 
Protocols 
 

 
16.1 JMX-SNMP Proxy : An Overview 
16.2 Adding JMX-SNMP Proxy Feature  
16.3 Accessing the SNMP Agent MBeans  
16.4 Running the Example 

 
 
16.1 JMX- SNMP Proxy: An Overview 
 
An existing SNMP agent can be accessed through multiple protocols using the JMX-SNMP Proxy feature.  
JMX-SNMP Proxy is a new feature provided by AdventNet. It helps to leverage legacy SNMP Agents and 
make them accessible through multiple protocols using the multi-protocol architecture.  
 
This feature is used, if there already exists an SNMP agent that the user wishes to manage through the 
Multi-Protocol agent.  Using the JMX-SNMP Proxy feature, the existing SNMP agent can be made to act 
as a sub-agent to the Multi-Protocol agent.  The Multi-Protocol agent must be generated with the same 
MIB which the SNMP agent implements. 
 
The Multi-Protocol agent, which supports the Proxy feature, acts as a Master Agent. It acts as a 
proxy and forwards the request to the SNMP Agent and  provides the required information to the 
Manager.  The manager receives the response through the same protocol using which the request was 
initiated.  
 
Hence, to implement the SNMP Proxy feature, the following conditions must be met : 

• The sub-agent should be a SNMP agent. 

• The Master agent must implement the JMX-SNMP Proxy feature. 

• The Master agent must implement the same MIB as that of the SNMP sub-agent. 

• The communication between the agents must be in SNMP language. 

• If the sub-agent's traps are to be forwarded to the SNMP managers through master agent, the 
snmpTrap group in the RFC1907 MIB must be included in the Master Agent. 

 

Note: The Multi-Protocol agent generated to leverage a legacy SNMP Agent can also 
implement MBeans of its own to manage its resources. It is not restricted to expose the 
information of the SNMP sub-agent alone.  

 
16.2 Adding JMX-SNMP Proxy Feature 
 
JMX-SNMP Proxy is achieved by providing a JMX Wrapper Agent for the existing instrumented SNMP 
Agent. No instrumentation is needed to achieve this. The instrumentation is taken care of by the 
AdventNet API.  You are just expected to generate a Multi-Protocol agent with the proxy feature and with 
appropriate protocols through which you wish to expose the manageable information. The proxy feature 
can be added to the Multi-Protocol agent from the JMX Compiler UI. 
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Using JMX Compiler UI 
 

To add this feature, at least one sub-agent entry must be added to the JMX Proxy Table. 

• Select the Project  -> Settings option.  In the Settings Tree structure, select AdventNet 
Services -> JMX-SNMP Proxy,  which displays the JMX-SNMP Proxy dialog on the right 
side. 

• Select the option, which displays the entry parameters of the JMX-SNMP Proxy Agent. 
The following information is specified here: 

o The SNMP sub-agent host IP address or name. 
o The Port number where the SNMP sub-agent is running. 
o The community name of the SNMP sub-agent. 
o The timeout value to receive a response from the SNMP sub-agent. 
o The MIBs loaded in the MIB Tree are displayed under MIB Modules. Select the 

MIB Module, which is implemented in the SNMP sub-agent. 
Similarly, you can add any number of SNMP sub-agent entries, using the JMX Compiler UI. 
 

If the community, host, and port number of the sub-agent have to be changed after generating the agent, 
JMXSNMPProxyMBeansConf.xml configuration file which is present in <Agent Toolkit 
Home>\jmxprojects\projectname\agent\bin\conf directory, can be used. 
 
16.3 Accessing  the SNMP Agent MIB Variables 
 
Once the Master agent is started, you can interact directly with the sub-agent’s MIB variables. These MIB 
variables can be accessed using RMI, CORBA, HTTP, HTML, and TL1 adaptors as MBeans. All 
management operations such as modifying attribute value, get operation, and set operation can be 
performed on the MBeans. This gives exactly the same result as if the manager were connected to the 
sub-agent while performing the action. 
 

 

Note: The SNMP sub-agent must be started at the specified port for enabling the 
connection between the Master Agent and the SNMP sub-agent. 

 
16.4 Forwarding  the Sub-agent's SNMP Traps as Notification 
 
The Master Agent, generated as mentioned above, opens an SNMP Session at the port number 8005 by 
default. When sub-agent sends a trap to this particular port, the Master agent will convert the trap to 
notification and forward it to its registered notification listeners. Thus, the notification can be viewed by all 
the adaptors and registered managers. 
 

 

Note: If the port has to be changed, the below given line in the generated main file can 
be edited with the port number at which the user wish the master agent to listen, 
 
jmxProxy.startListenerAndForwarder(new Integer(8005));  
 
Then compile and start the agent. The Master agent listens at the port number 
mentioned. 
 
Also, the SNMP trap can be forwarded to the SNMP Manager through master agent 
only if snmpTrap group in the RFC1907 MIB is included in the Master Agent. 
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16.5 Running the Example 
 
The JMX Proxy example is available in the <Agent Toolkit Home>/examples/jmx/jmxproxy directory.  
Using this example, you can access an existing SNMP agent implementing the RFC1213-MIB, through 
HTTP/RMI/CORBA. 
 
The readme.html file  explains the usage of the example and the steps involved in running the example.  
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17.0 Discovering Other Multi-Protocol agents in a Network 
 

 
17.1 Discovery Service : An Overview 
17.2 The Discovery Service MBean  
17.3 Creating the Discovery Service MBean  
17.4 The Discovery Client  
17.5 Performing the Discovery Operation  
17.6 Running the Example 

 
 
17.1 Discovery Service : An Overview 
 
Multi-Protocol agents in a network can be discovered using the AdventNet Discovery Service. The 
discovery service enables the Multi-Protocol agents to be discovered in a network. This service relies on 
a discovery client object, which sends out multicast requests to find agents. In order to be discovered, an 
agent must have implemented the discovery service. This functionality allows interested applications to 
establish a list of active Multi-Protocol agents and keep it updated.  
 
In addition to knowing about the existence of an agent, agent applications are free to use the discovery 
service since they may require such information for cascading (refer topic Master-Subagent Architecture 
in Multi-Protocol Agent) . To provide Remote manageability of the discovery service in an agent, all of its 
components are implemented as MBeans.  
 
17.2 The Discovery Service MBean 
 
Agent Toolkit provides the Discovery Service as a MBean. Multi-Protocol agents should have 
com.adventnet.services.discovery.DiscoveryService MBean registered with the MBean Server to be 
discovered by the discovery client. 
 
The Discovery mechanism uses XML over UDP (multicast datagram socket) for communication between 
the agent (discovery service) and discovery Clients. This enables,  

• Discovery information to be extended without changing the existing client or agent. 

• Achieving backward compatibility, i.e., discovery client can discover Multi-Protocol agents with 
different versions of Discovery Service MBean. 

 

Note: The Multicast group is a combination of Class D IP Address and standard UDP 
port number to which the recipients are subscribed to listen for the packets. Multicast 
group IP addresses are in the range 224.0.0.1 to 239.255.255.255, inclusive. The 
address 224.0.0.0 is reserved and should not be used. The default multicast group IP 
Address for AdventNet discovery service is 225.225.225.0 and multicast port is 8222. 
 
Time to live is an 8 bit unsigned byte associated with each multicast packet to 
determine how many hops it can travel. When this reaches zero, the packet is 
completely discarded. Time to live ranges from 0 - 255.  
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17.3 Creating the Discovery Service MBean 
 
You can create the discovery service MBean using the JMX Compiler UI or using the API.  
 

Using JMX Compiler UI 
 

You can configure the Multi-Protocol agent with discovery service by following the steps given 
below:  

• Select Project  -> Settings option.  In the Settings tree structure, select AdventNet 
Services -> Discovery,  which displays the Discovery dialog on the right side. 

• Select the option Enable Discovery Service. 
• Enter the following details : 

o The multicast group IP Address for discovery service. 
o The multicast group port number. 
o The time to live. 
o User Key and User Value 

On code generation, the above entry adds the necessary code to register the Discovery Service 
with the given multicast group IP Address and port number. 

 
Using API 
 

import 
com.adventnet.services.discovery.DiscoveryService; 
//Registering the Discovery Service. 
DiscoveryService discoveryservice = new 
DiscoveryService(); 
name = "Services:type=DiscoveryService"; 
discoveryservice.setMulticastGroup("225.225.225.255); 
discoveryservice.setMulticastPort(8222); 
discoveryservice.setTimeToLive(5); 
server.registerMBean(discoveryservice, new 
ObjectName(name)); 
Properties userData = new Properties(); 
userData.put("data1", "data2"); 
discoveryservice.setUserData(userData); 
discoveryservice.startService(); 

 
The above code snippet registers the discovery service MBean with multicast group IP Address 
225.225.225.255 and multicast port 8222. 

 
17.4 The Discovery Client 
 
The Discovery client service  enables to discover AdventNet Multi-Protocol agents in a network.  
Discovery clients can only discover the agents listening on the same multicast group and port and which 
has implemented the discovery service.  
 
The DiscoveryClient class provides methods to discover agents. The discovery client 
(com.adventnet.services.discovery.DiscoveryClient)  is the client that sends the broadcast packet 
when it comes up. The Multi-Protocol agents (with discovery service) running in the network will respond 
to it with the information such as Host Name, MBean Server ID, Adaptors/Connectors information.  
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Discovery Client  Code Snippet 
 

DiscoveryClient client = new DiscoveryClient(); 
client.addDiscoveryObjectListener(this); 
client.start(); 
.... 
//discover all agents in the network 
DiscoveryEvent event = client.discoverJMXAgents(); 
.... 
//discover all agents in the host "agent-testpc1" 
event = client.discoverJMXAgents("agent-testpc1"); 

 
The default multicast group IP address is 225.225.225.255 and port Number is 8222. These may 
be set to other values through the MulticastGroup and MulticastPort attributes. Before initiating 
searches, you must call the discovery client’s start method. This creates its multicast socket and 
joins the multicast group used for broadcasting its discovery request.  

 
The scope of the discovery request depends on the time-to-live used by the multicast socket.  
Time to live ranges from 0 - 255.  You can modify this value at any time by setting the discovery 
client’s TimeToLive attribute.  

 
By default, a discovery client waits for responses for five second after it has sent a discovery 
request. This period can be customized by setting a value in milliseconds for its TimeOut 
attribute. 

 
17.5 Performing the Discovery Operation 
 
The AdventNet MBean Browser is a Manager application, which enables the user to access a Multi-
Protocol agent's MBeans and use the provided services through the RMI/ CORBA/ HTTP protocol 
adaptor. To perform the discovery operation from MBean Browser, follow the steps given below : 

• Start MBean Browser 
• Select the option Settings -> Discovery. This displays the Discovery Service Panel . Here, the 

default multicast group for AdventNet discovery service is 225.225.225.255 and multicast port is 
8222.   You can change this to any other IP Address and Port number.  Also, specify the Timeout 
value within which the discovery client  has to discover the Multi-Protocol agent. 

• Click the Start button. This discovers the Multi-Protocol agents running in the network , which 
has  implemented the discovery service with the same multicast group IP address and port. 
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Connecting to the discovered agent 
 

To connect to a discovered agent, 

• Select the IP Address of the discovered agent and right-click. 

• From the right click menu, select Connect option to connect to the server using 
RMI/CORBA/HTTP. 

• Now, you will be able to view the list of MBeans registered with the Multi-Protocol agent 

Viewing properties of the discovered agent 
 

To view the properties of the discovered agent, 

• Select the IP Address of the discovered agent and right-click. 

• From the right click menu, select Properties option. This displays the following agent 
properties: 

o Host Name 
o MBeanServerId 
o The port number of the adaptors 

 

Note: To be discovered by the discovery client : 

• The Multi-Protocol agents must have implemented the Discovery service 

• The Multi-Protocol agents must belong to the same multicast group and port 
number. 

 
17.6 Running the Example 
 
Please refer  the Discovery Service example present in the <Agent Toolkit 
Home>/example/jmx/discovery directory. This is a simple example to illustrate the usage of discovery 
service provided by the Agent Toolkit. 
The Readme.html file explains the usage of the example and the steps involved in running the example . 
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18.0 Monitoring the MBean Attributes 
 
Attributes in the MBean can be monitored using the AdventNet Monitor Service. 
 

 
18.1 Monitor Service : An Overview  
18.2 Counter monitor  
18.3 Gauge monitor  
18.4 String Monitor  
18.5 Table Monitor  
18.6 Monitor Notification  
18.7 Running the Example  

 
 
18.1 Monitor Service : An Overview 
 
The Monitoring service allows you to observe the variation over time of attribute values in  MBeans and 
emit notifications at threshold events.   All monitors have a configurable granularity period that 
determines how often the attribute is polled. There are three monitor MBeans, one for counter attributes, 
another for gauge-like attributes, and the third for strings.  
 
These monitors send notifications when the observed attribute meets certain  conditions, mainly equalling 
or exceeding a threshold. The conditions are specified when the monitor is initialized. Monitors may also 
send notifications when certain error cases are encountered during the observation.  
 
The monitor derives a value from the observation, called the derived gauge. This derived gauge is either 
the exact value of the observed attribute, or the difference between two consecutive observed values of a 
numeric attribute.  
 
The time interval during which the attribute is monitored is called the Granularity period. It is specified in 
milliseconds. For example, if the granularity period is 5000, the attribute is monitored every  5 seconds.  
 

 

Note: Counter Monitor, String Monitor, and Gauge Monitor are not supported for 
Tabular Data. In this release, AdventNet provides a new feature called "Table Monitor" 
to monitor MBean attribute values represented in Tabular format. 

 
18.2 Counter Monitor 
 
The Counter Monitor observes an attribute of type byte, short, int and long that is monotonically 
increasing. That means,  

• Their value is always positive or null 

• They can only be incremented 

The counter monitor has a threshold value and an offset value to detect counting intervals. The counter 
monitor resets the threshold if the counter rolls over. 
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Creating a Counter Monitor MBean 
 
You can create a Counter Monitor using the JMX Compiler UI or using API. 
 

Using JMX Compiler UI  
 

To add a Counter Monitor entry using JMX Compiler, please follow the steps given below:  

• Select Project  -> Settings option.  In the Settings Tree Structure, select JMX Standard 
Services -> Monitors -> Counter. This displays the dialog for the Counter Monitor on 
the right side. 

• Select the Add option. This displays the Entry Parameters for the Counter Monitor and 
Counter Attributes available in the loaded MIB. 

• Enter the following details: 
o Attribute : Select the Attribute that has to be monitored from the attributes listed 

in the attribute tree.  Only those attributes in the MIB that are of "Integer, 
Timeticks, Integer32, Counter, Counter32, Counter64, TruthValue, TimeInterval, 
Storage Type, TestAndIncr" types will be displayed in the tree. 

o Threshold : Specify the comparison value with derived gauge to send 
notification. 

o Offset :  Specify the value to increment in threshold after derived gauge reaches 
or exceeds threshold.  If the offset value is not zero, whenever the threshold is 
triggered by the counter value reaching a comparison level, that comparison level 
is incremented by the offset value. 

o Enable Notification : The Counter Monitor Service sends a notification when the 
value of the counter reaches or exceeds a threshold known as the comparison 
level. 

o Difference Mode : Specify, derived gauge value calculation type, i.e., difference 
between two observations or not. 

o Granularity Period :  Specify the time interval taken for monitoring the attribute, 
in milliseconds. 

• Click OK to add the entry to the table. 
Example : Let us assume we want to monitor an MBean attribute "asmtimeTicksScalar" defined 
in MIB with default value of 0.  The comparison level (threshold) is 10 and the offset value is 5. 
The attribute is monitored every five seconds as specified in the Granularity Period. 

 
In this example, the Observed Attribute is asmtimeTicksScalar, the default attribute value is 0,  
the threshold value is 10, the time interval (granularity period) for monitoring the attribute is 5 
seconds. 

 
If Enable Notification option is selected, the Monitor service sends a notification , when the 
"asmTimeTicksScalar"  value reaches the threshold value 10.  Because the offset value is 
specified as 5, the comparison value  (10) is incremented by 5,  when the comparison level is 
reached.  

 
Using API 

 
A Counter Monitor can also be created by adding the relevant code directly in the generated 
main file inside registerJMXServices method. The following code snippet creates a Counter 
Monitor with the values as specified in the above example.  The  start() method is used to start 
the counter monitor service.  
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import javax.management.monitor.CounterMonitor; 
CounterMonitor cm_0 = new CounterMonitor(); 
name = 
"Services:type=CounterMonitor,name=CounterMonitor_0"; 
cm_0.setObservedObject(new 
ObjectName"AdventNetJMXAgent:type=GroupV2NodeInstrument
")); 
cm_0.setObservedAttribute("Integerv22"); 
cm_0.setGranularityPeriod(5000); 
cm_0.setDifferenceMode(false); 
cm_0.setThreshold(new Integer (10)); 
cm_0.setOffset(new Integer (5)); 
server.registerMBean(cm_0, new ObjectName(name)); 
server.addNotificationListener(new 
ObjectName(name),notifImpl,notifImpl,(new Object())); 
cm_0.start(); 

 
18.3 Gauge Monitor 
 
The Gauge Monitor observes an attribute of integer or floating point types that fluctuates within a given 
range. The gauge monitor has both a high and low  threshold, each of which can trigger a distinct 
notification. The two thresholds can also be used to avoid repeated triggering when an attribute oscillates 
around a threshold. Notification for a particular threshold would be sent again only after the value crosses 
the other threshold. 
 
Creating a Gauge Monitor MBean 
 
You can create a Gauge Monitor using the JMX Compiler UI or using API. 
 

Using JMX Compiler UI 
 

To add a Gauge Monitor entry using JMX Compiler, please follow the steps given below: 

• Select Project  -> Settings option.  In the Settings Tree Structure, select JMX Standard 
Services -> Monitors -> Gauge. This displays the dialog for the Gauge Monitor on the 
right side. 

• Select the Add option. This displays the Entry Parameters for the Gauge Monitor. The 
Gauge Attributes defined in the MIB is listed in the Gauge Attributes Tree on the left side. 

• Enter the following details: 
o Attribute : Select the Attribute that has to be monitored from the attributes listed 

in the attribute tree. Only those attributes in the MIB that are of type "Gauge32 
and Unsigned32" will be displayed in the tree. 

o High threshold value : Specify the high comparison value with derived gauge to 
send notification. 

o Low threshold value : Specify the low comparison value with derived gauge to 
send notification. 

o High Notification : Select this option to send notification, if the attribute value 
crosses the Maximum value specified. 

o Low Notification : Select this option to send notification, if the low threshold is 
crossed. 
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o Difference Mode : Select this option to specify derived gauge value calculation 
type, i.e., difference between two observations or not. 

o Granularity Period (milliseconds) : Specify the time interval taken for 
monitoring the attribute.  The default time interval is 1000 milliseconds. 

• Click OK to add the entry to the table. 
Example:  Let us assume we want to monitor an MBean attribute "adiskUsed" defined in a 
sample MIB  with default value of 2500.  The maximum used capacity of the disk should not 
exceed 4000 and the minimum capacity used must not fall less than 500. 

 
In this example, the Observed Attribute is adiskUsed,  the attribute value is 2500,  the maximum 
value is 4000 and the minimum value is 500, the granularity period is 5  seconds. The attribute is 
monitored every five seconds.  

 
If the option High Notification is selected, the Monitor service sends a notification , when the 
adiskUsed value exceeds 4000. If the option Low Notification is selected, the Monitor service 
sends a notification, when the adiskUsed value falls below 500. 

 
Using API 

 
A Gauge Monitor can also be created by adding the relevant code directly in the generated main 
file inside registerJMXServices method. The following code snippet  creates a Gauge Monitor 
with the values as specified in the above example.  The  start() method is used to start the 
gauge monitor service. 
 

import javax.management.monitor.GaugeMonitor;  
GaugeMonitor gm_0 = new GaugeMonitor(); 
name = "Services:type=GaugeMonitor_0"; 
gm_0.setObservedObject(new 
ObjectName("SAMPLE_MIB:type=allscalars")); 
gm_0.setObservedAttribute(adiskused); 
gm_0.setGranularityPeriod(5000); 
gm_0.setDifferenceMode(true); 
gm_0.setNotifyHigh(true); 
gm_0.setNotifyLow(true); 
gm_0.setThresholds (new Integer(4000), new 
Integer(500)); 
server.registerMBean(gm_0, new ObjectName(name));  
server.addNotificationListener(new 
ObjectName(name),notifImpl,notifImpl,(new Object()) 
gm_0.start(); 

 
18.4 String Monitor 
 
The String Monitor observes an attribute of type String. The string monitor performs a full string 
comparison between the observed attribute and its match string. A string monitor sends notifications both 
when the string matches and when it differs at the observation time.  
 

 

Note: Notification will be sent to all registered Notification listeners , when the monitors 
observed attribute  value matches or differs with the given "string to compare" value. 
The Notification Listeners for the notification must be specified. 
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Creating a String Monitor MBean 
 
You can create a String  Monitor using the JMX Compiler UI or using API. 
 

Using JMX Compiler UI  
 

To add a String Monitor entry using JMX Compiler,  please follow the steps given below: 

• Select Project  -> Settings option.  In the Settings Tree Structure, select JMX Standard 
Services -> Monitors -> String. This displays the dialog for the String Monitor on the 
right side. 

• Select the Add option. This displays the Entry Parameters for the String Monitor. The 
String Attributes defined in the MIB are listed in the String Attributes Tree on the left side. 

• Enter the following details: 
o Attribute : Select the Attribute that has to be monitored from the attributes listed 

in the attribute tree. Only those attributes in the MIB that are of type "String", will 
be displayed in the tree. 

o String to Compare : The String Monitor Service is configured with a value for 
the string called string-to-compare. Specify the String whose value is to be 
compared with the Attribute value. 

o Notification difference : Selecting this option sends a notification,  whenever 
there is a difference between the Attribute value and the String that is being 
compared by the String Monitor. 

o Notification Matching : Selecting this option sends a notification, if the Attribute 
value matches with the  String to compare. 

o Granularity period : Specify the Time interval for observing the attribute value.  
The default time interval is 1000 milliseconds. 

• Click OK to add the entry to the table. 
Example: Let us assume, that we want to monitor the scalar attribute agentDescr of AGENT-
SAMPLE-MIB, which has a default value AgentDescr. 

 
In this example, the Observed Attribute is agentDescr, the attribute value is snmp-agent, the 
String to Compare is  jmx-agent, the granularity period is 5 seconds.  

 
If the option Notification difference is selected, the Monitor service sends a notification , when 
the attribute value differs from the comparable string jmx-agent.  

 
If the option Notification Matching is selected, the Monitor service sends a notification, when the 
attribute value is the same as the compared value jmx-agent.  

 
The attribute is monitored every five seconds.  

 
Using API 

 
A String Monitor can also be created by adding the relevant code directly in the generated main 
file inside registerJMXServices method. The following code snippet  creates a String Monitor 
with the values as specified in the above example. The start() method is used to start the string 
monitor service.  
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import javax.management.monitor.StringMonitor;  
StringMonitor sm_0 = new StringMonitor(); 
name = 
"Services:type=StringMonitor,name=StringMonitor_0"; 
sm_0.setObservedObject(new 
ObjectName("AdventNetJMXAgent:type=GroupV2NodeInstrument
")); 
sm_0.setObservedAttribute("OctetString"); 
sm_0.setGranularityPeriod(5000); 
sm_0.setStringToCompare("jmx-agent"); 
sm_0.setNotifyDiffer(true); 
sm_0.setNotifyMatch(false); 
server.registerMBean(sm_0, new ObjectName(name)); 
server.addNotificationListener(new 
ObjectName(name),notifImpl,notifImpl,(new Object())); 
sm_0.start(); 

 
18.5 Table Monitor 
 
AdventNet provides a new feature called "Table Monitor" to monitor table column values at intervals 
specified by the granularity period. The Table Monitor observes an attribute of type Integer or floating 
point types. The Monitoring can be done only  for the column level and not the row level.  Notifications will 
be emitted, if there is a change in any of the rows of the column, for which monitor is set.  
 
Creating Table Monitor MBean 
 
You can create a Table Monitor MBean using the JMX Compiler UI or using API.  
 

Using JMX Compiler UI 
 

To add a Table Monitor entry using JMX Compiler, please follow the steps given below: 

• Select Project  -> Settings option.  In the Settings Tree Structure, select JMX Standard 
Services -> Monitors -> Table. This displays the dialog for the Table Monitor on the 
right side. 

• Select the Add option. This displays the Entry Parameters for the Table Monitor. All the 
Table Nodes defined in the MIB are listed on the left side. 

• Enter the following details: 
o Attribute : Select the Attribute that has to be monitored from the Table Nodes 

listed in the tree. 
o High Threshold: Specify the high comparison value with derived gauge to send 

notification. 
o Low Threshold : Specify the low comparison value with derived gauge to send 

notification. 
o Granularity period : Specify the Time interval for observing the attribute value.  

The default time interval is 1000 milliseconds. 

• Click OK to add the entry to the table. 
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Using API  
 

A Table Monitor can also be created by adding the relevant code directly in the generated main 
file inside registerJMXServices method.  The following code snippet  creates a Table Monitor 
for monitoring the table column "ADiskCapacity" of the AdiskTable. The attribute is monitored 
every 5 seconds. The start() method is used to start the Table monitor service. 
 

import com.adventnet.services.monitor.TableMonitor;  
TableMonitor tm_0 = new TableMonitor();  
name = 
"Services:type=TableMonitor,name=TableMonitor_0"; 
tm_0.setObservedObject(new 
ObjectName("AdventNetJMXAgent:type=AdiskTableExt"));  
tm_0.setObservedAttribute("AdiskCapacity");  
tm_0.setObservedColumn("AdiskEntry","Integer ");  
tm_0.setGranularityPeriod(5000);  
tm_0.setThresholds(new Integer (10),new Integer (0));  
server.registerMBean(tm_0, new ObjectName(name));  
server.addNotificationListener(new 
ObjectName(name),notifImpl,notifImpl,(new Object())); 
tm_0.start();   

 
18.6 Monitor Notification 
 
Monitor notifications contain the following, 

• notification Type 

• name of the observed MBean 

• name of the observed attribute 

• notification time-stamp 

• notification message 
Using this information, listeners know which MBean triggered an event, and they do not need to access 
the MBean before taking the appropriate action.  
 
18.7 Running the Example 
 
Please refer to the Monitor Example present in the <Agent Toolkit Home>/example/jmx/monitor 
directory. This is a simple example to illustrate the usage of illustrate the usage of Monitor MBeans.  It 
uses the String Monitor MBean for monitoring the attribute of a Standard MBean. 
 
The Readme.html file explains the usage of the example and the steps involved in running the example . 
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19.0 Using Query Expressions 
 

 
19.1 Query Expressions : An Overview  
19.2 Classes and Interfaces Defined for Developing Query Expressions  
19.3 Example  

 
 
19.1 Query Expressions : An Overview 
 
The MBeans registered with the MBean server can be retrieved using queryMBeans method.  Using 
Object name you can filter the MBeans according to its type. Using Query expression you can further filter 
the MBeans according to its attribute values. 
 
A Query expression is the user-defined criteria for filtering MBeans based on the attribute values. If query 
method does not find any MBean with the given condition and/or if MBeans do not satisfy the given query 
expression, the returned set will not contain any element. Querying and filtering are actually performed by 
the MBean server itself, not by a separate MBean.  
 
For example, a filter could select all the MBeans whose object name contains "MyMBeans" while a Query 
Expression in tandem with the filter would get all the MBeans whose ObjectName contains "MyMBeans" 
and attribute named color is equal to "red". The result of a query operation is a list of MBean object 
names, which can then be used in other management requests.  
 
19.2 Classes and Interfaces Defined for Developing Query Expressions 

• The QueryExp interface identifies objects that are complete query expressions. These objects 
can be used in a query or composed to form more complex queries. 
 
The ValueExp and StringValueExp interfaces identify objects that represent numeric and string 
values, respectively, for placing constraints on attribute values. 

• The AttributeValueExp interface identifies objects that represent the attribute involved in a 
constraint. 

• The Query class supports the construction of the query. It contains static methods that return the 
appropriate QueryExp and ValueExp objects. 

In practice, users do not instantiate the ValueExp and QueryExp implementation classes directly. Instead, 
they rely on the methods of the Query class to return the values and expressions, composing them 
together to form the final query expression. The methods of the MBeanServer interface that perform 
queries are: 

• queryMBeans(ObjectName name, QueryExp query) - Returns a Set containing object 
instances (object name and class name pairs) for MBeans matching the name and query. 

• queryNames(ObjectName name, QueryExp query) - Returns a Set containing object names 
for  MBeans matching the name and query. 

19.3 An Example 
 
Let us assume an agent is generated for AGENT-SAMPLE-MIB with default settings given in JMX 
Compiler. The object name of agentSystem would be 
AdventNetJMXAgent:type=AgentSystemInstrumentExt.  
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To filter the MBeans which has an attribute "AgentAvailMemory" where the attribute value is equal to 
1000 : 
 

• For the first constraint, define an AttributeValueExp as follows : 
AttributeValueExp at1 = Query.attr("AgentAvailMemory"); 
It takes care of filtering the mbeans which has an attribute "AgentAvailMemory". Here it is 
AdventNetJMXAgent:type =AgentSystemInstrumentExt.  
  

• For the second constraint, define an ValueExp as follows : 
ValueExp v1 = Query.value(1000);  
Using the above expressions, QueryExp is defined as follows:  
QueryExp exp1 = Query.eq(at1,v1);  
ObjectName objectName = new ObjectName("*:*");  
Set set = server.queryMBeans(objectName, exp1)  

 
This set will contain the MBean of agentSystem. 
 
In case of more condition statements, composition of calls can be constructed by arbitrary nesting of 
constraints, as follows : 
QueryExp exp = Query.and(Query.gt(Query.attr("age"),Query.value(5)), Query.match(Query.attr("name"), 
Query.value("Smith")));  
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20.0 Using the Timer Service 
 

 
20.1 Timer Service : An Overview  
20.2 Adding Timer Notifications  
20.3 Removing Timer Notifications  
20.4 Starting and Stopping the Timer Service  
20.5 Running the Timer Example 

 
 
20.1 Timer Service: An Overview 
 
The Timer service enables you to send predefined notifications at specific dates and times. The 
notifications are sent to all objects registered to receive notifications emitted by the timer. An object is 
registered to receive notifications by adding a notification listener interface. The Timer class manages a 
list of dated notifications. A method is provided that allows you to add/remove notifications into/from the 
list. If any of the notifications in the list has dates that have passed, the timer either sends them 
immediately or discards them. This behavior is defined by setting the sendPastNotifications flag. 
 
The timer service can manage notifications in two different ways given below.  This behavior is defined by 
the parameters passed to the timer when the notification is added into the list of notifications. 

• Notifications that occur only once. 

• Notifications that are repeated with a defined period and/or number of occurrences. 
AdventNet Multi-Protocol agent has implemented timer as an MBean so that it may be registered in an 
agent and configured by remote applications. A specific subclass of the Notification class is defined for 
use by the timer MBeans. The following code snippet in the generated main file is used to register the 
timer service in the Multi-Protocol agent. 
 
20.2  Adding Timer Notifications 
 
Timer Notifications can be added to the Notification list, using the JMX Compiler UI or using API.  
 

20.2.1Using JMX Compiler UI  
 

Please follow the steps given below to add a Timer Notification to the Notification list.  

• Select Project -> Settings option. In the Settings Tree Structure, select JMX Standard 
Services -> Timer. This displays the dialog for the Timer Notification on the right side. 

• Select Send Past Notification option to send notification in the list that has the elapsed 
dates and time when the timer is started. 

• Select the Add option. This displays the Entry Parameters for the Timer Notification. 
Enter the following details: 

o Timer Type: The type may be either User Defined or Standard. The Standard 
Timer types are : 

 jmx.mbean.created 
 jmx.mbean.deleted 
 jmx.monitor.counter.threshold 

o Timer Message: Specify the notification message to be sent in the notification. 
o Date: Specify the Date and time at which the notification is to be sent. 
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o Time Interval: Specify the Time interval for sending the notification. The default 
time interval is 5000 milliseconds, which means, the notification will be sent every 
five seconds, starting from the Date and Time specified in the Date option. 

o No.of Occurences: The number of times the notification has to be sent during 
the time interval. The default number of occurrences is 5, which means, the 
notification will be sent five times, with a time interval of five seconds, starting 
from the Date and Time specified in the Date option. 

• Click the OK button to add the defined Notification to the Notification Table. 

20.2.2 Using API  
               

Timer Notifications are added to the list of Notifications  by adding the relevant code directly in the  
generated main file inside registerJMXServices method. The following code snippet  creates a 
Timer   Notification with the following attributes :                                       

                                  Timer Type : Register  
                                Timer Message :  Testing timer service  
                                Timer Date :    Apr 11,2002  
                                Timer Interval :   5 sec 
                                No. of Occurrence :   2     

javax.management.timer.Timer timer = new javax.management.timer.Timer();  
name = "Services:type=Timer"; 
server.registerMBean(timer,new ObjectName(name));    
server.addNotificationListener(new 
ObjectName("Services:type=Timer"),notifImpl,notifImpl,(new      Object()));    
timer.addNotification("Register","Testing timer service",new String(),new 
Date(1029244438000L) 
5000,2;  
timer.setSendPastNotifications(false); 
timer.start();  

 
After the above notification is registered, the Timer Service sends two notifications to all 
registered listeners with a time interval of five seconds from the date and time specified. The 
setSendPastNotifications() method, when set as true, sends notifications in the list that has 
elapsed  
dates and time.  The default value of this method is set as false.            
      

20.3 Removing Timer Notification 
 
Timer notifications are removed from the list of notifications using the timer's removeNotification() method, 
or removeNotifications() method, or removeAllNotifications() method. The Timer Notification contains an 
identifier, which uniquely identifies a notification in the timer’s list of notifications. Hence, Notifications can 
be removed either by passing its Id or by passing its Type. 

• The removeNotification(integer) method takes the notification identifier as parameter and 
removes the corresponding notification from the list. If the specified notification identifier does not 
correspond to any notifications in the list, the methods returns an Error. 

• The removeNotifications(type) method takes the notification type as parameter and removes 
the corresponding notification from the list. If the specified notification identifier/type does not 
correspond to any notifications in the list, the method returns an Error. 

• The timer's removeAllNotifications() method empties the timer's list of notifications. 
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20.4 Starting and Stopping the Timer Service  
 
The timer is started using the timer Start() method and stopped using the Stop() method. If the list of 
notifications is empty when the timer is started, the timer waits for a notification to be added.  
 
You can determine whether the timer is running or not by invoking the timer method IsActive(). This 
method returns true, if the timer is running.  
 
20.5 Running the Timer Example 
 
The Timer Example is present in the <Agent Toolkit Home>/example/jmx/timer directory. This is a 
simple example to illustrate the usage of Timer MBeans. Timer MBeans are used to send notifications at 
specific dates and times.  
 
The Readme.html file  explains the usage of the example and the steps involved in running the example. 
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21.0 Using the Relation Service 
 

 
21.1 Relation Service : An Overview 
21.2 Terms used in Relation Service  
21.3 Defining Relations  
21.4 Defining Role Information  
21.5 Defining Relation Types  
21.6 Creating Relations  
21.7 Relation Service Notifications  
21.8 Operations of the Relation Service  

 
 
21.1 Relation Service : An Overview 
 
Relation Service allows to define a model for relations between MBeans. A Relation is an user defined 
association between MBeans in specified roles. The javax.management.relation package contains 
classes  used for constructing an object  that represents a relation. It also contains the Relation Service,  
which centralizes all operations on relations in an agent.  
 
With the help of Relation Service, users can create, update, and remove relations. The Relation Service 
can also perform queries on all the relations to find related MBeans. 
 
The Relation Service itself is registered as a StandardMBean with the MBeanServer, therefore enabling 
the Relation Service remotely Manageable. The relation service exposes an attribute called Active that is 
false until its MBean is registered with the MBean server. All  the operations that handle relation or role 
MBeans, either directly or indirectly, will throw an exception when the service is not active. 
 
21.2 Terms used in Relation Service 
 
Role : A named category of functionality that is performed by an MBean. A role describes the MBean 
objects that perform that role and is implemented by the Role class. 
 
Role Information: Information about the role such as the name of the role, minimum and maximum 
number of MBeans that are allowed to perform that role. Role information is implemented by the RoleInfo 
class. 
 
Relation type: Metadata that describes the relationships between RoleInfo objects. The Relation Type 
interface provides information about the relation type, such as the name of the relation type and the 
various roles that make up that type. 
 
Relation: An instance of a relation type. Metadata describing the relationship between MBeans (i.e., the 
relation type) provides the constraints on the relation that allow the relation service to be used to ensure 
that the relation remains consistent at all times. Once a relation has been instantiated, it must remain 
consistent, or the relation service will throw an exception.  
 
21.3 Defining Relations 
 
A Relation is defined by a Relation Type that provides information about the roles it contains, such as 
their multiplicity and the class name of the MBeans satisfying the role.  A set of one or more roles defines 
a relation type. The relation type is a template for all relation instances that wish to associate MBeans 
representing its roles. The term "relation" means a specific instance of a relation that associates existing 
MBeans according to the roles in its defining relation type.  
Defining relations involves the following steps :  
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• Defining Role Information 

• Defining Relation Types 

• Creating Relations 
Example, we can say that Students and Class are roles. Students represent the students of a class. This 
belongs to an MBean class. Class represents the class to which a student belongs, which is of another 
MBean class. We might define a relation type containing these two roles and call it Student Management:  
 
Simple use-case for the example:  

1. The Management registers a student in a Class. The class already has 24 students. A check is 
done and it is determined that this class is allowed accommodate minimum 10 students and 
maximum 25 students. So, the student is registered.  

2. The Management decides to registers one more student to this class. As they have defined the 
number of students to be minimum 10 and maximum 25, and they are trying to add a twenty 
sixth, they are not allowed to add the extra student. 

21.4 Defining Role Information 
 
The first step involved in defining relations is to represent information about the roles.  The role 
information is represented by the RoleInfo class. In our example, students and class are roles.  You 
have to provide the following information about the roles:  

• A name string . The name can be any string that is manipulated by the Java String class  It will be 
used to retrieve the corresponding MBeans when accessing a relation instance. 

• The MBean Class name for this role. 

• Read-write permissions. The read-write permissions apply to all of the MBeans in the role, since 
the value of a role is read or written as a complete list. The default is both readable and writeable. 

• The minimum and maximum number of MBeans required for this role to be fulfilled (the default is 
1..1). 

• A description string (the default is a null string). 
To build an array of RoleInfo objects that are intended to define a relation type, you need to define a valid 
set of roles. All role names must be unique within the array, and none of the array’s elements should be 
null. Also, the minimum and maximum cardinalities must define a range of at least one integer. 
 
21.5 Defining Relation Types 
 
After defining the role information, the next step in defining Relations is to define a Relation Type.  This 
can be done by associating a name for the relation type with a non-empty array of RoleInfo objects.  
 
The method createRelationType() in the Relation Service class is used to create a relation type 
(RelationTypeSupport object) with given role information (provided by the RoleInfo objects), and adds it in 
the Relation Service.  
 

public void createRelationType(java.lang.String theRelTypeName, 
RoleInfo[] theRoleInfoArray) throws 
java.lang.IllegalArgumentException, InvalidRelationTypeException 

 
The relation type name given by the caller must be unique among all relation type names already created 
in the relation service. Relations refer to this name to define their type, and the service verifies that the 
roles of the relation match the role information in this type.  
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The Relation Service class provides methods for managing the list of relation types it stores. The 
removeRelationType removes the type’s definition from the relation service and also removes all relation 
instances of this type.  
 
21.6 Creating Relations 
 
After defining role information and relation types, the next step is to create a relation. A relation is a set of 
roles, which fulfills all the role information of the relation type. The Role object contains a role name and 
value, which is the list of MBeans that fulfills the role. The RoleList object contains the set of roles used 
when setting a relation or getting its role values.  
 
In order to create a relation, you must provide a set of roles whose values will initialize the relation 
correctly. The createRelation method creates a simple relation (represented by a RelationSupport 
object) of given relation type, and adds it in the Relation Service. Roles are initialized according to the 
role list provided in parameter. A RelationNotification, with type RELATION_BASIC_CREATION, is sent.  
 
The createRelation method raises an exception, if the provided roles do not fulfill the specified relation 
type. 
 

public void createRelation(java.lang.String theRelId, 
java.lang.String theRelTypeName, 
RoleList theRoleList) 
throws RelationServiceNotRegisteredException, 
java.lang.IllegalArgumentException, 
RoleNotFoundException, 
InvalidRelationIdException, 
RelationTypeNotFoundException, 
InvalidRoleValueException 

 
The corresponding removeRelation method is also exposed for management operations. Removing a 
relation means that you can no longer access it through the relation service, and the isRelation operation 
returns false when given its relation identifier. 
 
21.7 Relation Service Notifications 
 
The Relation Service class implements the NotificationBroadcaster by extending 
NotificationBroadcasterSupport to send notifications when a relation is removed from it.  It implements the 
NotificationListener interface to be able to receive notifications concerning unregistration of MBeans 
referenced in relation roles and relation MBeans. 
The Relation Service sends a Notification to all the listeners, in the following cases : 

• A new relation is created 

• An existing relation is updated 

• A relation is removed 

21.8 Operations of the Relation Service 
 
The relation service supports to provide the following operations, in addition to creating and removing 
relation types and instances. The methods for the same are available in the Relation Service class.  

• Retrieves the MBeans associated to given one in a relation. 

• Retrieves the relations where a given MBean is referenced. 

• Returns the relation IDs for relations of the given type. 

• Returns the relation IDs for relations of the given type. 
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• Retrieves names of all known relation types. 

• Retrieves MBeans referenced in the various roles of the relation. 

• Returns name of associated relation type for the given relation. 

• Retrieves role value for given role name in the given relation. 

• Retrieves the number of MBeans currently referenced in the given role. 

• Retrieves role info for given role of a given relation type. 

• Retrieves list of role information (RoleInfo objects) of a given relation type. 

• Retrieves values of roles with given names in the given relation. 

• Sends a notification for a relation creation, a relation removal, and a role update in the given 
relation. 
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22.0 Writing Custom Protocol Adaptors for the Multi-Protocol 
agent  
 

 
22.1 Overview  
22.2 AdventNet Adaptor Framework  
22.3 Creating a Custom Protocol Adaptor  
22.4 Methods To Be Implemented in the Abstract Adaptor Class  
22.5 Limitations  

 
 
22.1 Overview 
 
Protocol adaptors provide a view of an agent and its MBeans through a different protocol.  They receive 
the protocol messages, for example, an SNMP PDU/TL1 Command/ HTTP request etc., and convert 
them into a single Java API call on the MBean Server. The MBean Server invokes the methods on the 
Common Instrumentation. The view of the agent and the range of possible requests depend upon the 
given protocol.  
 
All  the protocol-specific conversion intelligence, for example converting an SNMP PDU to a Java Method 
call on the MBean Server lies within the Adapters built for the specific protocol. For example, AdventNet  
provides an HTML adaptor, which presents the agent and its MBeans as HTML pages viewable in any 
Web browser. This mapping of the protocol information to the respective MBeans will be handled within 
the Adapters.  In general, a protocol adaptor tries to map the elements of the multi-protocol architecture 
into the structures provided by the given protocol. 
 
The Multi-Protocol agent framework allows to add protocol adaptors/connectors to the framework without 
disturbing the instrumentation done earlier. It provides APIs to access the MBean (instrumentation) 
information which can be used by the  user defined protocol adaptor to be added to the framework. Also 
this newly developed protocol adaptor can also be added to the agent on the fly using MLet  
(Management Applet) service, thus ensuring the dynamic behavior, a key factor for network management.  
 
The following diagram explains the concept of "Instrument Once Access With Any Protocol", using 
Multi-Protocol agent framework.  
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This document aims at providing a brief understanding of the existing AdventNet Adaptor framework and 
how to integrate a new Adaptor based on the AdventNet Framework. 
 
22.2 AdventNet Adaptor Framework 
 
The following is a pictorial representation of the Adapter Framework provided by AdventNet.  
 

 
 
The AdventNet Multi-Protocol agent supports SNMP, HTTP, and TL1 adaptors . All the Adapters extend 
from a base class called the Abstract Adaptor class. This Abstract Adaptor defines the core methods that 
are common to all the Adapters. 
 
In AdventNet architecture, the adaptors themselves are MBeans and hence, the adaptors themselves can 
be managed at run time. Following the AdventNet framework for adaptors, you can write your own 
Adaptor MBean, which can be registered with the MBean Server like all the other Adaptors. 
 
22.3 Creating a Custom Protocol Adaptor 
 
To write a new protocol adaptor for the AdventNet Multi-Protocol agent, you have to extend the Abstract 
Adaptor Class and implement certain methods available in this class. This  class abstracts the common 
behavior of all Adaptors. All protocol adaptors must extend this class .  
 
For example, if you have a Q3 protocol implementation ready, i.e.,an API that can process the Q3 
message formats, you can extend the Abstract Adaptor class and write a Q3 adapter which will define the 
mapping for the Q3 message to map to a particular MBean in the MBean Server.  
 
When a Q3 request comes in, the Q3 adapter looks up the mapping table, identifies the corresponding 
MBean  in the MBean Server, invokes the method on it and processes the return value and converts it 
into a  Q3 response, and sends it back.  
 
22.4 Methods To Be Implemented in the  Abstract Adaptor Class 
 
To create a custom protocol adaptor, the following methods  available in the Abstract Adaptor class have 
to be implemented.  

• bind() 
 
This method is used to bind the Adaptor to a Naming service . Those adaptors that need not bind 
to a Naming Service may provide a blank implementation. 

protected abstract void bind() 
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• destroyAdaptor() 
 
This method is used to kill the adaptor and release all its resources. 

protected abstract void destroyAdaptor() 

• InstantiateAdaptor() 
 
Must be implemented by the adaptor and should be used to instantiate itself. If the Adaptor 
instantiation fails, it must throw InstantiationException.  

protected abstract void instantiateAdaptor() 
throws java.lang.InstantiationException 

• unbind() 
 
This method is used to unbind the Adaptor from a naming service. Adaptors that do not make use 
of naming service may provide a blank implementation.  

protected abstract void unbind() 

 
22.5 Limitations 
   
Due to limitations of the chosen protocol, adaptors have the following limitations:  

• Not all data types are necessarily supported. 

• Not all management requests are necessarily supported, as some requests may rely on 
unsupported data types. 

• Notifications from a broadcaster MBean may not be supported. 

• A given protocol adaptor may require private data structures or helper MBeans in  order to 
respond to requests. 
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23.0 Packaging the Multi-Protocol agent 
 

 
23 1 Overview 
23.2 Jars Required for Packaging the Multi-Protocol agent 
23.3 Package Agent  

 
 
23.1 Overview 
 
Once the Multi-Protocol agent is deployed, it is ready for packaging. Please follow the steps given in this 
section to know how to package a Multi-Protocol agent. 
 
23.2 Jars Required for Packaging the Multi-Protocol agent 
 
The jars required for packaging a Multi-Protocol agent are given below:  

• For Multi-Protocol Agent (in general) 

o The compiled class files generated by the JMX Compiler in the output directory. 

o xmojo.jar 

o crimson.jar 

o jaxp.jar 

o xalan.jar 

o AdventNetAgentRuntimeUtilities.jar 

o AdventNetJmxAgent.jar 

o AdventNetAgentUtilities.jar 

o AdventNetLogging.jar 

Along with these, the following jars should be available for the multi-protocol agent to run in the below 
said adaptors:  

• For SNMP Adaptor 

o AdventNetSnmp.jar 

o AdventNetSnmpAgent.jar 

• For TL1 Adaptor 

o AdventNetTL1.jar 

o AdventNetTL1Agent.jar 

• For HTML Adaptor 

o servlet.jar 

o webserver.jar 

o AdventNetAgentWCF.jar 
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23.3 Running the Agent in Any Environment 
 
The option Package Agent  in Build Menu of the JMX Compiler, when selected ,  

• copies the required jars for running the agent from <Agent Toolkit Home>/jars directory to the 
./jmxprojects/<projectName>/agent/bin/jars directory.  

• creates a mibs folder under ./jmxprojects/<projectName>  and copies the MIB file used in the 
project. 

• creates an external files folder under ./jmxprojects/<projectName> and copies any external files 
used in the project. 

This makes the agent self-contained and it can be used as an independent project.  
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24.0 Multi-Protocol agent : FAQs 
 

• JMX Compiler 
  

• Multi-Protocol Agent  
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24.1 JMX Compiler 
1. What is JMX Compiler? 
2. How do I know what  the current project is? 
3. How do I know the properties of the current project ? 
4. How can I do a selected nodes code generation ?  
5. I combined three MIBs (for example MIB1, MIB2 and MIB3)  in one project. Do I have to create a 

separate project for a different MIB?  
6. How do I specify storage types for different  nodes ? 
7. How can I make Workspace opened previously open up each time I start the JMX Compiler ?  
8. How can I specify my preferred HTML browser ? 
9. I had assumed that when new stubs code is generated and the "Merge with previous Stubs" 

option is set that the existing code that we add to each function under "Fill up your stuffs here" 
would be retained. Instead the functions are empty. Is this intended? How about adding a start 
and end marker to each function indicating where code can be added and retained on generation 
of a new stubs file?  

10. Is there a way to improve the actual response time of the agent ?  
11. Can I use my own MIBs for generating source from the JMX Compiler or do I have to use the 

AdventNet Mib Editor to create a Mib ? 
12. I am not able to start my Agent both from the command line and from the JMX Compiler? What 

could be the reasons? 
13. We need to use database storage for our agent. But when I right click on a scalar group, 

"Database" is not enabled, instead Text File is selected by default. Is it a compulsion ? 
1. What is JMX Compiler?  
 
The JMX Compiler is a tool which provides an integrated environment to generate java source code for 
developing a Multi-Protocol agent. It takes the MIB file as input and based on the MIB generates the 
necessary java files. The generated code will be based on the Model MBeans specified by JMX 
specification. The code thus generated can be compiled and tested without any modifications. The user 
gets the default values for the parameters of the Multi-Protocol agent. 
 
The generated code can be instrumented with the help of built in editor of the JMX Compiler and thus 
make the Agent respond as required by the user.  Code generation provides a way to use common 
instrumentation on the agent and supports multiple protocols like SNMP, HTTP, RMI, CORBA, HTML and 
TL1 for management.  
 
One can also compile the generated code and test the developed agent by using the test tools provided 
with the toolkit. The JMX Compiler also helps the user in organizing the Multi-Protocol agent projects in a 
project workspace. A project workspace can contain multiple projects.  
 
2.  How do I know what the current project is?  
 
The project name displayed in the title bar of the JMX Compiler refers to your current project or select 
Project -> Properties from the Menu bar of the JMX Compiler to display  the properties of the current 
project. 
 

AdventNet Inc. 126



Multi-Protocol Agent 

3.  How do I know the properties of the current project ?  
 
To know  the current project properties, select the Project -> Project Properties from the Menu bar of 
the JMX Compiler. It will display the project properties like project name, directory name,  loaded MIBs 
etc. 
 
4.  How can I do a selected nodes code generation ?  
 
To do a selected nodes code generation,  

• Select the nodes in the MIB tree for which code is to be generated, right-click and select "Add to 
list". The node is added to the Selected nodes tree. 

• Select Build -> Generate Source -> Selected Nodes option. 
 
5. I combined three MIBs(for example MIB1, MIB2 and MIB3)  in one project. Do I have to create a 
separate project for a different MIB?  
 
You can create only one agent per project. But the agent you create can implement any number of MIBs. 
This can be done by doing a selected nodes code generation by adding  the MIB Module Nodes of all 
MIBs to be implemented by the agent, to the selected nodes list and generating code. 
 
6. How do I specify storage types for different  nodes ?  
 
To specify storage types for different nodes,  

• Right-click on the node in the MIB tree and select the required storage type from the options 
provided.  (or) 

• Specify the required storage option in the Project -> Settings -> Source code generation -> 
Storage Model dialog. 

 
7. How can I make Workspace opened previously open up each time I start the JMX Compiler ?  
 
In Edit -> Preferences dialog of the JMX Compiler, select Workspace and check the option "Open last 
opened workspace on startup". This will make the workspace opened previously open up each time you 
start the JMX Compiler.  
 
8. How can I specify my preferred HTML browser ?  
 
In Edit -> Preferences dialog of the JMX Compiler, select the Web Browser option and specify the 
preferred HTML Browser path. The JMX Compiler will open the HTML browser as per specified in the Edit 
-> Preferences dialog. If it fails it tries to open the same using the systems default browser. So specifying 
the browser path in Edit-> Preferences will open up with the preferred browser.  
 
9. I had assumed that when new stubs code is generated and the "Merge with previous Stubs" 
option is set , the existing code that we add to each function under "Fill up your stuffs here" 
would be retained. Instead the functions are empty. Is this intended? How about adding a start 
and end marker to each function indicating where code can be added and retained on generation 
of a new stubs file?  
 
In the current version of the Agent Toolkit if you add your code between the tags 
 
/* User code starts here */ 
/* User code ends here */  
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those statements will be preserved on regeneration of the source file. You can add your code at any 
place in the generated source files (instrument, handler files) with above mentioned tags.  
 
10. Is there a way to improve the actual response time of the agent ?  
 
To improve the actual response time of the agent,  set the debug option as DISABLED, regenerate 
source , compile and try. This should improve the response time of the agent. 
 
11. Can I use my own MIBs for generating source from the JMX Compiler or do I have to use the 
AdventNet MIB Editor to create a MIB ?  
 
No, you don't have to create MIBs using the MIB Editor. MIBs created by other sources can also be used 
to generate code in the JMX Compiler.  
 
12. I am not able to start my Agent both from the command line and from the JMX Compiler? What 
could be the reasons?  
 
Possible Reasons, 

• The port required by the agent is in use 

• The Agent is trying to connect to a port between1-1024 which is reserved for standard services 
and for which the administration privilege is required. 

13. We need to use database storage for our agent. But when I right click on a scalar group, 
"Database" is not enabled, instead Text File is selected by default. Is it a compulsion ?  
 
Database is supported only for table nodes in the MIB.  In the case of a scalar object the data to be 
stored is just one value per scalar object unlike tables which can have many rows. But if this is a must, 
you can easily implement by going through the code generated for tables and using it for the scalars also. 
You can also use "Runtime Memory" if you do not want to use Text File as a storage mechanism. 
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24.2 Multi-Protocol Agent 
 

1. What are the development and test tools used in the development and testing of the AdventNet 
Multi-Protocol agent ? 

2. What are MBeans?  
3. What are Attributes and Operations?  
4. Is there any kind of authentication system in a Multi-Protocol agent? Can you authenticate with 

user name and password?  
5. Do the adaptors handle the whole authentication process, or are some steps handled by the 

MBean Server? 
6. Does AdventNet Multi-Protocol agent deal with restricting/limiting access to MBeans based on an 

authentication/authorization?  
7. Does Adventnet have a master subagent architecture ? If so, can a subagent be a normal SNMP 

agent from any company ? Can a subagent be an MBean ?  
8. Is it possible to register an MBean from a remote URL? Is it possible to monitor its attributes and 

perform GET and SET operations on this Mbean?  
9. How can I configure Monitor service using JMX Compiler ? 
10. Can I define one MIB file, but implement the MIB variables in different MBeans ? How do I do that 

?  
11. Can an MBean handle both SNMP and non-SNMP attributes? For example, I have an MBean 

with 10 attributes. I want to expose 3 of them to SNMP, at the same time expose all 10 of them to 
other protocol. 

12. Does Adventnet have a discussion forum for this product ? 
13. Currently, I'm implementing the User Storage Model as provided by the JmxTableModelListener 

interface. I noticed that this interface is meant for representing MIB tables. Is there also a way 
(another interface for example) to represent simple scalar fields in the MIB? How can I do that? 

14. I'm using only the implementation of the RMI from SUN, and not the JMX. So, I would like to 
make a client (on the agent side) based on MBeans connect to a Sun RMI server (at the 
managed application side). And also the opposite, make a Sun RMI client connect to an MBean 
Server. Is it possible, or do I have any restrictions on it ? 

15. I've a question about the DiscoveryService.  It is not clear to me to what value can I set the 
multicast group.  Default is 225.225.225.225, I suppose this is to all hosts on the network . To 
what value should I change this if I want to discover agents only on the  localhost ?  

16. How do I link two Mbeans in two different machines? Do I need an Mbean Server for each 
machine? 

17. Could you please clarify the implementation of Monitor and Timer in JMX ?  
18. What is SSL and can it be configured in JMX Compiler ? 
19. Can I write my own Protocol Adaptor and add it to the MBean Server ?  
20. Why is it that the SNMP Data types are mapped to Java data types in  the generated XML files ? 
21. Are adaptors and connectors refer to the same or stand for their own meanings ? 
22. Can multi-protocol agent server instrument an application on a different JVM or machine, 

including registering/deregistering and starting/stopping that remote application ? 
23. When multi-protocol agent server crashes, does the restart of the server require to restart all the 

other applications that were being managed earlier ?  
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24. Does AdventNet support a true SNMP adaptor that allows the monitoring of existing MBeans via 
SNMP ?  

25. We have a distributed system with one master agent and several subagents located at different 
CPUs. This system isto handle many resources and listeners to these resources, and it is 
important that the notifications (which will be many every second) are filtered out at the 
subagents.  Please let me know  what AdventNet can do for me ? 

26. If I stop and start the subAgent should I need to restart the Cascading Service ? 
27. The AdventNet Multi-Protocol agent supports Cascader, JMX-SNMP Proxy and SNMP Proxy. 

Can you provide comparison between these?  
28. I would like to implement an agent that does not keep the data to monitor in memory, but gets it 

from different locations whenever it receives an SNMP Get request .  Is there a way to support 
tables without having them created in the agent's memory ? 

29. Which version of JMX specification does XMOJO support? 
30. What are the services that are provided by AdventNet using XMOJO JMX implementation? 

1. What are the development and test tools used in the development and testing of the Multi-
protocol Agent ? 
 
The JMX Compiler tool provides an integrated environment to generate java source code for developing 
a Multi-Protocol agent. It takes the MIB file as input and based on the MIB, it generates the necessary 
Java files. The generated code will be based on the Model MBeans specified by JMX specification. The 
generated code can be compiled and tested without any modifications. The user gets the default values 
for the parameters of the Multi-Protocol agent. 
 
The generated code can be instrumented with the help of built-in editor of the JMX Compiler and can 
make the Agent respond as required by the user.  Code generation provides a way to use common 
instrumentation on the agent and supports multiple protocols such as SNMP, HTTP, RMI, CORBA, 
HTML, and TL1 for management.  
 
The MBean Browser is a tool provided by the Agent Toolkit in order to test the Multi-Protocol agent for 
various RPC  protocols. The user can view and operate on the data  about the managed device available 
through the Multi-Protocol agent. For  accessing the data, the Multi-Protocol agent has to be queried and 
this is done with the help of MBean browser. Currently,  the protocols supported by Bean Browser are 
 RMI, IIOP, and HTTP.  
 
The mbean browser uses the client-side API provided for accessing the MBeans through the connectors 
(RMI, HTTP, or Corba Connectors) at the server side.  
 
The MIB Browser can be used to test the Multi-Protocol agent using SNMP. 
 
The TL1 Browser can be used to test the TL1 agent using TL1.  
 
2. What  are MBeans?  
 
A Managed Bean or MBean in short  is a Java object that implements specific interfaces and conforms to 
certain design patterns. MBeans encapsulate manageable objects as attributes and operations through 
their public methods and follow the design patterns for exposing them to management applications. The 
different types of MBeans supported by the AdventNet Multi-Protocol agent are,  

• Standard MBeans 

• Dynamic MBeans 

• Model MBeans 
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3.  What are Attributes and Operations?  
 
Attributes are fields or properties of the MBean which are in its management interface. Attributes are 
always accessed via method calls on the object that owns them. For readable attributes, there is a getter 
method to read the attributes value. For writeable attributes, there is a setter method to allow the attribute 
value to be updated. information about the description and the values of the MBean.  An attribute which 
has a read-write access can be modified by the user. 
 
Operations are the actions that a JMX manageable resource makes available to management 
applications. These actions can be any computation which the resource wishes to expose, and they can 
also return a value. 
 
4. Is there any kind of authentication system in a Multi-Protocol agent? Can you authenticate with 
user name and password?  
 
Yes, the AdventNet Multi-Protocol agent provides the option to authenticate the users before allowing 
them to access the agent information. The authentication is based on user names and password.  
 
5. Do the adaptors handle the whole authentication process, or are some steps handled by the 
MBean Server?  
 
The Authentication process is handled by the adaptors themselves. 
 
6.  Does AdventNet Multi-Protocol agent deal with restricting/limiting access to MBeans based on 
an authentication /authorization ?  
 
The AdventNet Multi-Protocol agent has implemented the View-Based Authorization Service that will help 
you  restrict /limit access to MBeans based on user Authentication.  
 
The implementation of this service is based on a user Authentication.  The user authentication is not 
common across all the adaptors but depends on the adaptor implementation. A configuration is made 
available based on the user and an associated context is attached with each user.  
 
Each user is configured for a particular view that is allowed for him and this view determines the access 
for that particular User.  The granularity level for this configuration can be extended till the methods that 
are accessible by the User on a particular MBean. This configuration is basically XML based and 
supports wild card pattern matching.  
 
Apart from the above, this service in itself is implemented as an MBean, so that remote management of 
the configuration can be effected without restarting the Agent. This gives the flexibility to add , delete, and 
modify users and their configuration at run time. 
 
7. Does Adventnet have a master subagent architecture ? If so, can a subagent be a normal SNMP 
agent from any company ? Can a subagent be an MBean ?  
 
Yes, AdventNet Supports Master - SubAgent architecture. 
 
Case I : If you have a pure legacy SNMPAgent , a JMX Proxy agent can be created to expose this agent  
through multiple protocols. For this, you just have to select an option in the Code generation and the 
instrumentation will also be generated. The proxying will be done purely through SNMP.   Please refer to 
the topic "Accessing existing SNMP Agents through multiple protocols using JMX " for more information. 
 
Case II :  In case if you want to have the SubAgent as an MBean registered in a different MBeanServer, 
then  you can make use of the Cascader Service to achieve Master - SubAgent architecture. Using the 
Cascader Service, you can avail a SubAgent MBean at the Master Agent. The cascader service supports 
three protocols RMI/CORBA/HTTP. Please refer to the topic "Master Subagent architecture in JMX" , to 
know more about adding subagent entries to the Cascader Table.  
 

AdventNet Inc. 131



Multi-Protocol Agent 

8. Is it possible to register an MBean from a remote URL? Is it possible to monitor its attributes 
and perform GET and SET operations on this Mbean?  
 
Yes,it is possible to register an MBean from a remote URL. This can be done using the MLet service. The 
Management Applet (MLet) service allows you to instantiate and register an MBean from a remote URL 
with the MBean server.  Please refer to the topic, "Loading MBeans dynamically using MLet service" for 
more information.  
 
9.  How can I configure Monitor service using JMX Compiler ?  
 
The JMX Compiler provides UI to create Counter Monitor, String Monitor, and Gauge Monitor. Please 
refer tothe topic, "Monitoring the MBean Attributes"  to configure the same in JMX Compiler.  
 
10.  Can I define one MIB file, but implement the MIB variables in different MBeans ? How do I do 
that ?  
 
Yes , it is possible. You just have to define a MIB File , give it as input to the JMX Compiler .  It  generates 
MBeans for each group in the MIB. As an example, you can try generating an agent for a Sample MIB 
provided with the toolkit.  
 
11. Can an MBean handle both SNMP and non-SNMP attributes ? For example, I have an MBean 
with 10 attributes. I want to expose 3 of them to SNMP, at the same time expose all 10 of them to 
other protocol.  
 
Yes, it is possible. An MBean can have both SNMP and non-SNMP attributes.  The SNMP details of the 
attribute are specified in the XML  file for Model MBeans. If the XML does not have SNMP details for a 
particular attribute, it will not be exposed via SNMP but will still be available through other Protocols.  
 
12. Does AdventNet have a discussion forum for this product ?  
 
You can contact agent-support@adventnet.com. Our developers will be eager to answer all your 
questions.   
 
13.  Currently, I'm implementing the User Storage Model as provided by the 
JmxTableModelListener interface. I noticed that this interface is meant for representing MIB 
tables. Is there also a way (another interface for example) to represent simple scalar fields in the 
MIB? How can I do that?  
 
The JmxTableModelListener interface is given to overcome a shortcoming in JMX Model.  The JMX 
model captures the entire rows of a table inside a Tabular Data, which is a potential memory issue with 
tables having a huge number of rows. Also, the data would be redundant in the memory as well as the 
persistent storage( for example, database). 
 
By using this interface, the GET on the server will actually be transferred to the interface methods on the 
underlying Java object implementing this interface through Reflection, thereby not bringing up the data to 
memory.  
 
But for Scalars,  which is going to have a single state value at any point of time, this might not be needed 
as there will not be huge chunks of data causing memory problems.  Even if we provide an interface, 
additional reflection method calls will be done than those done by the server directly. 
 
14. I'm using only the implementation of the RMI from SUN, and not the JMX. So, I would like to 
make a client (on the agent side) based on MBeans connect to a Sun RMI server (at the managed 
application side). And also the opposite, make a Sun RMI client connect to an MBean Server. Is it 
possible, or do I have any restrictions on it?  
 
If you use Sun RMI instead of JMX RMI, you will not have any issues using a Sun RMI client.  
 

AdventNet Inc. 132



Multi-Protocol Agent 

15.  I've a question about the Discovery Service.  It is not clear to me to what value can  I set the 
multicast group.  Default is 225.225.225.0, I suppose this is to all hosts on the network.  To what 
value should I change this if I want to discover agents only on the  localhost?  
 
You need not have to modify the multicast Group value at all. If you want to discover agent only on 
localhost, then you have to do a slight change in your code of the discovery client. 
 
Modify the below line 
DiscoveryEvent event = client.discoverJMXAgents(); to 
DiscoveryEvent event = client.discoverJMXAgents("localhost");  
 
You can use the machine name also,  if you want to discover the Multi-Protocol agents running on any 
particular machine.  
 
16.  How do I link two MBeans in two different machines? Do I need an MBean Server for each 
machine ?  
 
MBeanServer needs to be deployed on both the machines and the MBeans registered respectively. But in 
this case, Cascader service helps you to attain the Master - Sub Agent architecture  in the Multi-Protocol 
agent.  
 
17.  Could you please clarify the implementation of Monitor and Timer in JMX ?  
 
Monitors are service MBeans specified by the JMX specification to monitor attribute values of  MBeans 
over a period of time. JMX spec specifies different monitors based on the data type of the attribute of 
MBean that is being monitored. Monitors work based on Threshold comparison and sends out 
Notifications to the interested Managers about the crossing of Thresholds.  
 
Timers are service MBeans that allow the Multi-Protocol agent to send Notifications at specified interval. 
Timer can be configured with a list of notifications with the time of emission of these notifications. At the 
specified time, these notifications are emitted.  
 
18. What is SSL and can it be configured in JMX Compiler ?  
 
SSL refers to the Secured Socket Layer protocol,  which provides authenticated and encrypted 
communication between clients and servers.  To configure SSL support for the HTTP Agent, please refer 
to SSL Parameters.  
 
19.  Can I write my own Protocol Adaptor and add it to the MBean Server ?  
 
Following the AdventNet framework for adaptors, you can write your own Adaptor MBean, which can be 
registered with the MBeanServer like all the other Adaptors.  Please refer to the topic "Writing custom 
protocol Adaptors for the Multi-Protocol agent" for more information.  
 
20. Why is it that the SNMP Data types are mapped to Java data types in  the generated XML files?  
 
The wrapper classes SnmpString, SnmpInt, and SnmpCounter64 are specific to SNMP.  The generated 
XML file is common to all the adaptors.  Only if the data types are of Java types, there not be any problem 
while exposing through other adaptor. 
 
That is why Data types are mapped to Java data types in the generated XML files. 
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21. Do adaptors and connectors refer to the same or do they stand for their own meanings ?  
 
There is a difference between adaptors and connectors.  
 
A connector consists of two parts , one part on the server side and one on the client side.  The transport 
of data occurs through a given protocol between the two sides . AdventNet provides connectors for RMI , 
CORBA, and the HTTP. It provides client-side APIs for the above connectors.  
 
An Adaptor exists only on the server side . It acts as  the interface for the MBeanServer to receive the 
messages from any client in any protocol that can be understood by the respective adaptor. For example, 
SNMP adaptor is  one such adaptor provided by AdventNet. It can be accessed through any of the SNMP 
Managers and does not require any specific client-side implementations.  
 
22. Can multi-protocol agent server instrument  an application on a different JVM or machine, 
including registering/deregistering and starting /stopping that remote application ?  
 
This is absolutely possible in JMX.  RMI will be used in passing down the MBeans of the  remote 
application in  a different JVM to the MBean Server of the Multi-Protocol agent. The management 
interface of the remote application should be exposed through RMI. 
 
23. When multi-protocol agent server crashes, does the restart of the server require to restart all 
the other applications that were being managed earlier ?  
 
This is not mandatory . Once the JMX server restarts , it has to connect to the applications managed and 
get the management interface ( MBeans) for the applications. 
 
24. Does AdventNet support a true SNMP adaptor that allows the monitoring of existing MBeans 
via SNMP?  
 
Agent Toolkit supports SNMP Adaptor  for the management of existing MBeans via SNMP. The  
generated model MBeans are only to facilitate the user who develops MBeans from scratch and needs 
SNMP support.  
 
25.  We have a distributed system with one master agent and several subagents located at 
different CPUs. This system is to handle many resources and listeners to these resources, and it 
is important that the notifications (which will be many every second) are filtered out at the 
subagents.  Please let me know what AdventNet can do for me ? 
 
The Cascading Service acts as a listener for Notifications from the SubAgent server with the help of the 
Connector clients . When an MBean registers, the Cascader receives this notification and registers the 
mirror with the Cascading agent's MBeanServer. AdventNet  Agent Toolkit provides you with a reliable 
Cascading Service . Notifications can be filtered by specifying the Notification Filter to the Cascading 
service. 
 
26. If I stop and start the subAgent should I need to restart the Cascading Service ?  
 
Yes, the cascading service should be restarted.  
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27. The AdventNet Multi-Protocol agent supports Cascader, JMX-SNMP Proxy and SNMP Proxy. 
Can you provide comparison between these? 
 

S.No. Type 
Communication 

protocol between 
Master Agent & 

Subagent 

Communication 
protocol between 
Manager& Master 

Agent 

Protocol supported in 
Subagent 

1 Cascader Service RMI , CORBA or 
HTTP 

All protocols 
(SNMP, RMI, 
CORBA, HTTP, 
HTML, TL1) 

The subagent must be a 
Multi-Protocol agent and 
must have the protocol 
which is specified in 
Cascader service. Other 
protocols are optional. 

2 JMX-SNMP Proxy SNMP 

All protocols 
(SNMP, RMI, 
CORBA, HTTP, 
HTML, TL1) 

The subagent must be a 
SNMP standalone agent 
or Multi-Protocol agent 
with SNMP support. 

3 SNMP Proxy SNMP Only SNMP 

The subagent must be a 
SNMP standalone agent 
or Multi-Protocol agent 
with SNMP support. 

 
28.  I would like to implement an agent that does not keep the data to monitor in memory, but gets 
it from different locations whenever it receives an SNMP Get request .  Is there a way to support 
tables without having them created in the agent's memory ?  
 
The JmxTableModelListener Interface is implemented to handle this type of  user storage models . This 
interface is used for handling tables in JMX when you need the choice of handling the table entries rather 
than the Multi-Protocol agent holding them in memory. Please refer to the topic " 5.10  External storage of 
data for Tables"  to know more about the implementation.  
 
29. Which version of JMX specification does XMOJO support? 
 
XMOJO supports 1.0 version of JMX specification. 
 
30. What are the services that are provided by AdventNet using XMOJO JMX implementation? 
 
AdventNet provides the following services: 

• Discovery Service 

• Cascader Service 

• Table Monitor Service 

• Authentication Service 
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25.0 Reference Implementation - Multi-Protocol agent 
 

 
• Introduction 

• Objectives of the tutorial 

• Getting Started with the Tutorial 

• Application Notes 

• Running and Testing the Application 
Steps Involved in Developing the RI using Agent Toolkit Java Edition  

• Created a MIB 

• Generated Code for the MIB 

• Implemented Scalars 

• Implemented Tables 

• Implemented JMX Notifications 
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Introduction 
 
AdventNet Agent Toolkit is a rapid prototyping and development tool used for building cross platform Java 
based Multi-Protocol agents. It addition to building Multi-Protocol agents, the toolkit also supports the 
development of Standalone SNMP and TL1 Agents.  This tutorial is organized to demonstrate the 
complete development process of implementing a JMX management solution . The Product architecture 
of AdventNet Multi-Protocol agent is given below for your reference . It gives you an overview of the 
development and test tools used in building Multi-Protocol agents and the multi-protocol architecture. 
 

 
• The MIB Editor creates a MIB. 

• Taking the MIB as the input the JMX Compiler tool generates and compiles java code for that 
MIB. The generated code will be based on the Model MBeans specified by JMX specification. 

• The Multi-Protocol agent created  can be managed through SNMP, RMI, CORBA, HTTP, TL1, 
and HTML adaptors. 
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Objectives of the Tutorial 
 
The intention of this tutorial is to make you familiar with the features supported by AdventNet Agent 
Toolkit for Multi-Protocol Agents.  The power of the tools present in the toolkit and the rich agent features 
are illustrated in this tutorial by developing a Reference Implementation Agent for a Simple application. 
With this implementation, you can view the statistics of the application and also configure them from a 
remote place using a manager application. (ie) the agent exposes the application data to the manager 
through this implementation. After reading this tutorial you will be able to  

• Create a MIB using the MIB Editor 

• Generate and compile the code for the MIBs created, using the JMX Compiler. The generated 
code will be based on the Model MBeans specified by JMX specification. 

• Instrument Scalars created in the MIB. 

• Instrument Tables using the UserStorageModel approach. 

• Implement JMX Notification. 
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Getting Started with the Tutorial 
 

 
• Agent Toolkit Java Edition Product Installation 

• Help documentation for the RI 

• Application Specification 
 

 
This tutorial leads you through the development of dynamic Multi-Protocol agents using the framework 
and components provided by AdventNet Agent Toolkit.  It is aimed at OEM who wish to instrument their 
objects to make them JMX manageable and developers of Multi-Protocol agents. The pre-requisite of this 
tutorial would be reasonable knowledge in Java programming and JMX technology. 
 
Agent Toolkit Java Edition  Product Installation 
 
To run the reference implementation and use the tools specified in this tutorial, AdventNet Agent Toolkit 
Java Edition, must be installed in your machine.  Before reading this tutorial, you should be familiar with 
the tools (like MIB Editor, JMX Compiler etc.,). For information on these tools, refer Agent Toolkit Java 
Edition Product Documentation. The documentation is also available online ( http://www.adventnet.com ) 
 
HELP Documentation for the RI 
   
To start with, please refer the "Application Notes" section and directly move on to the steps involved in 
running the application and testing the same. The steps have been covered in the section  "Running and 
Testing the application".  
To know how this Reference Implementation was developed, go through the "Steps Involved in 
Developing the RI" section. This will also give a brief introduction about the application that we have 
implemented for this tutorial. 
 
The "Creating a MIB" and "Generating Code" section provides explanation for creation of a simple 
Agent, starting from the definition of a MIB till compilation of the code. Other sections like Implementing 
Scalars, Tables and Traps talks about the features supported by the toolkit. On following these steps 
you can implement the features required for your application and the Agent will respond with the 
implementation values on request (not the default values).  
 
To have detailed explanation on the terms explained here please refer the Building Multi-Protocol 
agents section of the AdventNet Agent Toolkit Java Edition, Product Help Documentation. 
 
Application Specification 
 
Application Version Shopping Cart Application, 1.0 
Agent Toolkit Version Agent Toolkit Java Edition 6 

Tools Used MIB Editor, JMX Compiler, MIB Browser,TL1 
Browser, MBean Browser 

Platform Specific Requirements No special requirements 
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Application Notes 
 
This section of the tutorial, talks about the Shopping Cart application which we are trying to make it JMX 
manageable. The Shopping Cart application bundled along with the toolkit is present in <Agent Toolkit 
Home>/reference/jmx directory.  
 
About Shopping Cart 
 
Shopping Cart is basically an application used for ordering items in a shop. The items as per this 
reference implementation are "Pets".  Four pets namely : Parrot, Dog, Cat and fish are available in the 
shop and to place orders for these pets the Shopping Cart application can be used.  
 
Treat yourself as a customer and the Shop Keeper has allowed you to place orders through this 
application. The Shopping Cart application gets started via the Agent. To know more about starting the 
Agent/application  please go through "Running and Testing the Application".  
 
The first step toward Building the Agent is to define the resources required for the Agent. Based on the 
requirements the resources are identified as follows : -  

• Pet Name. 

• Unit Price of the Pet. 

• Quantity of the Pets. 

• Total Amount of the Pet based on the Quantity. 

• Total Stock available for a Particular Pet. 

• Total Pets ordered. 

• Total Price for the Pets ordered. 

Having identified these details, grouping has to be done. They can be classified as 
follows :  
 
Table  
 
The following details can be presented in the form of a Table as they have details related to a particular 
variable : The Pet. Hence the Pet Name can be made as the index column.  
 

Pet Name.  Unit Price of 
the Pet. 

Quantity of the 
Pets. 

Total Amount of 
the Pet based on 

the Quantity. 

Total Stock 
available for a 
Particular Pet. 

     
     
 
Scalar Group  
 
The total amount of the pet based on the quantity ordered and total pets ordered can be represented as 
two scalar variables.  
 
Using these details the MIB Module is defined.  
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Running and Testing the Application 
 

 

• Introduction  

• Starting the Agent and Application  

• Testing the Agent 

 
 
Introduction 
 
This section of the tutorial deals with Starting the Agent and the Shopping Cart Application and testing the 
Agent using the Manager tools bundled with Agent Toolkit.  
 
Starting the Agent and Application 
 
Please follow the steps given below to run the Agent.  This will also start the Shopping Cart Application. 

• Go to <Agent Toolkit Home>/reference/jmx/agent/bin directory from the command prompt. 

• Set the JAVA_HOME path in the run.bat/sh file 

• Now execute run.bat/.sh file. 

• This will start the Agent at the default port numbers specified below. 

• Once the Agent is started, the Shoppping Cart application UI also gets opened. 

• The different adaptors gets started in Multi-Protocol agent at the default port numbers listed 
below: 

o SNMP Adaptor  - 8001 

o RMI Adaptor   - 1099 

o CORBA Adaptor - 1050 

o HTTP Adaptor  - 8050 

o TL1 Adaptor - 9099 

Testing the Agent 
 
The Multi-Protocol agent is now running at the port numbers specified above.  The Shopping cart 
application is started and you can find the UI of the Shopping Cart Application displayed, as shown below:  
 
As seen in the above image, you will find the Item count which refers to the Total number of items 
ordered and the Total Price which refers to the total price of the items ordered. The UI will have all the 
details about the items sold and the rice of each item items.  To order an item, click on the Add button 
which displays a Pop Up window with a Combo Box listing the Pets that are available in the shop. 
Specifying the Pet and the Quantity required , a row can be added. On adding a Item, the Item count and 
Total Price columns will get updated. 

• Say for example, you add an entry in the Shopping Cart application as follows and click OK, 
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The entry gets added as below in the UI. 
 
 

 
 
 
Now in the Agent side, if you are going to do a query for the ShoppingCartTable in the ShoppingCartMib 
at any point of time, the value that is available in the Application will be received from the Agent.  As this 
is a Multiprotocol Agent you can access the Agent or the Application which are coupled, by means of the 
supported protocols (SNMP, HTTP, RMI, CORBA, TL1, HTML).      
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SNMP Testing 
 

The Shopping Cart Agent can be managed through SNMP Manager using the MIB Browser 
tool. This application creates a Manager environment.  

• Go to <Agent Toolkit Home>/bin directory and start the MIB Browser application using 
MibBrowser.bat/.sh file. 

• Load the ShoppingCartMib.mib from <Agent Toolkit Home>/mibs directory either 
using the Load MIB Module toolbar icon or File -> Load MIB menu bar. 

• A Load MIB Dialog opens up wherein you have to go to the URL using the Browse 
button. Various Load options are available. Let us leave them to be with the default 
settings. 

• Click OK and the MIB gets loaded. 

• Start querying the following groups : 

o ShoppingCartTable 

o shoppingCartSummary 

• The tables can be queried by doing a GET  /  GET_NEXT/SET request. 

• The Scalars can be queried with GET / GET-NEXT requests alone as they are read-only 
variables. 

• You can find the Agent responding with the values present in the shopping cart. For 
example, you add an entry using the Shopping Cart application UI for Pet Name "Parrot" 
and quantity ordered as 1. 

• On querying the Table columns from the MIB Browser, the following results gets 
displayed : 

o PetName : Parrot 

o Unit Price : $20 

o Quantity : 1 

• The scalar group responds with total Item Count as 1 and Price 20. 

• You can also add/modify/delete entries from the Manager (MIB browser ) . The UI 
application gets updated with these values. 

• Say, if the pet "dog" needs to be purchased, the ascii values of d-o-g has to be given as 
an instance in the MIB Browser object field and a Multivarbind request has to be sent to 
the Table column. This will add a row and the Shopping Cart Application UI also gets 
updated with these values. The screenshot given below depicts the scenario : 
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• Even if the row is deleted or modified in the Shopping Cart Application , the values are 

removed/modified accordingly when queried from MIB Browser. This happens vice versa 
also. 
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On Updating a row (Modifying the Quantity of a Pet that is required) or adding a row (ordering 
one more Pet that is available in the Shop) or deleting a Pet requirement, through the Agent, you 
will find that the Application gets updated with the requests.  
 
Thus, the Agent can be coupled easily with any of the Application data  which in turn can be 
remotely accessed and managed. To know more about the UserStorageModel instrumentation 
part have a look at the Instrumenting Tables section. This will give you a clear idea about how 
to couple your Application and the Generated Agent. 
 
To know more on Testing the Agent using MIB Browser, please refer to Testing the Agent 
section in Building SNMP Agents of Product Help documentation.  

 
RMI/CORBA/HTTP Testing 

 
The Shopping Cart application can be managed through the RMI /CORBA/HTTP using MBean 
Browser. 

• Go to <Agent Toolkit Home>/bin directory and start the MBean Browser application 
using MBeanBrowser.bat/.sh file 

• Select "RMI Client" in the MBean browser and click Operations -> Connect.  It gets 
connected to the Multi-Protocol agent using the RMI protocol. You can see the MBeans 
defined in the ShoppingCartMibModule listed in the left hand frame of the remote 
browser.  The MBeans are listed under the domain name ShoppingCartAgent. 

The following operations can be performed : 
 

GET/SET Scalar Attributes  
 

You can GET and SET scalar attribute values if the attribute is of type read-write.  For read only 
attributes, you can only get the values. In the Shopping Cart application, the scalar attributes 
TotalItemcount and TotalPrice are read only attributes and hence their values cannot be 
modified.   To access the Scalar attributes of the application,  

• Select Attributes for type=ShoppingCartSummaryInstrument. When this query is made, 
the Agent will fetch the value available with the application. You can also get the attribute 
values by selecting Operations for type=ShoppingCartSummaryInstrument. 

GET Table values 
 

Now, let us assume that we have ordered one quantity of each item using the Shopping Cart 
Application UI.  On the Agent side, if you are going to do a query for the ShoppingCartTable at 
any point of time, the value that is available in the Application will be received from the Agent.  

• To access the table values,  select Attributes for type=ShoppingCartTable. You will now 
find the values displayed as shown in the screen-shot below.  You can also get the 
attribute values by selecting Operations for type=ShoppingCartTable. 

Add / Modify / Delete Row 
 

The customer can also place an order through the Manager application (MBean Browser) by 
adding an entry using the Add Row option . The Modify Row option can be used to modify an 
existing entry.  The Delete Row option can be used to delete an existing item added by the user. 
These changes will get reflected in the ShoppingCartTable.  

 
Similarly you can access the value available in the application and add entries by selecting 
CORBA/HTTP client from the Client Menu. For example, access the scalar attribute values 
TotalItemCount and TotalPrice using HTTP client. You will find the values displayed as shown in 
the screen-shot below:  
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TL1 Testing 
 

The Shopping Cart application can be managed through the TL1 Adaptor using  TL1 Browser.   

• Go to <Agent Toolkit Home>/bin directory and start the TL1 Browser application using 
TL1Browser.bat/.sh file . To test the agent using TL1Adaptor, follow the steps given 
below: 

• Load  ShoppingCartMibModule.tcs file  which is under the tcs directory by selecting File -
> Load option . A dialog prompts for command set and data set file.  Select the Add 
option to browse and select the ShoppingCartMibModule.tcs file and 
ShoppingCartMibModule.dat file from the<Agent Toolkit Home>/tcs directory.  Click 
O.K to add it to the TL1 tree. 

• >Choose Operations -> Connect option in the Menu Bar.  Enter the Host Name and Port 
Number where the agent is running in the dialog box that appears. Click OK. Now,  you 
will be connected to the Agent. 

• The next step is to Authenticate into the TL1 Agent . To do this, load tl1security.tcs file 
as specified above from the <Agent Toolkit Home>/tcs directory to login to the TL1 
Agent. 

• Select the command ACT-USER  in the TL1 Security tree. The default user name and 
password for the Administrator are root and public respectively.   Hence, select ACT-
USER command and specify the user name as root in the AID block and the password 
(PID) public in the MPB block. 

• After entering the user name and password values send the input message by selecting 
the toolbar icon or by selecting Operations ->Send  from the menu bar.  Now,  you will be 
authenticated into the TL1 Agent. The following autonomous message will be sent by the 
Agent to notify the completion of authentication. 
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Now, select ShoppingCartMibModule.tcs file and expand the tree . The following operations can 
be performed on the ShoppingCartAgent using TL1 Browser. 

• Get Request for a Scalar Object 
 
To get the scalar values, select the command SHOPPINGCARTMIBMODULE-
ShoppingCartSummary listed in the tcs tree.  Now, send the input message by selecting 
the toolbar icon or by selecting Operations ->Send  from the menu bar.  You will find the 
response from the agent as shown in the screen-shot below: 

• Get Request for a column object in the Table 
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   To query a table object "unitCost" of the "ShoppingCartTable" for a given PetName (index), 

 
Select the object, SHOPPINGCARTMIBMODULE-ShoppingCartTable-unitCost from the Get 
Command of the TL1 tree.  To find the unit Cost of Fish, specify the Index value as "Fish"  in the 
Value field of the Message Payload block. Now, press the icon or choose the Operations -> 
Send from the menu bar. You will now find the index value added to the Input Message block. 
 
The Agent sends a response message with the unit Cost of Fish as shown in the screen shot 
below. 

 

 
 
• Set Table Values To send a set command for a table column object, "quantity" of 

"ShoppingCartTable" for a given PetName (index), 
 
Select the object, SHOPPINGCARTMIBMODULE-ShoppingCartTable-quantity from the Set 
Command of the TL1 tree. To change the quantity of fish ordered, specify the index value and the 
value to be set in the Value field of the message payload block as shown in screen-shot below. 
Now, press the send icon or choose the Operations -> Send from the menu bar.  
 
You will now find the index value and the set value added to the InputMessage.  The Agent sends 
a response message with the set value as shown in the screen shot below.  
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• Get All rows from the Table 
 
Select the object SHOPPINGCARTMIBMODULE-ShoppingCartTable from the GetALL Command 
of the TCS file . Now, press the send icon or choose the Operations -> Send from the menu bar. 
The Agent sends a response message with the values for all the rows of the table as is currently 
available with the application, as shown in the screen-shot below :  
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• Create a new row 
 
To create a new row in the ShoppingCartTable, 
 
Select the table object, SHOPPINGCARTMIBMODULE-ShoppingCartTable under the create 
command of the TL1 tree. In the message payload block, specify the index value of the new row 
to be created , for example, "Parrot" and the column values to be set in the new row separated by 
commas as shown in the screen-shot below.  Note :  Here, we assume that a row with index 
value "Parrot" does not already exist in the table. 
 
Press the send icon or choose the Operations -> Send from the menu bar.  You will now find the 
index value and the column values added to the InputMessage as shown in the screen-shot 
below. The Agent sends a response message for the new row created as seen in the response 
block. 

 
 
• Delete a row from the table 

 
To delete an existing row, from the ShoppingCartTable, 
 
Select the Table object, SHOPPINGCARTMIBMODULE-ShoppingCartTable under the delete 
command of the TL1 tree. 
 
In the message payload block, specify the index value of the table row to be deleted , for 
example, Dog  
 
Press the send icon or choose the Operations -> Send from the menu bar. You will now find the 
index value of the row to be deleted added to the Input Message block. The Agent sends a 
response message for the deleted row as shown in the screen shot below. You can repeat this 
operation for deleting any other row in the table by providing the correct index value of the row to 
be deleted.  
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HTML Testing 

 
The Shopping Cart application can be tested through the HTML Adaptor using  any Web 
Browser  for example Netscape, IE etc. 

• Start the Browser and specify the URL as : http://localhost:8030. The HTTP Console 
Login page is displayed. 

• Specify the User name and password for authentication and select Login. The default 
User Name is jmx and password is root. 

• On successful authentication, the JSP Home page is displayed. It has a left side tree 
view in which all the MBeans are grouped under their respective domains. These are the 
domain names with which the MBeans are registered in the MBean server. Clicking a 
domain, the MBeans registered under this domain are listed in the left side tree. 

• Select a Domain name, for example ShoppingCartAgent. MBeans in the selected 
domain are listed in a separate page. 

• MBeans are grouped under different domains.  Select the MBean whose attribute you 
want to view, for example ShoppingCartTableAttributes of tabular data type are 
displayed as a table . 

The following operations can be performed : 
 

Modify Row/Add Row/Delete Row :  
 

To modify a row, select the check box of the corresponding row and modify the value. For 
example, in the ShoppingCartTable, modify the quantity of Parrot purchased from 1 to 2 and 
select the Save button. The new values will be saved as shown in the screen-shot below:   
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New rows can be added using the New Row button at the bottom of the page. The Delete button 
can be used to delete a row from the table.  

 
Get Scalar Values  

 
The attributes of the selected scalar MBeans ShoppingCartSummaryInstrument are listed in 
table format with the following information: Attribute name, Attribute type, Attribute access, 
Attribute value,  and Attribute Description. Values of Read-Write attributes are presented in 
editable text field.  
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The JavaServer pages also allow you to perform operations on MBeans. If operations can be 
performed on an MBean, then the Operations button is displayed at the right-top corner of the 
the MBean attribute page. Clicking this button presents a page with the list of operations. 
Selecting an operations hyperlink displays the following information pertaining to the MBean 
operation:  

• Operation Name: The name of the MBean operation. 

• Description: Short description about the operation. 
Apart from these, SET operations are provided with text fields to specify the attribute values.  
Further chapters will discuss the implementation details of Scalar group and Tabular group.    
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Steps Involved in Developing the RI using Agent Toolkit  
 
Creating a MIB 
 

 
• Overview 

• Defining the ShoppingCart MIB Module 

• Defining the Scalar Group 

• Defining the Tabular Group and  

• Defining Notifications 
 

 
Overview 
 
Based on the resources discussed in Application Notes, the MIB has to be defined.  In this section, the 
steps involved in defining the MIB for the application is discussed. This will be the first step for developing 
a Multi-Protocol agent for the existing Shopping Cart application.  
 
AdventNet Agent Toolkit provides the tool "MibEditor" for defining SMIv1/v2 mibs. The application can be 
started from the Agent Toolkit launcher or from <Agent Toolkit Home>/bindirectory using the 
MibEditor.bat or MibEditor.sh file.  
 
We have defined a MIB module under which 3 groups exist. The basic work to land up with the  
"ShoppingCart" MIB module is :  

• Define the Shopping Cart MIB Module 

• Define the Scalar Group 

• Define the Tabular Group and 

• Define Notifications 

 

Note:  
1. To know more on defining trap type and notification type construct  please 

refer the Defining a MIB  section in the Building SNMP Agents section of 5.0 
Product Help documentation. 

2. Also refer the product document for defining the external index column. 
3. Please see the final MIB for the ShoppingCart application in <Agent Toolkit 

Home>/mibs directory.  

 
Defining the "ShoppingCart" MIB Module 
 
To define the Shopping Cart MIB Module the following steps need to be followed. 

• Start the MibEditor tool. 

• Select File -> Create Mib Module menu or toolbar icon to create the mib module. 

• A dialog box prompts asking to fill in the details of the mib. For this example, the following details 
have to be used. 

• Module name - ShoppingCartMibModule 
• ModuleDirectory - mibs\ (by default). 
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• MIB Version - Choose SMIv2 for this case. 
• Root OID - enterprises (by default). 

• Click OK. 

• The ShoppingCartMibModule gets added to the left side MIB Tree view with a module identity 
under enterprises. 

• Select moduleidentity and right click on it to enable Modify option. 

• Click Modify that enables the Module Identity tab where again details of the Mib Module has to be 
specified. The following values are specified, 

• Module Identity - adventnet (this has to start in lower case letters) 
• Sub ID - Disabled. 
• Parent ID - Disabled. 
• Last-Updated  - Disabled. 
• Organization - AdventNet Inc., 
• Contact Info - agent-support@adventnet.com 
• Description - Reference Implementation 

• Now click "SaveNode". Ignore Revision, Revision Description details. This is required when any 
changes are need to be made in the MIB and maintained later. 

• The ShoppingCartModule mib can be seen in the left side frame of the MibEditor with adventnet 
below the enterprises key. Thus a new mib module is created. 

• Operations -> Add Node from the menu bar  (or) from the pop-up menu that appears on right click 
of the mouse (or)  by clicking on the toolbar icon. 

 

 

Note: As specified here, to add a new node any of the above said options can be used. 
These options are implied and hence can be used when you try to add a new node 
anywhere in the mib.  

• Select Object Identifier and a  tab  gets displayed  in  the right  frame. 

• Enter 

• The Object Identifier name as "shoppingCartModule". 
• Make sure that  the Parent node selected in the combo box is "adventnet". 
• Also fill the Sub ID no as 571. (i.e shoppingCartModule has an unique node for the 

enterprise named "adventnet") 

• Then Press Add To Module button  present below. The added "shoppingCartModule" gets 
displayed  under "adventnet" in the mib tree. 

• The next step is to define the 3 management objects under the Shopping Cart MIB module. To 
begin with, define the shoppingCartSummary group which has different scalars under it. 

Defining Scalars 
 
From the application resources explained in Application Notes section, you saw the "scalar" group 
information as totalItemCount and totalPrice. Hence a scalar group is defined in the MIB which contains 
scalar objects. (management objects which can hold only a single value).  

• Similar to the steps explained in the previous section (defining shoppingCartModule under 
adventnet) define an Object Identifier "shoppingCartSummary" under the shoppingCartModule 
node with id as "3" . The summary group gets created. 

• To add scalars under that group select "shoppingCartSummary" from  the MIB tree in the left 
frame and right click on it. Use Add  -> Scalar Object to add a scalar variable. 
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• The MIB tree in the left frame gets deactivated and all the possible constructs (depending on 
whether the MIB file is v1 or v2) which  can be added to the parent node gets activated in the 
wizard interface. 

• In the right side tab panel fill in the following details : 

• Object Type - totalItemCount 
• Sub ID - 1 
• Parent - shoppingCartSummary. 
• Syntax - Integer32 (Select from the combo-box items). 
• Max-Access - read-only. 
• Status - Current. 
• Description -  The total number of Pet items. 
• Reference - (optional) 
• Defval - Need not specify anything. 

• Then click on Add to Module button. The "totalItemCount" object gets added in the mib tree of 
left frame. 

• Similarly define the node "totalPrice" under the "shoppingCartSummary" node with id as 2. Now 
that the scalars are defined the next step would be define tables for the mib. 

Defining Tables 
   
Steps involved in defining the table :-  

• Use Add- > Table Object construct to add the table shoppingCartTable under 
shoppingCartModule group. 

• The OBJECT TYPE Table construct opens up with the following columns in the right side tab. Fill 
in the required details : 

• Object Type - shoppingCartTable 
• Sub ID - 2 
• Parent - shoppingCartModule 
• Max-Access - not-accessible 
• Status - current 
• Description - This Table contains information about the items purchased in the shopping 

cart. Use "..." button for adding the content. 
• Reference - Need not specify. 

• Click Add Table. 

• The Table gets listed in the right side frame itself. 

• Now to add the Table entry fill in the following details : 

• Object Type - shoppingCartEntry 
• SubID -1 
• Table - shoppingCartTable 
• Syntax - shoppingCartEntry 
• Max-Access - not-accessible 
• Status - current 
• Need not fill in Description, Reference and Index column. 

• Now Add Entry. 

• The ShoppingCartEntry gets listed below shoppingCartTable and the text-fields for adding 
column entries gets listed. 
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• Just fill in the details as given below to add the first column petName, 

• Object-Type - petName 
• Sub Id - 3. 
• Entry - ShoppingCartEntry 
• Index - Check the Index box. Now this column acts as the index column for the whole 

Table. 
• Syntax - DisplayString. 
• Max access - Not Accessible 
• Status - current 
• Description, Reference, Default values are optional. 

• Click "Add Column to Table". 
• The next column's Object-Type is "unitCost" . The syntax is "Integer32" with Max-Access 

"read-only" and Sub id "4". Index box need not be checked here. Finally, click Add Column to 
Table. 

• The next column's Object-Type is "quantity". The syntax is "Integer32" with Max-Access "read-
write" and Sub id "5". Index box need not be checked here. Finally, click Add Column to Table. 

• The next column's Object-Type is "listPrice" . The syntax is "Integer32" with Max-Access 
"read-only" and Sub id "6". Index box need not be checked here. Finally, click Add Column to 
Table. 

• The next column's Object-Type is "rowStatus". The syntax is "Row Status" with Max-Access 
"read-write" and Sub id "7". Index box need not be checked here. Finally, click Add Column to 
Table. 

• The Add to Module gets activated only when an index column is present. 

• Since the petName column is already made as the index column, this gets enabled in the 
beginning itself. Now Press Add To Module button . 

• The Table gets added in the mib tree under "shoppingCartModule". 

Defining Notifications 
 
"out of Stock" Notification.  
 
We have also defined a Notification group. Traps/Notifications are implemented in a manner such that 
Notifications get generated for a particular state of change in the Shopping Cart. The state of change can 
be an event happening in the application. Thus the notification implemented is,  

• outofStockNotification 
As per our case, the SNMP Agent which we are trying to develop has to send Notifications to Managers 
when the following occurs :  

• Stock count reaches 15: The maximum inventory level is 20 for each item and when any of the 
pet item's stock reaches 15 a Notification is generated to the Managers stating that the stock 
level is reducing. 

If this is the requirement, then we have to define a notification in the MIB (as it is of v2 type). It is very 
easy to define traps/notifications using MIB Editor. First, define the object group notification under the 
shoppingCartModule node with ID as 1.  
 
Then, to define the Notification Type construct, select shoppingCartModule and right-click on it. Use 
Add -> Notification Type pop-up menu.  The Notification Type construct tab gets enabled in the right.  

• The Notification Type is outofStockNotification 

• Sub ID is 1 
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• Parent Node is shoppingCartModule 

• Status is current 

• The Objects are "petName and Quantity". This object can be chosen using the Browse option 

• Fill in the other details if required 

• Finally press "Add to Module" which adds the notification construct under shoppingCartModule 
Thus the MIB is defined. 
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Generated Code for the MIB 
 

 
• Overview 

• Generating Stub Files 

• Compiling Stub Files 
 

 
Overview 
 
In the chapter given earlier you saw how to define a MIB for the Shopping Cart application.  In this 
chapter you will see how the stub/instrument files were generated for the defined ShoppingCartMIB. The 
JMX Compiler tool is used to generate stub files for a given MIB file. 
 
To know more about the options available in the JMX Compiler, please refer topic 5.0 Configuring the 
Multi-Protocol agent in the section Building Multi-Protocol agents. 
 
Generating Stub Files 
   
The following steps were performed for generating the stub/instrumentation files :  
 

Created a New Project 
• Start the JMX Compiler application from Agent Toolkit launcher or from <Agent Toolkit 

Home>/bin directory using JmxCompiler.sh or JmxCompiler.bat file. 

• The application opens up with the New Project tab. 

• Specify a workspace for your Project. By default it starts with workspace1. Lets take it to 
be the same. 

• Now, fill in the following details : 
o Name the Project : ShoppingCartAgent. 
o Location for the Project : As per our tutorial, it is <Agent Toolkit 

Home>\jmxprojects\ShoppingCartAgent. 
• And Click OK. 

• This creates a New Project. You can see ShoppingCartAgent.prj listed in the File View 
Tab. 

Loaded the ShoppingCart MIB 
 

The next step is to load the ShoppingCart MIB that was developed using MIB Editor application.  

• Load the ShoppingCartMib.mib that we defined, from <Agent Toolkit Home>/mibs 
directory by selecting the File  --> Load Mib menu from the menu bar or clicking the 
Load MIB module from toolbar icon . 

• The ShoppingCartMib gets automatically loaded in the MIB View tab and gets listed 
under Loaded MibModules. 

AdventNet Inc. 159



Multi-Protocol Agent 

Configured Agent  Settings  
 

Now you have to configure all the necessary settings for the Agent using the menus available.  

• Go to Project -> Settings menu from the menu bar of JMX Compiler application. 

• You get the settings tree listed on the right side frame. 

• Do the following changes leaving others to be as default : 
o Select  Source Code Generation -> Storage Model. On the right-side frame, you 

will find the storage options displayed.  Here, expand the MIB and select 
shoppingCartMeanTable and specify the storage type as User defined. 

o Select Source Code Generation -> General and specify the Package Name as 
refimpl.shoppingcart.jmx and Agent Name as ShoppingCartAgent 

Generated Stub files 
 

To generate code for the ShoppingCartMib, 

• Select the Build -> Generate Source option or the  generate icon on the toolbar, which 
generates source files corresponding to the ShoppingCartMib 

• The Debug window opens  and displays information about the generated source files 
under the projects directory. After the code generation, it says Code generation 
succeeded for project : ShoppingCartAgent 

• The files are generated in <Agent Toolkit 
Home>/jmxprojects/ShoppingCartAgent/agent/src directory. 

• You  can  also view the files generated for the ShoppingCartproject in the Fileview Tab of 
the WorkSpace dialog.  The main file will be generated in the name 
ShoppingCartAgent.java 

• The output and source directory are 
<Agent Toolkit Home>/reference/jmx/ShoppingCartAgent/agent/bin and <Agent 
Toolkit Home>/reference/jmx/ShoppingCartAgent/agent/src respectively. 

Files Generated 
 

The following files get generated for the shoppingCartMib.mib : 

• ShoppingCartTable.java 

• ShoppingCartEntry.java 

• ShoppingCartSummaryInstrument.java 

• ShoppingCartAgent.java 

• NotificationListenerImpl.java 
Explanation for the Table, Scalar and Trap files are provided in Implementing Tables, Scalars 
and Traps sections respectively.  

 
Main File  

 
The Main file (ShoppingCartAgent.java) takes care of all the registrations. The following code 
has been added in the Agent Main file to start the Shopping cart application.  This file has been 
instrumented for instantiating the Application Starter.  
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/* User code starts here */ 
// Starting shopping cart application  
ApplicationStarter appl = new ApplicationStarter(); 
   Thread appThread = new Thread(appl); 
   appThread.start(); 
 /* User code ends here */ 

 
This method is required for providing the Reference for the ShoppingCartApplication. 
 

/* User code starts here */ 
class ApplicationStarter implements Runnable{ 
public void run() 
{ 
ShoppingCartApplication frame = new 
ShoppingCartApplication(); 
ReferenceProvider.setShoppingCart(frame); 
frame.setVisible(true); 
} 
} 
/* User code ends here */ 

 
Reference Provider 

 
The file ReferenceProvider.java is an additional file created for the Shopping Cart application. 
The above code in the Main file provides  a reference to the ShoppingCartApplication. The 
instrumentation part in the scalar file and table file takes reference from this file.  

 
Compiling the Stub Files 
 
The next step is to compile the stub files to form a complete Agent. Selecting Build -> Compile Source 
menu from the menu bar will compile all the source files and form the Agent. On successful compilation a 
confirmation message saying that the code has been compiled successfully can be seen.  
 
The majority of work gets over here and now you can run the tutorial to test the Agent with default values. 
To run and test the Agent please refer to Running and Testing the Application. To know how the 
Shopping Cart application has been instrumented to return specific values on querying, please refer to 
the following sections : Implementing Scalars, Implementing Tables and Implementing Traps.  
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Implemented Scalars 
 

 
• Overview 

• Instrumentation 
 

 
Overview 
 
In the previous section you saw how the stub files are generated.  This section deals with the files 
generated for the scalar group and how they are instrumented. 
 
The file generated for the scalar group shoppingCartSummary is 
shoppingCartSummaryInstrument.java. The instrument file contains all the getter and setter methods 
for all the attributes in  the MBean . In this tutorial, the scalar attributes are totalItemCount and 
totalPrice .  
 
Instrumentation 
 
The extra code added for instrumentation inside the method getTotalItemCount() 
shoppingCartSummaryInstrument.java file is available in between the following tags: 
 
 /* User code starts here */  
 /* User code ends here */  
 

public Integer  getTotalItemCount() 
throws AgentException { 
// Fill up the stub with required processing 
 /* User code starts here */ 
com.adventnet.agent.application.shoppingcart.ShoppingCart 
shoppingCart = ReferenceProvider.getShoppingCart(); 
if(shoppingCart == null) 
throw new AgentException("null reference got", CommonUtils.GENERR); 
totalItemCount = new java.lang.Integer 
(shoppingCart.getTotalItemCount());  
/* User code ends here */  
return totalItemCount; }  

   
The instrumentation code has to be filled between these tags in order to support code merging when 
regenerated.  Note that totalItemCount and totalPrice are "read-only" variables defined in the MIB and 
hence does not provide SET methods to modify the variable values.  
 
When a get request is made from the manager for the scalar variable TotalItemcount,  

• The agent calls the getTotalItemcount() method of ShoppingCartSummaryInstrument object 

• Inside this method, the ShoppingCart object is obtained by calling the getShoppingCart() method 
of  Reference Provider object. 

• The required TotalItemCount of the shoppingCart application is retrieved using 
getTotalItemCount() of ShoppingCart object 

• The getTotalItemCount() of ShoppingCartSummaryInstrument object returns the value obtained 
from the ShoppingCart application. Hence, the Agent sends this response to the manager. 
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Implemented Tables 
 

 
• Overview  

• Instrumentation  

• To Get the First Entry in the Table 
• To Get the Entry for the Given  Row 
• To Get the Next Entry for the Given Row 
• To Add a Row to the Table 
• To Delete a Row from the Table 
• To Modify an Existing Row in the Table 
• To Return the Total Number of Rows in the Table 
• To Get All the Entries in the Table 

 
 
Overview 
 
In this chapter we are going to see how instrumentation is done for the tables using the User Storage 
Model.  The AdventNet Multi-Protocol agent supports storage of tabular data in text files, XML files, 
databases, and RAM.  In some cases,  tabular data may be held in some other form or stored externally 
in a different  place.  The JmxTableModelListener Interface is implemented to handle this type of  user 
storage models .  
 
To use the JmxTableModelListener, the XXXTable.java has to implement the 
com.adventnet.utils.jmx.JmxTableModelListener interface. This interface is used for handling tables in 
JMX when user needs the choice of handling the table entries rather than the Multi-Protocol agent holding 
them in memory.   
 
Instrumentation 
 
The file generated for the Table group ShoppingCartTable are,  

• ShoppingCartTable.java 
This file contains the methods for updating or retrieving the whole Table,  getting the first entry , 
getting the entry by passing the instance etc.  

• ShoppingCartEntry.java 
This file contains the getter and setter methods for petName , unitCost, quantity , listPrice .  The 
composite Data or a row in the table refers to a single table entry. 

As specified earlier in the code generation section, the storage option was specified as User Defined for 
the ShoppingCartTable of the shoppingCartMibModule.  Hence, the following code is generated in 
ShoppingCartTable.java  
 

public class ShoppingCartTable implements JmxTableModelListener 
 
With this, the ShoppingCartAgent gets initialized with User Storage Model and thus any request from the 
manager for that particular table is forwarded to the Interface implemented for this purpose. Data is 
retrieved from the table only when the request reaches the Agent  The interface, when initialized, calls the 
respective methods present in the interface.  These methods will be exposed to the MBeanServer 
through the ShoppingCartTable.xml file.  In this tutorial, we have instrumented  these methods , so that it 
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returns the required information from the Shopping Cart application.  Now, let us see how the methods 
present in the JmxTableModelListener interface are instrumented for this purpose.  
 
To Get the First Entry in the Table 
 
The getFirstEntry() method is used to get the first entry in the table.  This method will be called when a 
walk is done on a table. After calling the getFirstEntry(), the getNextEntry() will be called while doing a 
walk on a Table. The return type of this method is a CompositeData entry object. 
 
The following instrumentation is done inside this method:  
 

public CompositeData getFirstEntry() {  
java.util.List table = null; 
try { 
table = getShoppingCartCollection() 
} catch(Exception e1) { 
// TODO: logging 
return null; 
} 
if(table == null) { 
// TODO: logging 
return null; 
} 
com.adventnet.agent.application.shoppingcart.ShoppingItem shoppingItem 
= 
(com.adventnet.agent.application.shoppingcart.ShoppingItem)(table.get(
0)); 
ShoppingCartEntry tableEntry = new ShoppingCartEntry(shoppingItem); 
return makeCompositeData(tableEntry); 
} 

• The getShoppingCartCollection() which is defined in the ShoppingCartTable returns the  list of 
shopping items from the ShoppingCartApplication 

• In order to retrieve the first shopping item from this list, we use the table.get(0) method. 

• The method makeCompositeData() of the ShoppingCartTable  takes care of sending the 
corresponding entry  for this shopping item. 

To Get the Entry for the Given  Row (Identified by the Instance) 
 
The getEntry() method is used to get the entry for the given row, identified by the instance. This method 
will be called when a GET is done on a Table specifying the instance. It takes an Object array with index 
objects, which identify the row, as the parameter. It returns the CompositeData object of that instance. 
Each row in the table is a CompositeData object.  
 
The following instrumentation is done inside this method:  
 

public CompositeData getEntry(Object[] indexObjects) { 
com.adventnet.agent.application.shoppingcart.ShoppingItem 
shoppingItem = getRowObject(indexObjects); 
if(shoppingItem == null){ 
return null; 
} 
ShoppingCartEntry tableEntry = new ShoppingCartEntry(shoppingItem);
return makeCompositeData(tableEntry); 
} 
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• In the above instrumentation, inorder to retrieve the shopping item for the given 
instance(indexObjects) we use the getRowObject() method. 

• The method makeCompositeData() of the ShoppingCartTable takes care of sending the 
corresponding entry  for this shopping item. 

To Get the Next Entry for the Given Row (Identified by the Instance) 
 
The getNextEntry() method is used to get the next entry of the given row, identified by the instance.  This 
method will be called while doing a  walk on the Table, after calling the getFirstEntry().  It takes an 
Object array with index objects, which identify the row , as the parameter. It returns the CompositeData 
object of that instance. 
 
The following instrumentation is done inside this method: 
 

public CompositeData getNextEntry(Object[] indexObjects) {  
java.util.List table = null; 
try { 
table = getShoppingCartCollection(); 
} catch(Exception e1) { 
// TODO: logging 
return null; 
} 
if(table == null) { 
// TODO: logging 
return null; 
} 
int len = table.size(); 
for(int i=0; i<len; i++) { 
com.adventnet.agent.application.shoppingcart.ShoppingItem shoppingItem 
= 
(com.adventnet.agent.application.shoppingcart.ShoppingItem)(table.get(
i)); 
if(isIndexEqual(indexObjects, shoppingItem)) { 
try { 
ShoppingCartEntry tableEntry = new 
ShoppingCartEntry((com.adventnet.agent.application.shoppingcart. 
ShoppingItem)table.get(i+1)); 
return makeCompositeData(tableEntry); 
} catch(Exception ee) { 
// TODO: logging 
return null; 
} 
} 
} 
return null; 
}  
  

• In the above instrumentation, the getShoppingCartCollection() which is defined in the 
ShoppingCartTable returns the  list of shopping items from the ShoppingCartApplication 

• Using the for loop we are finding out the shopping item for the given index. We are getting the 
next shopping item by incrementing 1. 

• The method makeCompositeData() of the ShoppingCartTable takes care of sending the 
corresponding entry  for this shopping item. 
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To Add a Row to the Table  
 
The >addRow() method is used to add a row to the table. This method will be called when the manager is 
trying to add a row in the table.  This method takes the following parameters: The Object array with index 
objects, which identify the row, and the Composite data entry. 
 
The following instrumentation is done inside this method: 
 

public void addRow(Object[] indexObjects, CompositeData entry) 
throws Exception { 
if(isRowExists(indexObjects)) 
throw new AgentException("Row Already exists, 
CommonUtils.ROWCREATIONFAILED); 
ShoppingCartEntry tableEntry = makeEntry(indexObjects, entry); 
String petname = 
(java.lang.String)Utilities.convertStringToObject("java.lang.String
", entry.getDataItem("PetName").toString()); 
Integer qty = 
(java.lang.Integer)Utilities.convertStringToObject("java.lang.Integ
er", entry.getDataItem("Quantity").toString()); 
addItem(petname, qty); 
} 
 

• In the above instrumentation to add a new row, a verification is made if the entry already exists in 
the application using the isRowExists()method by passing the index object. 

• If the entry does not already exist in the application a new entry is created using the makeEntry() 
method passing the index objects and the entry as parameters. 

• By calling the addItem()of the ShoppingCartTable, the shopping item for the corresponding entry 
is created and added to the ShoppingCart Application. 

To Delete a Row from the Table  
 
The deleteRow() method is used a delete a row from the table. This method will be called when the 
manager is trying to delete a row from the table. This method takes the object array with index objects, 
which identifies the row, as its parameter. 
 
The following instrumentation is done inside this method:  
 

public void deleteRow(Object[] indexObjects) throws Exception { 
java.util.List table = getShoppingCartCollection(); 
for(int i=0; i<table.size(); i++) { 
com.adventnet.agent.application.shoppingcart.ShoppingItem shoppingItem 
= 
(com.adventnet.agent.application.shoppingcart.ShoppingItem)(table.get(
i)); 
if(isIndexEqual(indexObjects, shoppingItem)) { 
removeItem(shoppingItem.getPetName()); 
} 
} 
} 

• In the above instrumentation to delete an existing row,  we first get the list of shopping items by 
calling getShoppingCartCollection()method. 

• From the list, we find out the shopping item for the given instance and the same is removed using 
the removeItem()from the ShoppingCartApplicationTable. (ie) corresponding entry of the given 
instance is removed. 
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To Modify an Existing Row in the Table 
 
The modifyRow() method is used to modify the values of a row in the table.This method will be called 
when the manager is trying to modify a row in the table. This method takes the following parameters : The 
Object array with index objects, which identify the row,  and the Composite data entry. 
 
The following instrumentation is done inside this method: 
 

public void modifyRow(Object[] indexObjects, CompositeData entry) 
throws Exception {  
if(!isRowExists(indexObjects)) 
throw new AgentException("Row doesn't exists", 
CommonUtils.MODIFYROWNOTEXIST); 
com.adventnet.agent.application.shoppingcart.ShoppingItem 
shoppingItem = getRowObject(indexObjects); 
if(shoppingItem == null) 
return; 
String key = null; 
ShoppingCartEntry tableEntry = new ShoppingCartEntry(shoppingItem);
String petname = 
(java.lang.String)Utilities.convertStringToObject("java.lang.String
", entry.getDataItem("PetName").toString()); 
Integer qty = 
(java.lang.Integer)Utilities.convertStringToObject("java.lang.Integ
er", entry.getDataItem("Quantity").toString()); 
updateItem(petname, qty); 
}  

• In the above instrumentation to modify an an existing row, a verification is made if the entry  
exists in the application using the isRowExists()  method by passing the index object. 

• The shopping item for the given instance(indexObjects) is obtained using the getRowObject() 
method. 

• The values to be modified are modified in the composite data using the methods available in the 
Utlities object. 

• The updateItem() updates the values of the pet name and quantity in the 
ShoppingCartApplication. 

To Return the Total Number of Rows in the Table  
 
The totalRows() method is used to give the total number of rows in the table as an integer. The following 
instrumentation is done inside this method:  
 

public int totalRows() {  
java.util.List table = null; 
try { 
table = getShoppingCartCollection(); 
} catch(Exception e1) { 
// TODO: logging 
return 0; 
} 
if(table == null) { 
// TODO: logging 
return 0; 
} 
return table.size(); 
} 
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• The getShoppingCartCollection() which is defined in the ShoppingCartTable returns the  list of 
shopping items from the ShoppingCartApplication 

• The total rows in the table (i.e) the size of the list is obtained and returned. 

To Get Instances in the Table between given two index values  
 
The getEntries() method is used to get all the instances in the table between given two index values. It 
takes the startIndex and endIndex (both as int datatype) as the parameters and returns an ArrayList of 
instances in the table.  The HTML adaptor calls this method while viewing the entries in the table. The 
TL1Adaptor calls this method while doing a GETALL on the Table. 
 
The following instrumentation is done inside this method: 
 

public java.util.List getEntries(int startIndex, int endIndex) {  
java.util.List table = null; 
try { 
table = getShoppingCartCollection(); 
} catch(Exception e1) { 
// TODO: logging 
return new ArrayList(); 
} 
int i = startIndex - 1; 
ArrayList arrayList = new ArrayList((endIndex - startIndex)+1); 
while (i < endIndex) { 
try { 
Object[] instances = new Object[indexNames.length]; 
com.adventnet.agent.application.shoppingcart.ShoppingItem shoppingItem 
= 
(com.adventnet.agent.application.shoppingcart.ShoppingItem)(table.get(
i)); 
instances[0] = shoppingItem.getPetName(); 
if (!arrayList.add(instances)) { 
// TODO: logging 
return null; 
} 
i++; 
} catch(ArrayIndexOutOfBoundsException aiobe) { 
// TODO: logging 
return arrayList; 
} catch(Exception e) { 
// TODO: logging 
return arrayList; 
} 
} 
return arrayList; 
} 

 

• In the above instrumentation to get the table instances between the given range,  we first get the 
list of shopping items by calling getShoppingCartCollection() method. 

• An array list is created to store the instances. 

• Using the while loop we get the shopping item and its instance (pet name). This instance is added 
to the array list. This continues until it reaches the end index. 

• The created array list now containing the instances is returned 
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Implemented JMX Notifications 
 

 
• Overview 

• Requirement 

• Instrumentation 

• Viewing Notifications 
 

 
Overview 
 
Notifications are generated by an Agent to intimate the change of state of a particular variable in the 
Agent , to the Managers. In this Reference Implementation, Notification Type construct is defined for a 
variable and on any change of state of that variable, Notification is generated. Lets discuss in detail the 
implementation details of sending Notifications to the Managers from our shopping cart Agent.  
 
Requirement 
 
As per the Reference Implementation, the Agent has to send Notifications to the Managers when :  

• Inventory level exceeds 15 for every pet item. 
The maximum inventory level available for all the pet items is 20. Say for example, if the customer places 
an order for more than 15 for the pet Parrot, then a Notification is generated. This is done through the 
methods implemented in the java file generated for Traps.  
 
Instrumentation 
 
In the main file generated the following code snippet is added inside registerJmxServices method.  
Once this method is executed (ie) the thread is started, it will execute the run method of inventory monitor 
class which is defined inside as inner class in ShoppingCartAgent class  
 

InventoryMonitor inventoryMonitor = new InventoryMonitor(this, 
ShoppingCartTable);  
Thread invThread = new Thread(inventoryMonitor);  
invThread.start(); 

 
As long as the agent is alive, it will keep calling monitorAndSendNotif()method for every 10000 seconds, 
as given in the following code-snippet.  
 

public void run(){ 
while(true){  
monitorAndSendNotif(); 
try{ 
Thread.sleep(10000); 
}catch(InterruptedException e){ 
//e.printStackTrace(); 
} 
} 
} 
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• The monitorAndSendNotif()method first retrieves the inventory level of  the following pets : Parrot 
, Fist,Cat,Dog. 

• First it checks whether the inventory level of Parrot is less than 5. If it is less than five it calls the 
sendNotification() method passing the pets name (Parrot) and the inventory level of the Parrot. 

• This process is done for all the pets. 

public void { 
int parrotInv = Store.getInventoryLevel("Parrot").intValue(); 
int fishInv = Store.getInventoryLevel("Fish").intValue(); 
int catInv = Store.getInventoryLevel("Cat").intValue(); 
int dogInv = Store.getInventoryLevel("Dog").intValue(); 
try{ 
if (parrotInv < 5) { 
sendNotification("Parrot", new Integer(parrotInv)); 
// Uncommenting the following code snippet will increase 
// the stock Level by 10. 
/*if (parrotInv <= 2){ 
Store.increaseStock("Parrot", new Integer(10)); 
}*/ 
} 
if (fishInv < 5) { 
sendNotification("Fish", new Integer(fishInv)); 
/*if (fishInv <= 2){ 
Store.increaseStock("Fish", new Integer(10)); 
}*/ 
} 
if (catInv < 5) { 
sendNotification("Cat", new Integer(catInv)); 
/*if (catInv <= 2){ 
Store.increaseStock("Cat", new Integer(10)); 
}*/ 
} 
if (dogInv < 5) { 
sendNotification("Dog", new Integer(dogInv)); 
/*if (dogInv <= 2){ 
Store.increaseStock("Dog", new Integer(10)); 
}*/ 
} 
}catch(Exception e){ 
e.printStackTrace(); 
} 
} 

 
Here the Notification is defined with the following inputs:  

• Notification Type (outOfStockNotification) 

• Name of the MBean Class 

• Sequence Number 

• Time at which the notification is sent 

• Notification Message which specifies that the inventory level has fallen below the minimum level. 
NotificationBroadcaster of ShoppingCartTable is obtained and the same is used to send the notification 
by calling the sendNotification() passing the Notification which is defined above.  
 

public void sendNotification(String petName, Integer level) 
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throws AgentException { 
Notification notification = new 
Notification("com.adventnet.traps.outOfStockNotification", 
ShoppingCartTable.getClass().getName(), ++sequenceNumber, new 
Date().getTime(), new String(petName + " Inventory Level Went down 
to " + level)); 
try{ 
ModelMBeanNotificationBroadcaster notifBC= 
(ModelMBeanNotificationBroadcaster 
)agent.getNotifHandler(ShoppingCartTable); 
setUserDataForNotification(notification); 
notifBC.sendNotification(notification); 
} 
catch(Exception e) 
{ 
e.printStackTrace(); 
} 
} 

 
Viewing Notifications 
 
The Notification mechanism is designed to forward only notifications from registered MBeans on the 
agent side to proper listeners on the manager side.  

• To view the Notifications through RMI/CORBA/HTTP Adaptors, select the View -> Notification 
option or View Notification icon in the MBean Browser. 

• To view the Notifications through TL1 Adaptor, select the Autonomous Message Block in the 
TL1 Browser. 

• To view the Notifications through SNMP Adaptor, select View -> Trap Viewer option or Trap 
Viewer icon of the MIB Browser. Set the port to 8003 in Trap Viewer.  Click Start button.  The 
Notification emitted will be listed in the trap viewer . 
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26.0 Migration Guide for Multi-Protocol Agent 
 
This section will be helpful for users who are using Multi-Protocol agents in the earlier versions of Agent 
Toolkit Java Edition and now wish to migrate to the latest release of the Toolkit. The document explains 
how to migrate between 4.2 to 5.1.0 and 5.1.0 to 6.0.0 release. 
 
26.1 Migrating to Agent Toolkit 6.0.0 
 
The following change needs to be made while migrating from 5.1.0 to 6.0.0 
 
Modify the package structure: 
 
The package structure has been modified for certain imports. The following table depicts the changes in 
package structure in 6.0.0 compared to 5.1.0: 
 

Package Structure in 5.1.0 Package Structure in 6.0.0 
com.adventnet.agent.utilities.common.* com.adventnet.utilities.common.* 
com.adventnet.agent.utilities.xml.XMLIntender com.adventnet.utilities.xml.indenter.XMLIntender
com.adventnet.agent.logging com.adventnet.utilities.logging 
com.adventnet.agent.framework.xml com.adventnet.utilities.xml.sax 
com.adventnet.agent.utilities.xml com.adventnet.utilities.xml.dom 

 
Before generating the agent, you need to ensure that the latest package structure is followed. 
 
26.2 Migrating to Agent Toolkit 5.1.0 
   
The step by step procedure for migrating to release 5.1.0 is given below:  

• For easy migration, create a New Project with the JMX Compiler in 5.1.0 release product. 

• The source files for the new project will be generated under <Agent Toolkit 
Home>/jmxprojects/projectname/agent/src/ directory. 

• Remove all the generated files under this directory. 

• Move the source files of the agent developed using the previous release product and place them 
in the <Agent Toolkit Home>/jmxprojects/projectname/agent/src/ directory of the new project 
created using the latest release product. 

• Change the import statement as specified in "Package Structure Modified" section. 

• Modify the xml Location for all MBeans in the initialize( ) method of the agent main file. 

• If HtmlAdaptor is enabled, 

o Modify the location of HtmlNotif.ser file using htmladaptor.setLogFile() in the agent main 
file. 

• Then compile the Agent. 

• This will make your Agent work in 5.1.0 release. 
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26.3 Package Structure Modified 
 
The Package structure for certain imports have been modified and before generation the older import 
statements have to be commented and new import statements have to be added in the source files 
generated in the previous version product. Package structure have been changed for the following import 
:  
 

Import statement to be Commented Import statement to be Included 

import com.adventnet.common.agent.*; import 
com.adventnet.agent.utilities.common.* 

import com.adventnet.ssiparser.*; import com.adventnet.html.dynamic.*; 

import com.adventnet.utils.xml.*; import com.adventnet.agent.utilities.xml.*; 

import com.adventnet.clients.common.*; import com.adventnet.adaptors.clients.*; 

import com.adventnet.clients.rmi import com.adventnet.adaptors.clients.rmi 

import com.adventnet.clients.corba import com.adventnet.adaptors.clients.corba 

import com.adventnet.clients.http import com.adventnet.adaptors.clients.http 
 
26.4 Jars Replaced 
   
For easy migration, the latest jars have to be used instead of the existing jars. These jars are available in 
<Agent Toolkit Home>/jars directory of 5.1.0 release. The jars that have been changed:  
 
xmojo.jar has been replaced with  

• xmojo.jar 

• AdventNetJmxAgent.jar and 

• AdventNetAgentRuntimeUtilities.jar 

26.5 Adaptor Framework Changes 
 
One of the major features of this release is the enhancement of Adaptor and Client Framework. The 
existing Adaptor Framework has been completely revamped. The major changes are documented in this 
section to enable you to switch over to the new Framework easily. The following classes and interfaces 
have been renamed:  

• Adaptor Classes 
o Interface ServiceInfo has been renamed as Interface Adaptor. 
o Class SimpleAdaptor has been renamed as Class AbstractAdaptor. 

• Client Classes 
o Class  SimpleClient  has been renamed as Class  AbstractClient. 

26.6 Changes made to ServiceInfo interface : 
 

Interface ServiceInfo  Interface Adaptor  
isActive isActive 

stopService stopService throws IllegalStateException 

startService startService throws 
llegalStateException,Exception 

getAdaptorVersion getAdaptorVersion 
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Interface ServiceInfo  Interface Adaptor  
getProtocol getProtocol 

 getHost 

 getPort 

 getState 

 getStateInString 

 setPort(int) throws IllegalStateException 

 isSecure() 

 
getAdaptorObjectName()  
Note: This function was previously associated with 
the client. 

 enableAuthentication(boolean)throws 
UnsupportedOperationException 

 enableAuthorisation(boolean) throws 
UnsupportedOperationException 

 
26.7 Changes made to SimpleAdaptor class : 
 

SimpleAdaptor  
implements ServiceInfo  

AbstractAdaptor extends Thread  implements 
Adaptor,MBeanRegistration,NotificationBroadcaster,Serializable 

public isActive public isActive 

public stopService public synchronized  stopService() throws IllegalStateException 

public startService public synchronized  startService() throws IllegalStateException 

  public getHost 

  public getPort 

  public abstract getProtocol * 

  public getState 

  public getStateinString 

  public setPort throws IllegalStateException 

 public isSecure 

 public abstract enableAuthentication * 

  public abstract enableAuthorisation * 

 public getAdaptorVersion 

  public abstract getAdaptorObjectName * 

  public addNotificationListener 

 public removeNotificationListenet 

  public getNotificationInfo 

  public preRegister 

  public postRegister 
  public preDeregister 
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SimpleAdaptor  
implements ServiceInfo  

AbstractAdaptor extends Thread  implements 
Adaptor,MBeanRegistration,NotificationBroadcaster,Serializable 

  public postDeregister 

  protected abstract instantiateAdaptor() throws 
instantiationException * 

  protected abstract bind() * 

  protected abstract unbind() * 

  protected abstract processClientRequests * 

  protected abstract destroyAdaptor * 
 
* These methods need to be implemented by the adaptors. 
 
26.8 Changes made to ClientInfo Interface : 
 
The Client interface  extends from the MBeanServer instead of re-declaring them ( Hence the respective 
adaptors must implement de-serialize functions of the MBeanServer as well  ). 
 

Interface ClientInfo  Interface Client  
public interface ClientInfo public interface Client extends MBeanServer 

connect connect 

disconnect disconnect 

isConnectedWithAdaptor isConnectedWithAdaptor 

getAdaptorObjectName Moved to Adaptor 

getAdaptorVersion Moved to Adaptor 

enableHeartBeat enableHeartBeat 

isHeartBeatEnabled isHeartBeatEnabled 

getHeartBeatRate getHeartBeatRate 

setHeartBeatRate setHeartBeatRate 

addHeartBeatListener addHeartBeatListener 

removeHeartBeatListener removeHeartBeatListener 

MBeanServerFunctions derives it from the super interface 
MBeanServer 

 
26.9 Changes in SimpleClient class : 

• SimpleClient  is split into two classes  AbstractClient and ClientFactory 

• AbstractClient implements all the heartbeat functions 

Class Simple Client  Class AbstractClient  
createClient() Moved to  Class ClientFactory 

abstract connect abstract connect 

abstract disconnect abstract disconnect 

abstract isConnectedWithAdaptor abstract isConnectedWithAdaptor 
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abstract getAdaptorVersion -- 

abstract getAdaptorObjectName -- 

abstract enableHeartBeat enableHeartBeat(boolean flag) Note: Not 
abstract. 

abstract isHeartBeatEnabled isHeartBeatEnabled () 

abstract addHeartBeatListener synchronized addHeartBeatListener 

abstract  removeHeartBeatListener synchronized removeHeartBeatListener 

asbtract getHeartBeatRate getHeartBeatRate 

abstract setHeatBeatRate(int rate) setHeartBeatRate(int) 

  abstract sendHeartBeatEvent 

MBeanServerFunctions -- 
 
26.10 Changes in setMethod Argument types for Discovery Service 
 
If discovery service is enabled and setMutlicastPort and setTimetoLive methods are called, then the data 
type of the arguments should be changed from primitive 'int' to integer object, java.lang.integer. 
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